Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18
  1. #16
    Join Date
    December 2015
    Posts
    273
    Quote Originally Posted by dante696 View Post
    I brang up the topic up in our Meeting and we made a decision.

    PC Client 3.1.6 will be the minimum version that is needed to connect to server 3.1
    Same counts for released Android 3.1.6.1 and iOS Client 3.1.26.

    Edit
    Client 3.1.6 will not reject connecting to old server.
    Unreleased client 3.1.7 also connects to the old server but with a little chance that this may change when a beta was released (no release date yet).
    Thank you very much. This is clearly the most sane solution. I mean that way all 3.1 servers will have a ground base with all features that are available atm. Be it user-, admin- or securityfeatures.

  2. #17
    Join Date
    June 2008
    Posts
    18,513
    Quote Originally Posted by Dimos View Post
    This is clearly the most sane solution.
    We don't fully agree to this.

    Forcing user to use a version isn't always a good idea.
    These users sometimes have a valid reason (crashes, incompatibility etc) not to use the latest version and you and we would loose them. And sure they don't get any support and run the old version on their own risk.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #18
    Join Date
    December 2015
    Posts
    273
    Quote Originally Posted by dante696 View Post
    We don't fully agree to this.

    Forcing user to use a version isn't always a good idea.
    These users sometimes have a valid reason (crashes, incompatibility etc) not to use the latest version and you and we would loose them. And sure they don't get any support and run the old version on their own risk.
    Well, as far as I understand it, it was out of question to make 3.1 server compatible with 3.0.x clients. So you would have choosen a 3.1.x client anyways. And the best choice out of all the 3.1.x clients is cleary the 3.1.6, atleast in my eyes.

    And backwards compatibility is fine and all and I like it and are mostly for it, but if it keeps features away from the main usersbase, than no, sorry. Some people will always "suffer" and that way it will be the minior faction.

    Edit: Just saw now that 3.1.5 was the last Vista client, thought 3.0.19.4 was the last client for XP and Vista. But anyway. I still like this choice more.
    Last edited by Dimos; November 10th, 2017 at 11:49 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Client Version FIX Server Version 3.0.7-beta
    By avats in forum Linux / FreeBSD
    Replies: 1
    Last Post: February 19th, 2013, 10:06 AM
  2. [Suggestion] Changes to minimum client version server setting
    By Screech in forum Suggestions and Feedback
    Replies: 1
    Last Post: November 28th, 2011, 03:09 PM
  3. [solved] Revert minimum client?
    By patrick9950 in forum Windows
    Replies: 4
    Last Post: August 7th, 2010, 08:59 AM
  4. [BUG?] Unable to modify minimum client version
    By Godko in forum Server Support
    Replies: 7
    Last Post: January 24th, 2010, 07:10 PM
  5. Replies: 3
    Last Post: December 24th, 2009, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •