Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    December 2015
    Posts
    273

    3.1. Server minimum Client version?

    What will be the minimum Client version for 3.1 servers?

    The client 3.1.6 should be a no-brainer in my opinion, because as of this version user are able to connect via the new myTeamspeak Nickname feature, one of the biggest user experience feature update for TS3 in the last years.

    So I really hope 3.1.6 will make the cut as minimum required version to join the new servers.

    Would make little to no sense for me to not force it, because then you still can't advise the Nickname for your TS3 server freely, because some user will get errors when they try to connect via a Nickname in a old client and wont understand it, since thier friends can connect just fine.

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    If they make such requirement, it will also be for the new copy protection, which was added in 3.1.6.

  3. #3
    Join Date
    December 2015
    Posts
    273
    Quote Originally Posted by numma_cway View Post
    If they make such requirement, it will also be for the new copy protection, which was added in 3.1.6.
    Can you explain that a little further? I Don't know what you mean with "copy protection" and if this argument is pro 3.1.6+ as minimum version or against it.

  4. #4
    Join Date
    June 2008
    Posts
    18,513
    Update:
    Quote Originally Posted by dante696 View Post
    PC Client 3.1.6 will be the minimum version that is needed to connect to server 3.1
    Same counts for released Android 3.1.6.1 and iOS Client 3.1.26.
    ----------------------------------------------------------------

    As explained in the other thread:
    The final decisions to allow connection of client 3.1.5 or 3.1.6 is not made yet.
    But the decisions will not depend on the server nickname feature. We released that feature already.

    Till our server will force client 3.1.6 (or newer):
    You can force your users to use the latest client on your server to solve your problem.
    The command in Server query is serveredit virtualserver_min_client_version=1502873983

    Edit
    Quote Originally Posted by Dimos View Post
    what you mean with "copy protection"
    * Support for new server license features.
    you can find that in the client changelog.

    Edit 2
    Numma meant sth. different but already active here. See post below mine.
    Last edited by dante696; November 10th, 2017 at 09:31 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    The copy protection is also called blacklist2.

  6. #6
    Join Date
    June 2008
    Posts
    18,513
    That's not a copy protection.
    The new and old license systems are kind of copy protections.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    December 2015
    Posts
    273
    What messages does a user get when he tries to join with a banned client version? Is it a generic one or does it state the reason?

    Becaus if it says like "Your client version is not allowed/banned on this server" it doesn't sounds nice or even welcoming

    But if the 3.1 default message (which I guess you guys will have for the 3.1 servers) and which will probably reads as "Your client version is to old to join this server, please download the new version Here" gets triggert its much more informative and friendly. But well thats just my opionion.

    But even the fact that the new Blacklist/Greylist and licensing feature were added in 3.1.6 are just more reasons to choose 3.1.6 or even 3.1.7 as minimum version.

    Why not get ride of old burdens and make some kind of restart/refresh from this point on. I don't get it.

  8. #8
    Join Date
    June 2008
    Posts
    18,513
    Quote Originally Posted by Dimos View Post
    What messages does a user get when he tries to join with a banned client version?
    Name:  min client version dialog.png
Views: 2365
Size:  29.9 KB


    Quote Originally Posted by Dimos View Post
    But even the fact that the new Blacklist/Greylist and licensing feature were added in 3.1.6 are just more reasons to choose 3.1.6 or even 3.1.7 as minimum version.
    As said before there is no final decision made yet.
    Last edited by dante696; November 9th, 2017 at 04:43 PM. Reason: missed a "no" here
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #9
    Join Date
    December 2015
    Posts
    273
    Okay, if thats the current error message you get when your client version is banned I'm ok with it, kinda.

    Quote Originally Posted by dante696 View Post
    As said before there is final decision made yet.
    And what decision is it now?

  10. #10
    Join Date
    June 2008
    Posts
    18,513
    i missed a word. "no" was missing ....

    Please wait till we release server 3.1.
    Maybe we reply before that release
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #11
    Join Date
    December 2015
    Posts
    273
    Quote Originally Posted by dante696 View Post
    i missed a word. "no" was missing ....
    Okay, nvm then

  12. #12
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    In some way blacklist2 is a kind of copy protection. Eventually, all kinds of copy protection in terms of "running an application" can be circumvented. But then you would eventually (as soon as you get blacklist2ed) have to have all users circumvent blacklist2, which will be too hard to achieve for most communities.

    If they set the minimum version beyond 3.0.19.4, they will lose users of Windows XP and Vista, which aren't that many (0.5% of playerbase), but they exist. inb4: Yes, they are outdated and no longer supported unless you identify as cashier system.

  13. #13
    Join Date
    December 2015
    Posts
    273
    Quote Originally Posted by numma_cway View Post
    If they set the minimum version beyond 3.0.19.4, they will lose users of Windows XP and Vista, which aren't that many (0.5% of playerbase), but they exist. inb4: Yes, they are outdated and no longer supported unless you identify as cashier system.
    Well, I can't find it right now, but I'm quiet sure that it was said somewhere (by Dante) that 3.1 server need atleast 3.1.x clients anyway. So that decision was already made. I guess.

    I mean you also just said the other reason, don't use a deprecated OS that won't get anymore support from either Microsoft or TS3.

    And this is also one of the few reasons I understand and I am ok with to drop support for so the other 99,5% can profit from it.

    In other words. If only 0.5% of my userbase profits from it I will not keep the legacy stuff for this small fraction only to let others "suffer"

  14. #14
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    Because blacklist2 has a hivemind aspect (thanks to submitting IPs, DNS and virtual server ID, which allow tracking illegal servers), it would make little sense to set the requirement for anything below 3.1.6.
    They also announced that an upcoming client might reject connecting to 3.0 servers.

  15. #15
    Join Date
    June 2008
    Posts
    18,513
    I brang up the topic up in our Meeting and we made a decision.

    PC Client 3.1.6 will be the minimum version that is needed to connect to server 3.1
    Same counts for released Android 3.1.6.1 and iOS Client 3.1.26.

    Edit
    Client 3.1.6 will not reject connecting to old server.
    Unreleased client 3.1.7 also connects to the old server but with a little chance that this may change when a beta was released (no release date yet).
    Last edited by dante696; November 10th, 2017 at 09:30 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Client Version FIX Server Version 3.0.7-beta
    By avats in forum Linux / FreeBSD
    Replies: 1
    Last Post: February 19th, 2013, 10:06 AM
  2. [Suggestion] Changes to minimum client version server setting
    By Screech in forum Suggestions and Feedback
    Replies: 1
    Last Post: November 28th, 2011, 03:09 PM
  3. [solved] Revert minimum client?
    By patrick9950 in forum Windows
    Replies: 4
    Last Post: August 7th, 2010, 08:59 AM
  4. [BUG?] Unable to modify minimum client version
    By Godko in forum Server Support
    Replies: 7
    Last Post: January 24th, 2010, 07:10 PM
  5. Replies: 3
    Last Post: December 24th, 2009, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •