Hello guys,
I was using the TeamSpeak3 client on Ubuntu 16.04 for two weeks, but today my client wasn't starting.
Everything works on my system except TeamSpeak.
Here's the terminal output after running the runscript.sh.

Code:
QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
Crashdump ENABLED,  directory is: /home/kevin/.ts3client/crashdumps
DUMP defined! Dumpdir is: /home/kevin/.ts3client/crashdumps
2017-11-10 15:39:12.798032|INFO    |              |   |TeamSpeak 3 Client 3.1.6 (2017-08-16 08:59:43)
2017-11-10 15:39:12.798091|INFO    |              |   |SystemInformation: Linux 4.10.0-38-generic #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017 x86_64 Binary: 64bit
2017-11-10 15:39:12.798115|INFO    |              |   |Using hardware aes
2017-11-10 15:39:12.809944|DEBUG   |PulseAudio    |   |connected to pulse audio server - 
2017-11-10 15:39:12.924997|INFO    |ClientUI      |   |OpenGL Info: LibGL, Vendor: NVIDIA Corporation, Renderer: GeForce GTX 960/PCIe/SSE2, Version: 4.5.0 NVIDIA 384.98
2017-11-10 15:39:12.952947|INFO    |Addons        |   |Checking for addon updates...
2017-11-10 15:39:13.113145|INFO    |SyncImpl      |   |Creating default config in local storage
The X11 connection broke: Maximum allowed requested length exceeded (code 4)
XIO:  fatal IO error 2 (No such file or directory) on X server ":0"
      after 508 requests (504 known processed) with 0 events remaining.
./teamspeak3-client.sh: line 7:  8479 Segmentation fault      (core dumped) /usr/lib/teamspeak3-client/ts3client_linux_amd64 [email protected]
I already tried to reinstall TeamSpeak3 and rebooted multiple times.
If anybody needs some more information, let me know.

Kind regards, Tyan