Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    June 2012
    Posts
    9

    Delay in my voice after a few hours connected

    So this has been happening ever since I downloaded Windows 10 for Teamspeak 3 only. Essentially the longer teamspeak is open, the more delay my voice gets. I use voice activation 100% of the time and I noticed when talking to friends the light would light up a few seconds after I started speaking but they heard me so I assumed it was visual.

    Until today I was on teamspeak playing cs:go with some friends and when talking in cs:go my friend noticed that what I was saying was coming in cs:go fine but than it would come into ts3 delayed. So after the game I did some minor tests.

    1: A simple voice test. And it even is delayed in the voice test.

    2: Checked Discord. This was essentially to see if it was my mic or hardware in general. But Discord was fine.

    3: Google. Found a 2012 thread saying it happened to them after being on ts3 for long periods of time. So I restarted my ts3 and it fixed it. But thats still not really solving anything but rather identifying the issue.

    Sadly that thread only had old pastebin solutions that don't exist anymore so I figured I would make a new one.

    Please help D:

  2. #2
    Join Date
    June 2012
    Posts
    9
    Bump

    + also tried another teamspeak server and same issues

  3. #3
    Join Date
    June 2012
    Posts
    9
    after the most recent update it has only gotten worse. The delay happens after only like 2-3 hours of connection

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,319
    I think I have this issue as well.

  5. #5
    Join Date
    December 2017
    Posts
    2
    Go too tools then select settings
    then select capture then select Windows audio setting apply

    do same with playback no delay anymore

  6. #6
    Join Date
    June 2012
    Posts
    9
    Quote Originally Posted by mitchell111 View Post
    Go too tools then select settings
    then select capture then select Windows audio setting apply

    do same with playback no delay anymore
    thanks! this worked 100%

  7. #7
    Join Date
    April 2019
    Posts
    1

    2 second delay outputs after hours

    I'm having this issue for months that if I run teamspeak for hours( like 3-4 hours), my voice in teamspeak has about 2 second delay. The first 1-2 hour is normal, but after 3-4 hours, it happens 100%. If I close the teamspeak and run it again, the problem will disappear. I've tried to reinstall it, but it is still happening. Please fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Voice delay after few hours connected
    By d3monCorp in forum Windows
    Replies: 39
    Last Post: July 8th, 2018, 08:52 AM
  2. [No Bug] Temporary Channel deletion delay only 24 hours
    By Soulflare3 in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: September 25th, 2015, 09:24 AM
  3. Is the voice delay going ever to be tightened even more?
    By jesepi in forum General Questions
    Replies: 2
    Last Post: June 14th, 2010, 01:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •