Results 1 to 1 of 1
  1. #1
    Join Date
    December 2017

    TeamSpeak and ArmA3: Complete computer freeze when running together


    I recently started getting involved in ArmA3 multiplayer through a group that uses TeamSpeak. For this, I have installed Teamspeak 3.1.7 64-bit edition on my 64-bit Windows 7 machine. Unfortunately, I have run into an issue where if both of them are running at the same time, my computer will freeze in very short order. Only a hard reboot will give me control back.

    Particularly, it seems to be specifically when I am connected to a server, and when I am using the ArmA3 launcher. If I have TeamSpeak up and connected to a server, the system will freeze almost immediately when I run the ArmA3 launcher. The window for this launcher renders and the whole thing locks up forever. If I try and run the launcher first, then TeamSpeak, the computer will freeze mere seconds after connecting to a server - any TeamSpeak server.

    If I have TeamSpeak running and connected without ArmA3 running, I run into no issues - by itself, TeamSpeak is fine. If I am not running TeamSpeak at all and I try to play ArmA3 by itself, I run into no issues - by itself, ArmA3 is fine. If I have TeamSpeak running but not connected to anything, I run into no issues - the problem only begins when I connect to a server while the launcher is running.

    This behavior cannot be reproduced with any other game - only ArmA3. Mods to the game also do not seem to matter - Installed, uninstalled, enabled, disabled - does not matter. Overwolf being installed or running (or not) also has no difference.

    I have tried running TeamSpeak in -safemode, which does report add-ons as disabled due to Safemode. This doesn't help.

    I have also tried other versions of TeamSpeak - 3.1.7 32 bit behaves the same, as does 3.1.6. I have pulled down 3.1.4 as well but not tried, because honestly I do not believe that will do anything but skirt the issue - there is no long-term support there.

    I have tried changing some of the drivers; I use an EVGA X58 SLI FTW3 motherboard, and pulled down the latest Networking drivers off of the EVGA website, thinking maybe something was going awry there. No help, and honestly that was kind of a straw-grab. I use on-board sound, but did not mess with the drivers for that.

    I've also seen a few other suggestions other people with freezing issues have made - these seem to revolve around turning off options regarding how the chat is handled in the client. That was a stretch, and of no help. From further research some people in the past seem to have similar issues with ArmA2, way back in 2010 or so, but those were evidently resolved in future versions of the TeamSpeak client - something related to Overlays, which -safemode seems to have disabled anyways.

    Briefly, I found a work-around. It appears that if I start ArmA3, go all the way to the actual in-game menu (launcher now being left behind), I can alt-tab the game and connect to a TeamSpeak server without any issue. I would then be able to speak through TeamSpeak and interact with the game. Unfortunately this is not a viable work-around, as some of the mods this group uses crash if you alt-tab the game. This is its own issue not being trouble-shot here, but rather it removed the work-around I had. If I launch ArmA3 directly - bypassing the launcher - it also works in a similar fashion but seems to cause trouble with the game's mod arrangement. This is just side-stepping whatever the real issue is.

    So, I need to be able to find a way to make TeamSpeak and the ArmA3 launcher get along, and stop locking my system up. I have used TS in the past many times, though it has been quite a while since I have (probably 5 years easily). I have even used it with earlier versions of ArmA (1, 2) but never had this kind of issue. And again, it's only ArmA3 and only when TeamSpeak is connected - no other game struggles like this, and the game itself does not struggle without TeamSpeak.

    I have attached my most recent four logs. All of the troubleshooting I've done probably deleted earlier logs during uninstall. I *believe* these represent the 32-bit 3.1.7 and the 64-bit 3.1.6 attempts. If better, more accurate logs are needed, I can repeat the process and obtain them with whatever version is desired.

    This is a perplexing issue that seems to leave little to go on. While I'm familiar with troubleshooting techniques, this is not making itself an easy process. After three days of trying different things again and again (bonus points to Steam for occasionally losing the installed files, making me wait 30-45 minutes to "reinstall" after some hard reboots), I figure it might be time to turn to more experienced hands.



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: April 7th, 2016, 03:07 PM
  2. Complete freeze of teamspeak
    By graynizmo in forum Windows
    Replies: 0
    Last Post: June 2nd, 2011, 08:11 AM
  3. Teamspeak 3 Kills My Computer to a freeze?
    By elemein in forum Windows
    Replies: 5
    Last Post: May 25th, 2011, 03:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts