Hello guys,
I've started to have this problem few months ago with TS3 client. Every time I join the TS server after a few minutes I lost connection to the server and client is trying to reconnect but it cant. Sometimes connection is renewed after 5 minutes of reconnecting, but the quickest way is to turn off client for 2 seconds and run it again and I can connect immediately. Ive tried to completely reinstall my TS3 client, but nothing has changed. I did not change my provider since this problem started.

It's happening on every server, so its not server problem. Ive tried to flush DNS or set default proxy, but it doesnt work.
Sometimes i can be connected on the server for 5 hours without any problem but sometimes it keeps disconnecting me every 10 minutes.

Log:

Code:
18. 1. 2018 19:29:53	ClientUI	Info	Connect status: Disconnected	
18. 1. 2018 19:29:53	ClientUI	Info	Connection lost, want autoreconnect = 1	
18. 1. 2018 19:29:54	ClientUI	Info	Autoreconnecting	
18. 1. 2018 19:29:54	ClientUI	Info	Connect to server: tecko.mc1.eu	
18. 1. 2018 19:29:54	ClientUI	Info	Trying to resolve tecko.mc1.eu	
18. 1. 2018 19:29:54	TSDNS	Info	SRV DNS resolve successful, "_ts3._udp.tecko.mc1.eu" =(h: mc1.eu p:5748)	
18. 1. 2018 19:29:54	TSDNS	Info	SRV DNS resolve unsuccessful, "_tsdns._tcp.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:29:54	TSDNS	Info	A/AAAA DNS resolve unsuccessful, "tecko.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:29:54	TSDNS	Info	A/AAAA DNS resolve unsuccessful, "tecko.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:29:54	TSDNS	Info	A/AAAA DNS resolve successful, "mc1.eu" =(h: 213.32.105.169 p:0)	
18. 1. 2018 19:29:54	TSDNS	Info	A/AAAA DNS resolve for possible TSDNS successful, "mc1.eu" =(h: 213.32.105.169 p:0)	
18. 1. 2018 19:29:54	ClientUI	Info	Lookup finished: ip=213.32.105.169 port=5748 query=tecko.mc1.eu error=0	
18. 1. 2018 19:29:54	ClientUI	Info	Resolve successful: 213.32.105.169:5748	
18. 1. 2018 19:29:54	ClientUI	Info	Initiating connection: 213.32.105.169:5748	
18. 1. 2018 19:29:54	ClientUI	Info	Connect status: Connecting	
18. 1. 2018 19:29:55	TSDNS	Info	TSDNS queried unsuccessfully 213.32.105.169:41144	
18. 1. 2018 19:29:55	TSDNS	Info	No TSDNS found	
18. 1. 2018 19:29:59	ClientUI	Info	Connect status: Disconnected	
18. 1. 2018 19:29:59	ClientUI	Info	Failed to connect to server, want autoreconnect = 1	
18. 1. 2018 19:30:00	ClientUI	Info	Autoreconnecting	
18. 1. 2018 19:30:00	ClientUI	Info	Connect to server: tecko.mc1.eu	
18. 1. 2018 19:30:00	ClientUI	Info	Trying to resolve tecko.mc1.eu	
18. 1. 2018 19:30:00	TSDNS	Info	A/AAAA DNS resolve for possible TSDNS successful, "mc1.eu" =(h: 213.32.105.169 p:0)	
18. 1. 2018 19:30:00	TSDNS	Info	SRV DNS resolve successful, "_ts3._udp.tecko.mc1.eu" =(h: mc1.eu p:5748)	
18. 1. 2018 19:30:00	TSDNS	Info	A/AAAA DNS resolve unsuccessful, "tecko.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:30:00	TSDNS	Info	A/AAAA DNS resolve unsuccessful, "tecko.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:30:00	TSDNS	Info	SRV DNS resolve unsuccessful, "_tsdns._tcp.mc1.eu" DNS server returned answer with no data	
18. 1. 2018 19:30:00	TSDNS	Info	A/AAAA DNS resolve successful, "mc1.eu" =(h: 213.32.105.169 p:0)	
18. 1. 2018 19:30:00	ClientUI	Info	Lookup finished: ip=213.32.105.169 port=5748 query=tecko.mc1.eu error=0	
18. 1. 2018 19:30:00	ClientUI	Info	Resolve successful: 213.32.105.169:5748	
18. 1. 2018 19:30:00	ClientUI	Info	Initiating connection: 213.32.105.169:5748	
18. 1. 2018 19:30:00	ClientUI	Info	Connect status: Connecting	
18. 1. 2018 19:30:01	TSDNS	Info	TSDNS queried unsuccessfully 213.32.105.169:41144	
18. 1. 2018 19:30:01	TSDNS	Info	No TSDNS found	
18. 1. 2018 19:30:02	ClientUI	Info	Connect status: Disconnected