Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    January 2018

    Inrico T320 hotkeys not working

    Hi guys I'm just wondering if in any upcoming updates you will allow ptt access for the new Inrico T320 as you can't map the PTT button on this model of network radio

  2. #2
    Join Date
    February 2018

    Wont PTT


    As Radio ham we use Teamspeak for the IRN network.
    Unfortunately there is a considerable problem when using the Inrico T320s Handheld.
    The PTT button does not work.
    Please see an excellent post by Duarte Braga regarding this issue. (Link below)

    Some update on the T320 issue with the PTT not working on the TS3. While we can not get a solution from Inrico, I made some tests. First, using Button Mapper, it's clear that the PTT button is using KEYCODE 142. However, TS3 seems to not catch that event. So using the ADB tool (in developer mode) with the T320 connected to my laptop, I used the command "adb shell input keyevent 142" and the TS3 did not react. If I try any other combination of codes, it will accept them. So, this tells me that something is in between the KEYCODE 142 event and TS3.
    I have e-mailed the head of engineering in Inrico and even the owner, so I expect we will have some results. Meanwhile I will keep looking for solutions. Obviously this could be solved by TS3 if they were looking for an android android.intent.action.PTT instead of this old fashioned way of looking for the keycode. That's how K1RFD, the author from Echolink solved the problem!!!

    Using the ADB I managed to program the TS3 to accept the button MEDIA_PLAY_PAUSE as input. Then I went to Button Mapper, and mapped the PTT to the action MEDIA_PLAY_PAUSE, in hope that it would trigger TS3. However, TS3 waits for the MEDIA_PLAY_PAUSE key, and not the action that such key will produce.

    I also tried to edit the file /system/usr/keylayout/Generic.kl that has the mapping of the keys. This would solve the problem, however, after trying everything I could, I was unable to get root access to change the file. Tomorrow is another day!
    Last edited by dante696; February 2nd, 2018 at 07:39 AM. Reason: merged

  3. #3
    Join Date
    February 2018

    Also Issues T320

    Hi All

    I am also in the same Boat with the T320

    It was myself that has been talking to Duarte about this issue and it seems a issue of firmware of Network Radio

    You will find that Zello works flawless and has full control of PTT, But issues are that even with Zello uninstalled the PTT can not be mapped as stated.

    There is a video of a T320 using full functioning PTT here:

    I have already flashed the unit with a firmware from Duarte hoping for a fix but it did nothing still the same.

    You can not even map the camera button, Well you can but when you use Teamspeak it keys up and then drops PTT after about 1-2 secs for some reason

    You can not even map the SOS red button for teamspeak.

    Now with Echolink PTT also it has big issues and hopefully we will be getting a fix soon.

    All other units of Network Radios work on the pTT for all so i am sure a fix will come fast but we just need to hope it happens soon.


  4. #4
    Join Date
    May 2018

    Inrico T320 alphanumeric keypad

    Hi all

    Is anyone out there able to tell me how to activate the alphanumeric keypad on a T320? According to the instruction manual the # key is supposed to toggle between input types, ie between the keypad buttons and the tiny letters on the touch screen. Am i missing something?

    Thanks guys.

  5. #5
    Join Date
    August 2018

    PTT T320 on Ts3

    Hello everyone
    T320 can use the PTT button in Ts3. Only EN version firmware is required. And use the number button to use the button map app to set.

    My Youtube

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hotkeys not working.
    By ProCcat4 in forum Windows
    Replies: 2
    Last Post: January 10th, 2017, 12:27 PM
  2. [Resolved] PTT Hotkeys not Working
    By GPMMoonShine in forum Windows
    Replies: 1
    Last Post: March 12th, 2015, 03:49 AM
  3. [Resolved] Hotkeys not working
    By Jolle in forum General Questions
    Replies: 20
    Last Post: May 29th, 2014, 01:17 PM
  4. Hotkeys not working?
    By DanTheHumann in forum General Questions
    Replies: 0
    Last Post: December 14th, 2013, 06:10 PM
  5. Hotkeys not working
    By thecakeisalie in forum Windows
    Replies: 2
    Last Post: September 25th, 2012, 01:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts