Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 23

Thread: opus 1.2

  1. #1
    Join Date
    January 2018
    Posts
    60

    opus 1.2


  2. #2
    Join Date
    June 2008
    Posts
    18,151
    Update
    Original post is outdated


    Opus 1.2 can handle old and new CPUs and can detect which CPU is in use.
    It's still on our todo but there is no release date set.


    ----- Original post below -----
    We have this on our todo, but....
    Adding Opus 1.2 will need newer CPUs and this means our software will become more incompatible for users.

    There may be workarounds, but workaround often cause problems so...
    We are not sure when we are adding it.

    Please do not create a fourth Post/Thread for this.
    Last edited by dante696; April 25th, 2018 at 02:53 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2018
    Posts
    3
    Serious question: Why will you need newer CPUs? What does this answer even mean? Discord has already added Opus 1.2. I prefer to use TeamSpeak over Discord, but come on, you're losing users to Discord because it sounds slightly better.

    Give users an option at least?

    Quote Originally Posted by dante696 View Post
    We have this on our todo, but....
    Adding Opus 1.2 will need newer CPUs and this means our software will become more incompatible for users.

    There may be workarounds, but workaround often cause problems so...
    We are not sure when we are adding it.

    Please do not create a fourth Post/Thread for this.

  4. #4
    Join Date
    June 2008
    Posts
    18,151
    What I've heard from our devs was that Opus 1.2 needs CPU with "Streaming SIMD Extensions 3" (SSE3).
    Currently we still support when CPU instructions has at least SSE2.

    But as said there may be a workaround, but no release date for this. Workarounds are dirty and may cause more problems.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    April 2016
    Posts
    3
    Quote Originally Posted by dante696 View Post
    What I've heard from our devs was that Opus 1.2 needs CPU with "Streaming SIMD Extensions 3" (SSE3).
    Currently we still support when CPU instructions has at least SSE2.
    This is a lie. Opus supports these instruction sets and also has run-time CPU detection, but it's optional. Sure... you can build Opus with several platform optimizations that will require SSE3, but this does not mean you have to. Your devs are wrong, which is very sad as they are working on a voice-communication software.


  6. #6
    Join Date
    January 2018
    Posts
    60

    Opus 1.3

    Bitte bei teamspeak5 Opus updaten.
    Last edited by dante696; June 12th, 2018 at 03:47 PM. Reason: merged

  7. #7
    Join Date
    June 2008
    Posts
    18,151
    Opus 1.3 is not stable yet.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    January 2018
    Posts
    60
    Yes, but it could be at the end oft the year.

  9. #9
    Join Date
    June 2018
    Location
    Poland
    Posts
    98

    Opus voice

    That would be nice to see the new opus voice but if it will cause problems devs have to test it and then it should be available.

  10. #10
    Join Date
    March 2013
    Location
    localhost
    Posts
    2
    Quote Originally Posted by dante696 View Post
    Currently we still support when CPU instructions has at least SSE2.
    Why tho? Even on the Steam Hardware Survey, 100% of systems support SSE3 (Other Settings):
    https://store.steampowered.com/hwsur...lcome-to-Steam

    So the number of systems that don't support SSE3 and use TeamSpeak should be so low and it's neglectable.

  11. #11
    Join Date
    June 2008
    Posts
    18,151
    Please ignore this and read post #2 instead.

    Opus has a detection and can handle older or newer CPUs.
    So which SEE we like to support doesn't matter anymore.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141
    just want to inform you that 1.3 is out

  13. #13
    Join Date
    June 2018
    Posts
    10
    Opus 1.3 stable was released on Oct. 18th so when will come up with it???

  14. #14
    Join Date
    February 2017
    Location
    Australia
    Posts
    106
    Quote Originally Posted by edisonjwa View Post
    Opus 1.3 stable was released on Oct. 18th so when will come up with it???
    I read the blog post the other day, it's pretty great. Being able to get better quality from lower bitrates makes it great when roaming

  15. #15
    Join Date
    October 2016
    Posts
    123
    An option for higher bitrates on Opus Voice would also be great.

    E.g. Make the Codec Settings go up to 12 or 15 to get like 10 or 12 KiB/s

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Help?] Opus Voice > Opus Music!?
    By Vinni_ in forum Client Support
    Replies: 2
    Last Post: December 13th, 2014, 11:57 PM
  2. [Rejected] Opus 1.1, Opus Voice Stereo, Server-side smiles
    By KIDINK^ in forum Suggestions and Feedback
    Replies: 5
    Last Post: October 27th, 2014, 11:11 AM
  3. Opus 1.1 and SSL
    By Razilla in forum Suggestions and Feedback
    Replies: 13
    Last Post: August 8th, 2014, 03:32 PM
  4. Opus Codec
    By RadarGaming in forum General Questions
    Replies: 21
    Last Post: September 7th, 2013, 01:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •