Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    February 2018
    Posts
    1

    "Failed to load certificate" since server 3.1

    so i tried to satrt my ts3server but when i entered ./ts3server_startscript.sh start license_accepted=1 inifile=ts3server.ini i got:
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [email protected]:~$
    ------------------------------------------------------------------
    I M P O R T A N T
    ------------------------------------------------------------------
    Server Query Admin Account created
    loginname= "serveradmin", password= "********"
    ------------------------------------------------------------------

    2018-02-15 10:28:23.103697|CRITICAL|ServerLib | |Failed to load ca certificates! Please install ca certficates on your system, or specify the location using the SSL_CERT_DIR or SSL_CERT_FILE environment variable.
    unset LD_LIBRARY_PATH


    and when i tried ./ts3server_startscript.sh start inifile=ts3server.ini i got

    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    Please set the environment variable TS3SERVER_LICENSE to "accept" in order to accept the license agreement.
    Alternatively, create a file named ".ts3server_license_accepted" in the working directory or start the server with the command line parameter "license_accepted=1".
    To view the license agreement set TS3SERVER_LICENSE to "view" in order to print the license to the console.
    Alternatively view the file "LICENSE" in your favorite text viewer yourself.
    TeamSpeak 3 server could not start


    please help, thanks

  2. #2
    Join Date
    June 2008
    Posts
    18,407
    For most Linux distributions following commands (run with sudo or as root) should help.

    Code:
    apt-get update
    apt-get install ca-certificates
    Update -> Thread marked as resolved after receiving a private reputation from user.
    Last edited by dante696; February 15th, 2018 at 01:34 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2018
    Posts
    1
    Quote Originally Posted by dante696 View Post
    For most Linux distributions following commands (run with sudo or as root) should help.

    Code:
    apt-get update
    apt-get install ca-certificates
    Update -> Thread marked as resolved after receiving a private reputation from user.
    I have the same problem, but I'm using an intel X64 based QNAP nas.
    Can you help me?

  4. #4
    Join Date
    August 2018
    Posts
    2

    Server desn't start after update on 3.3.0 - UPDATE CERTIFIACATES

    Hello,
    I need help. I update my teamspeak server on linux on version 3.3.0...After update I start server from console and console write STARTING SERVER, its ok, I think, thats ok, but I can't connect on server...server doesn't start...
    I look in log and there is some problem with CERTIFICATES... I must install or I don't know, how and what is problem...
    Thanks for help me..

    Here is log:
    Code:
    2018-08-15 09:38:25.271621|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.3.0 (2018-07-31 16:10:01)
    2018-08-15 09:38:25.272111|INFO    |ServerLibPriv |   |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 Binary: 64bit
    2018-08-15 09:38:25.272153|WARNING |ServerLibPriv |   |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!
    2018-08-15 09:38:25.275212|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-08-15 09:38:25.275282|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
    2018-08-15 09:38:25.277313|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
    2018-08-15 09:38:25.315334|INFO    |SQL           |   |database updated successfully to revision: 27
    2018-08-15 09:38:25.318568|INFO    |SQL           |   |database updated successfully to revision: 28
    2018-08-15 09:38:25.322089|INFO    |SQL           |   |database updated successfully to revision: 29
    2018-08-15 09:38:25.323548|INFO    |DatabaseQuery |   |database busy, waiting for finishing index tasks, may take some time!
    2018-08-15 09:39:05.347573|CRITICAL|ServerLib     |   |Failed to load ca certificates! Please install ca certficates on your system, or specify the location using the SSL_CERT_DIR or SSL_CERT_FILE environment variable.
    Last edited by dante696; August 16th, 2018 at 12:50 PM. Reason: merged

  5. #5
    Join Date
    June 2008
    Posts
    18,407
    Yes you must install or update the certificates. It's explained in post #2

    If this does not work read the manual from your operation system.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    August 2018
    Posts
    3
    the update of said certificates did not work on my rasperry pi.
    However, manually setting the CERT_FILE in my start script solved the issue:

    Code:
    export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt

  7. #7
    Join Date
    August 2018
    Posts
    2

    Problem is in command, this command is working

    Ok, now its my update ok and teamspeak working amd I update certificates succesfully. Command up here is not working, but I found else command and that is ok and working, here is that command:

    Code:
    [email protected]:~$ sudo apt-get update
    [email protected]:~$ sudo apt-get install ca-certificates

  8. #8
    Join Date
    July 2017
    Posts
    2
    If you manually delete the certificate files the aptitude package will still be installed. Make sure you remove it first:
    Code:
    sudo apt-get remove ca-certificates
    This happened in my case.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Plugin failed to load
    By Tjeller in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: November 23rd, 2015, 09:26 AM
  2. Plugin failed to load
    By Cruz3R in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: July 6th, 2014, 12:20 PM
  3. Failed to load plugin
    By Puffiamo in forum Client Plugins / Lua Scripts
    Replies: 9
    Last Post: September 24th, 2013, 10:12 PM
  4. TS3 Server SSL certificate?
    By ts3_ssl in forum Server Support
    Replies: 3
    Last Post: October 4th, 2011, 10:57 AM
  5. failed to load my own server ? at launch
    By swagmaxxima in forum Windows
    Replies: 2
    Last Post: August 16th, 2011, 06:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •