Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    November 2006
    Location
    USA
    Posts
    55

    How to set MIN CLIENT VERSION

    I know the sq command is as follows. I am just not sure what to enter as the client version you want to limit.

    serveredit virtualserver_min_client_version=

    I tried
    serveredit virtualserver_min_client_version=3.0.0-beta18\s[Build:\s10609]

    This did not work, all it added to the db was a 3

  2. #2
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    I will take a guess and say it wants the build number. I've never tried to use this feature though.

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    Quote Originally Posted by poisonpanik View Post
    I will take a guess and say it wants the build number.
    This is right, just set the build number.

    Code:
    serveredit virtualserver_min_client_version=10609

  4. #4
    Join Date
    November 2006
    Location
    USA
    Posts
    55

    Resolved

    Thank you that worked.

  5. #5
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Is it needed to restart the server to apply this change?

  6. #6
    Join Date
    June 2008
    Posts
    18,512
    No it isn't needed to restart the server.
    It's no global change for all servers.

  7. #7
    Join Date
    June 2010
    Location
    wqf3f
    Posts
    5

    Modify min client version?

    What exactly does this permission do?
    I've never ad the chance to really play around with it. I have it granted for my usergroup, but how do I use it?
    Last edited by Chris; September 12th, 2012 at 11:57 AM. Reason: removed ads

  8. #8
    Join Date
    June 2008
    Posts
    18,512
    You have to edit it with our server query

    How to edit such a client version:
    - Step 1: Login into the query admin and select your virtual server
    Code:
    login serveradmin passowrd
    use sid=1
    - Step 2: Edit the Value for your server
    Code:
    serveredit virtualserver_min_client_version=14345
    Now only user with Rc1 client can connect to this server. The value is the build number behind beta1-30 or Rc1.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #9
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    340

    how set manually min version of client to connect the server ?

    hello !

    Question is simple.

    how set manually min version of client to connect the server ?? and after reboot the VDS and start again it will saved ?? i would set manially client to 3.0.0 only that client or more than 3.0.0 can connect to my server.

  10. #10
    Join Date
    December 2009
    Location
    ohio
    Posts
    50
    so what is the build version # for 3.0.8.1 client then, i do not see that anywhere

  11. #11
    Join Date
    September 2012
    Posts
    6,079
    For quite some time now the build number got replaced by the date and time the version got created. This can easily be converted into a unix timestamp which will give you a number to use. You can use this website to get the timestamp.

  12. #12
    Join Date
    December 2009
    Location
    ohio
    Posts
    50
    well i used the time code converter and if anyone wants to know without having to go do it them selves it is
    client version=1343624400
    and another thing do not put the time in just use the date of the client version

  13. #13
    Join Date
    September 2006
    Location
    Germany / Hannover
    Posts
    137
    A timestamp contains always a time - not only a date. In 1343624400 the time is 07:00:00

  14. #14
    Join Date
    February 2018
    Location
    Portugal
    Posts
    13

    Old versions

    Please put teamspeak 3 client old versions allow to join on new teamspeak 3 servers version.
    Last edited by dante696; February 27th, 2018 at 06:10 PM. Reason: moved out of server release thread

  15. #15
    Join Date
    June 2008
    Posts
    18,512
    For client 3.1.8 set 1516614607 as value for virtualserver_min_client_version=.
    See Post #8 in this thread for a how to.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: November 18th, 2016, 11:28 PM
  2. Client Version FIX Server Version 3.0.7-beta
    By avats in forum Linux / FreeBSD
    Replies: 1
    Last Post: February 19th, 2013, 10:06 AM
  3. iOS Client version
    By Mildur in forum iOS
    Replies: 14
    Last Post: October 7th, 2011, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •