It's not a big thing, not a bug or problem, but it would be kind of a programming improvement, and not much programming work imho to fix this.

When you update the Teamspeak client by downloading a new client version and installing it over the old one, the version information of the new client version is updated in the Windows uninstaller, so 3.1.7 will become 3.1.8.

However, when the update function from within the TS client is used, the client is updated flawlessly, but the new version information is not passed to the Windows uninstaller.

So it can happen that you have version 3.1.7 mentioned in the uninstaller while having version 3.1.8 already installed.

There are a couple of tools like Patch My PC which use the uninstaller information to see if application versions are outdated and need update.
At this moment they are placing TS client as outdated every time when the build in updater is used, because the version update is not passed to the uninstaller.

So it would be nice if that could be fixed.