Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2

Hybrid View

  1. #1
    Join Date
    September 2015

    Completely unable to update server from

    I've been a terrible server admin, the version of TS currently being run is on Windows.

    Yesterday a few things made me think that things weren't quite right with the server so I tried to update.

    I followed the usual method, copy and replace all new version files. I then launched the app, agreed to the Ts&Cs, and a file was created showing that I'd accepted these. Then I waited. The server icon is in the sys tray, and then stops being in the sys tray. I re-launch the application - again it crashes.

    I login via server query to my pre-patch backup and do servercreatesnapshot, write it to a file, then try to deploy the snapshot to a clean install I've created. This crashes the clean install and it now won't open.

    I think the sqlite db (650~kb) is corrupted. I say this because of two symptoms:
    a. On of the spacers has inexplicably broken and the format code doesn't work ( [cspacer3] )
    b. The permissions for the main channel which all of the other channels sit in changed to limit maxclients.

    Looking in the log I can see that no-one has been messing around with settings.

    I really don't want to have to recreate everything manually, but it seems like I will have to if I can't fix this... We have a servergroup access permissions system and so it's going to be a tedious case of adding everyone back to the right membergroup as-and-when they join.

    As far as I can tell the only thing I've not tried is updating the server incrementally by going through each major release, instead of going straight to the newest.

    Can anyone offer any suggestions as to how I should proceed?

  2. #2
    Join Date
    June 2011
    Post logs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to Update
    By iflog in forum Windows
    Replies: 7
    Last Post: April 1st, 2017, 04:49 PM
  2. [Resolved] Unable to update client to 3.0.16 - Unable to download new client
    By TheRealJaycen in forum Windows
    Replies: 4
    Last Post: April 5th, 2015, 02:30 AM
  3. Unable to update server
    By Avygeil in forum Linux / FreeBSD
    Replies: 1
    Last Post: June 20th, 2014, 07:25 PM
  4. [Resolved] unable to update
    By gladiss in forum Linux
    Replies: 2
    Last Post: August 27th, 2013, 09:25 PM
  5. Windows 7 64 Bit - Unable to update
    By gibsonm in forum Windows
    Replies: 4
    Last Post: July 2nd, 2011, 05:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts