Forum

Results 1 to 5 of 5
  1. #1
    Join Date
    May 2018
    Posts
    2

    Ubuntu file:sql/update_29.sql failed.

    I have a Ubuntu server that's been running for several years and today it just crashed. No update was done or any changes. I opened the logs folder and looked at the error.
    2018-05-26 09:28:55.651957|CRITICAL|DatabaseQuery | |setSQLfromFile( file:sql/update_29.sql) failed
    I was curious if any of you could help me. I read several places about certain lines not being where they should be and others I've read elsewhere recommended to replace the SQL folder from a new server SQL folder but after looking in a newly downloaded SQL folder. Version 3.2.0, the "update_XX.sql" files only go up to "update_28.sql."
    The help is appreciated and thanks for your time!

  2. #2
    Join Date
    June 2008
    Posts
    18,119
    No update was done?
    It's hard to believe when server up to date. This update was release 2 weeks ago.

    Your error looks like you did update and downgrade the server and then it crashed on next server start. Or you started the wrong binary.

    edit
    Or not all files where overwritten / added during the update.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,344
    There is no file like update_29.sql.
    Please note that TeamSpeak does not try to update when your data version is lower than what the server expects, but updates when it is different.

    Example: After running a 3.2.0 (version 28), you start a 3.0.0-beta1 server (version 11). If you count from 28 to 11, there's obviously 4294967269 database updates in between which your server will try to install.

  4. #4
    Join Date
    May 2018
    Posts
    2
    I currently have a copy of the entire hard drive which was running the instance. update 29 was not the original update error, this update error only happened after I made a copy and tried installing the updated version of TeamSpeak 3. The binary is automatically started on startup. No binaries are ran manually. Originally it was asking for update 27 before I tried updating to the new version. Are updates done automatically in any way or are they only performed on demand? No update or downgrade was done that I know of since it's literally just sitting there with people in it and than kicked people off.
    Thanks for your analogy numma_cway, is there any way to get it back on track so it doesn't keep asking for imaginary updates?

  5. #5
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,344
    The current version is 28. You can tell from the last update SQL included.
    If your server is trying to update over that number, you are trying to run an outdated server.

    If this error is not fixed by not running an outdated server, post the full log (which will say that you are running an outdated server, and we can't tell you how to start the correct binary or make sure tar can write it).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. File transfer failed
    By Morbid_Fable in forum Client Support
    Replies: 0
    Last Post: September 14th, 2016, 09:27 PM
  2. Ubuntu 16.04 LTS mysql_real_connect() failed
    By Uncle666Sam in forum Linux / FreeBSD
    Replies: 2
    Last Post: July 12th, 2016, 11:27 PM
  3. File transfer failed
    By Halfon in forum Windows
    Replies: 1
    Last Post: February 1st, 2014, 01:03 PM
  4. File Transfer Failed
    By Morgisto in forum General Questions
    Replies: 2
    Last Post: August 27th, 2012, 11:42 AM
  5. [Ubuntu 10.04] "converting bind() IP failed"
    By Hertog_Jan in forum Linux / FreeBSD
    Replies: 5
    Last Post: July 21st, 2010, 08:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •