Forum

Results 1 to 4 of 4

Thread: Ts3 in Vps

  1. #1
    Join Date
    May 2018
    Posts
    1

    Ts3 in Vps

    Hi, I have two problem
    1)I'm inserting a ts3 server in the vps, I have executed these commands:

    A) wget http://dl.4players.de/ts/releases/3.0...

    B) tar xvf teamspeak3-server_linux_amd64-3.0.12.2.tar.bz2

    C) mv teamspeak3-server_linux_amd64 /home/

    D) ln -s /home/teamspeak3-server_linux_amd64/ts3server_startscript.sh /etc/init.d/teamspeak3

    E) update-rc.d teamspeak3 defaults

    F) service teamspeak3 start
    The problem is that when i go to do this command: update-rc.d teamspeak3 defaults
    it gives me command not found
    HOW DO I FIX IT?

    2) When i go to do this command service teamspeak3 start, it don't gives me the login data
    HOW DO I FIX IT?

    THANKS ALL

  2. #2
    Join Date
    September 2012
    Posts
    6,076
    You're using an ancient server version that isn't supported.
    Isn't init.d dead anyway?
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    March 2017
    Posts
    2
    Hello

    First of all if its Centos 7 please follow https://www.vultr.com/docs/installin...ak-on-centos-7

    If its ubuntu use

    https://www.vultr.com/docs/how-to-in...u-16-04-64-bit

    Remember:

    Do NOT run teamspeak as ROOT! NEVER EVER! Why?

    If someone gains access thrue teamspeak to the user that runs teamspeak via a exploit if its run as root they can do anything on the system.

    If you need any more help please reply here and we will help you.
    Last edited by Chris; June 3rd, 2018 at 01:41 PM.

  4. #4
    Join Date
    September 2012
    Posts
    6,076
    Would recommend to not follow any tutorial you find online to the letter. Usually they're quite old and outdated, using ancient server versions that have known bugs that are actively being abused.
    Unless the tutorial directs you to https://teamspeak.com/downloads#server to download the server it shouldn't be followed. At the very least use the latest server version, which you can find on https://teamspeak.com/downloads#server (you can copy the download link, by clicking the right most button).
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •