Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    June 2018

    Teamspeak mic errors: ts3 keeps cutting out mic input

    So yesterday I updated to 3.1.9 (because server required latest update, otherwise I don't update anything cause it usually breaks something) and I've been having issues.

    The mic keeps cutting out if I talk more that about 2 seconds, and then for the next few seconds there is no sound from my mic. I can say a word like "yes" and "no" or other quick answers but if I talk for any longer it just cuts out and no sound. No matter what setting I choose, Push to talk, continues or voice activation it all cuts out. And all of this happened since yesterday when I updated TS3.

    If I turn on "listen to this device" in the recording devices in windows, I can hear myself no problem with no interruptions.

    Does anyone know a fix to this? I use ts3 everyday to play with my friends, and I can't really thanks to these interruptions.

  2. #2
    Join Date
    April 2013

    Play arround with this and see if it fixes it..
    Click image for larger version. 

Name:	tt.png 
Views:	1121 
Size:	56.2 KB 
ID:	16759

    The "cuts out" problem is from the mic "sensitivity", it may also be caused by the mic configuration

    My mic config. as an example:

    Click image for larger version. 

Name:	ok.png 
Views:	673 
Size:	231.0 KB 
ID:	16760
    if i move it left, the mic start cutting off

  3. #3
    Join Date
    June 2018

    Problem solved

    I've fixed it.

    As you suggested I tried various voice activation levels, but none of them seemed to help. Giving sound boost as well as many other settings did not seem to fix it.

    So I decided to do what fixed many of my problems lasts time for a different problem, I'll just update my drivers. So I go and check and to my surprise these was a sound driver update (even though I updated everything a few months ago).

    Click image for larger version. 

Name:	aaahaaaaha.png 
Views:	578 
Size:	36.9 KB 
ID:	16764

    I let all the updates download and install, restarted the PC and joined my ts3 server and everything seemed to be working fine.

    Thanks for trying to help. Now I need to find a way to put this thread on "Solved" and hopefully if anyone else is having these problems, to go and check if the drivers are updated.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: September 13th, 2017, 05:36 PM
  2. File input / output errors for icons
    By agent smith in forum Windows
    Replies: 3
    Last Post: February 17th, 2016, 08:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts