Forum

Results 1 to 10 of 10
  1. #1
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    444

    "Server is running" but it's still offline

    I'm tryin' to update my Teamspeak Server from 3.0.12 to 3.2.0
    and I did follow the instructions, and everything seems to have worked, but after the install/upgrade, I couldn't start the server anymore, after a few restarts still didn't work at all. The server says (ts3server_startscript status) replies: "Server is running" but none can connect to the server.

    The teamspeak server is running on a linux machine/server (debian 8).
    And yes: I accepted the license.

    Did someone had similar experiences or who can help me out?
    Last edited by dante696; July 7th, 2018 at 11:09 AM. Reason: size 5 doesn't make it more readable.

  2. #2
    Join Date
    June 2008
    Posts
    18,275
    Read server Log 0 and the one from virtual server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    444
    2018-07-07 19:45:07.200959|INFO |VirtualServerBase|8 |stopped

    that's it.

  4. #4
    Join Date
    June 2008
    Posts
    18,275
    That was log 8.
    But what about log 0 I did mention?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    444
    ts3server_2018-07-08__02_10_41.147800_0.log - the very first log after the install/upgrade

    2018-07-08 02:10:41.147942|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.12.4 (2016-04-25 15:16:45)
    2018-07-08 02:10:41.148175|INFO |ServerLibPriv | |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.51-3 (2017-12-13) x86_64 Binary: 64bit
    2018-07-08 02:10:41.148225|WARNING |ServerLibPriv | |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!
    2018-07-08 02:10:41.154132|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-07-08 02:10:41.154198|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-07-08 02:10:41.157127|INFO |DatabaseQuery | |checking database integrity (may take a while)

  6. #6
    Join Date
    June 2008
    Posts
    18,275
    Please compare the logs with same time.
    The one on next restart is quiet useless. It doesn't show what happened before.

    At the moment it looks like the virtual server was stopped manually, when there are no error in log 0.

    You may enable more logging on virtual server to make sure no one stops the server via ServerQuery.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    444
    I'm not tryin' to get off-topic but listen

    Well, I finally upgraded my server from 3.0.12.4 to the new 3.2.0 but there's a new problem...
    The server crashes everytime after a few secounds or after a hour, no idea what's wrong here, but I'll send the logs here

    2018-07-21 19:43:59.248231|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.2.0 (2018-05-08 06:11:20)
    2018-07-21 19:43:59.250774|INFO |ServerLibPriv | |SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.51-3 (2017-12-13) x86_64 Binary: 64bit
    2018-07-21 19:43:59.250829|WARNING |ServerLibPriv | |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!
    2018-07-21 19:43:59.251392|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-07-21 19:43:59.251420|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-07-21 19:43:59.251593|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-07-21 19:43:59.326805|INFO |Accounting | |found old license, downloading new license
    2018-07-21 19:43:59.523883|INFO |Accounting | |Licensing Information
    2018-07-21 19:43:59.523938|INFO |Accounting | |type : Non-Profit License
    2018-07-21 19:43:59.523960|INFO |Accounting | |starting date : Mon Apr 30 00:00:00 2018
    2018-07-21 19:43:59.523972|INFO |Accounting | |ending date : Wed Nov 7 00:00:00 2018
    2018-07-21 19:43:59.523983|INFO |Accounting | |max virtualservers: 2
    2018-07-21 19:43:59.523993|INFO |Accounting | |max slots : 512
    2018-07-21 19:44:01.889462|INFO | | |Puzzle precompute time: 2263
    2018-07-21 19:44:01.889874|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2018-07-21 19:44:01.991544|ERROR |VirtualSvrMgr | |loading VirtualServer(2) start denied, error: server is already running under a different serverID
    2018-07-21 19:44:01.993385|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    2018-07-21 19:44:01.993593|INFO |Query | |listening on 0.0.0.0:10011, [::]:10011
    2018-07-21 19:44:59.693926|ERROR |Accounting | |too many virtualservers running, shutting down!
    2018-07-21 19:44:59.754445|ERROR |Accounting | |too many virtualservers running, shutting down!
    2018-07-21 19:49:09.106371|INFO |ServerMain | |Received signal SIGTERM, shutting down.

  8. #8
    Join Date
    March 2018
    Posts
    55
    check, may be someone using your license or any server running with your license

  9. #9
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    444
    I'm sure that nobody use my license.

  10. #10
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    Make sure you have stopped all ts3server processes running (confirm with top/htop) and wait at least 3 hours. If that does not work, you have shared your license.

    Important info for your next update: After a major server update, the database has to be updated. This is done automatically, but programmed extremely badly by TeamSpeak, as it does not use any CPU most of the time during this process and will therefore take around a minute no matter how fast or big your server is. I do not know if that time stacks depending on the updates you missed. Therefore, here's another hint: Do not wait that long.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server keeps going offline
    By SgtCheesepuffs in forum Server Support
    Replies: 1
    Last Post: March 26th, 2015, 08:17 AM
  2. How to obtain a Offline License (Offline AAL)
    By florian_fr40 in forum General Questions
    Replies: 11
    Last Post: May 23rd, 2012, 02:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •