Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2

Thread: PTT not working

  1. #1
    Join Date
    August 2018

    PTT not working


    My client started having issues today. When I came back from lunch, I tried to key up to talk, and the icon didnt light up as if my PTT wasn't being pressed. I tried in test, and same thing happened.

    Some things I've tried:

    - Double checked Capture and Hotkey profiles
    - Confirmed microphone works on Discord and other clients
    - Tried several different PTT keys
    - Closed and reopened TS3
    - Rebooted my computer
    - Uninstalled and reinstalled TS3 twice
    - Deleted my configurations

    It worked for about 20 minutes after the reboot, and then broke again.

    Edit: Update Aug 7th, I tried installing older versions of TS3, one at a time, and got it to work on 3.1.3 - but - it is now broken again. I cannot speak on any server.
    Last edited by Shawk420; August 8th, 2018 at 12:26 AM.

  2. #2
    Join Date
    August 2018

    I was running my new headset through a 5-in-1 USB hub. When I changed the headset USB to a direct connection, it started working immediately.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: March 5th, 2016, 05:41 PM
  2. Replies: 0
    Last Post: August 10th, 2013, 07:09 AM
  3. Replies: 8
    Last Post: March 1st, 2011, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts