Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 26
  1. #1
    Join Date
    September 2012
    Posts
    6,076

    [Discussion] TeamSpeak 3 Client 3.2.1

    This thread is for discussion and feedback for the 3.2.1 release of the TeamSpeak Client.
    Please see the announcement for changelog / features.
    Last edited by Chris; August 15th, 2018 at 01:28 PM.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  2. #2
    Join Date
    February 2018
    Location
    Portugal
    Posts
    12
    Clients 3.0.19.4 / 3.0.19.2 it's possible join? This because we have one Eee pc with windows 7 starter and don't supports last teamspeak version... :/

  3. #3
    Join Date
    September 2012
    Posts
    6,076
    server versions >= 3.1.0 require client 3.1.7 or newer.
    Last edited by Chris; August 13th, 2018 at 05:23 PM.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  4. #4
    Join Date
    February 2018
    Location
    Portugal
    Posts
    12
    But it's not possible the new clients version join on 3.0.13.8? It's a version of my actually server because of we sayed at up of old pcs don't support xpto windows versions.

  5. #5
    Join Date
    September 2012
    Posts
    6,076
    No, as mentioned in the changelog / announcement, client 3.2.0 will only connect to servers 3.1.0 or newer.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  6. #6
    Join Date
    August 2018
    Posts
    2
    @Chris there are people connecting with 3.2.0 clients to servers that are not Teamspeak Server. You need to make something against this!

  7. #7
    Join Date
    April 2017
    Posts
    2
    If somebody downloaded by mistake and cannot connect to our server anymore, is there a way to download an older client for TeamSpeak ? I cannot find anything on your website linking to older versions.

  8. #8
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    351
    If that wouldn't be a problem for tons of servers...

  9. #9
    Join Date
    August 2018
    Posts
    1
    Dropping support for older servers? Yikesm, not the way to go. Guess I won't be updating for a while.

  10. #10
    Join Date
    August 2018
    Posts
    1
    It would be excellent if the client would warn you about an upgrade locking you out of a server.

    Example (from just now): I connect to a server on startup, client checks for update and there is one. In my case, the server is 3.0. something and the update was 3.2 which aren't compatible. I click upgrade now, cause I like having the most up to date client, and now I can't connect to the server.

    I should probably read the patch notes more, this is true. But I feel like it would be pretty easy to check if the upgrade version will work with your connected server(s) and just warn you - are you sure? - if it won't.

  11. #11
    Join Date
    September 2012
    Posts
    6,076
    Quote Originally Posted by Wicstar View Post
    If somebody downloaded by mistake and cannot connect to our server anymore, is there a way to download an older client for TeamSpeak ? I cannot find anything on your website linking to older versions.
    No, but the server should be updated to the latest version, so that everyone can enjoy new features and fixed bugs.

    Quote Originally Posted by MCGamingDE View Post
    If that wouldn't be a problem for tons of servers...
    It shouldn't no... The last non supported server is over a year old. If you're affected that means the server wasn't updated for a year.

    Quote Originally Posted by Sticks271 View Post
    It would be excellent if the client would warn you about an upgrade locking you out of a server.

    Example (from just now): I connect to a server on startup, client checks for update and there is one. In my case, the server is 3.0. something and the update was 3.2 which aren't compatible. I click upgrade now, cause I like having the most up to date client, and now I can't connect to the server.

    I should probably read the patch notes more, this is true. But I feel like it would be pretty easy to check if the upgrade version will work with your connected server(s) and just warn you - are you sure? - if it won't.
    While it may sound easy, it's a little more involved than that. You'd have to store, associate and transfer that additional data with the update check (which strictly speaking isn't part of an update check really). What happens if the server didn't connect yet when the update happens, then that wouldn't work, etc.
    Plus, these old servers shouldn't really exist anymore and are not supported.


    In general we do not support old server versions, and it was announced quite some time ago that we will release a client that cannot connect to 3.0.x servers anymore when we released 3.1.0
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  12. #12
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    351
    It shouldn't no... The last non supported server is over a year old. If you're affected that means the server wasn't updated for a year.
    Like I see alot of users have got the problem that they can't upgrade their server so there's coming a new user wave soon.

  13. #13
    Join Date
    February 2018
    Location
    Hamburg
    Posts
    12
    I can't disbale or mute the TeamSpeak Soundpack in the new version. please fix that- i hate this voice ^^.. But very cool that now all cracked Hosters are stopping their illegal service!

  14. #14
    Join Date
    January 2017
    Location
    Switzerland
    Posts
    351
    Why does TeamSpeak 3 still getting big updates if teamspeak 5 will be here soon?

  15. #15
    Join Date
    February 2018
    Location
    Portugal
    Posts
    12
    Quote Originally Posted by MCGamingDE View Post
    Why does TeamSpeak 3 still getting big updates if teamspeak 5 will be here soon?
    Really... Hmm LOOL

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Discussion] TeamSpeak 3 Client 3.1.10
    By Chris in forum Suggestions and Feedback
    Replies: 23
    Last Post: June 17th, 2018, 04:14 PM
  2. [Discussion] TeamSpeak 3 Client 3.1.8
    By Chris in forum Suggestions and Feedback
    Replies: 12
    Last Post: May 8th, 2018, 01:37 PM
  3. [Discussion] TeamSpeak 3 Client 3.1.9
    By Chris in forum Suggestions and Feedback
    Replies: 0
    Last Post: May 7th, 2018, 02:36 PM
  4. [Discussion] TeamSpeak 3 Client 3.1.7
    By Chris in forum Suggestions and Feedback
    Replies: 9
    Last Post: December 27th, 2017, 02:49 PM
  5. [Discussion] TeamSpeak 3 Client 3.1.6
    By Chris in forum Suggestions and Feedback
    Replies: 17
    Last Post: December 19th, 2017, 01:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •