Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    August 2018
    Posts
    2

    Server 3 not accessible from outside domain after 3.3 upgrade.

    Hi all,

    I've been running TS3 server on my own pc for several years now, on Windows 10, 64bit. It's a simple configuration: personal router with those 3 ports forwarded to my pc.

    Yesterday (12-8) there were no problems. used it fine with friends. Today (13-8) someone accepted the update client request to 3.2 and cannot connect anymore. I did the same to check his issue, upgraded to client 3.2 and got "this version is not compatible with the server (which ran 3.0.10)"
    (My other friends simply gets the "cannot connect to xxx.xxx.xxx.xxx" message.)

    So I updated the server to 3.3.

    I can access it again from within my own domain (both using localhost and using my external IP address other people connect to.) That works. However, no other clients from outside can access it anymore now.

    I have disabled my firewall completely for both public and private networks to see if it was firewall related maybe with a windows patch, didn't help. Verified ports forwarding on the router. Also still ok. So I don't know if there is anything I can check?

    The server log 0 from the upgrade to 3.3:

    Code:
    2018-08-13 22:13:37.494625|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.3.0 (2018-07-31 16:10:01)
    2018-08-13 22:13:37.494625|INFO    |ServerLibPriv |   |SystemInformation: Windows 10 (17134) x64 (AMD or Intel) Binary: 64bit
    2018-08-13 22:13:37.494625|INFO    |ServerLibPriv |   |Using hardware aes
    2018-08-13 22:13:37.494625|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-08-13 22:13:37.495625|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
    2018-08-13 22:13:37.495625|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
    2018-08-13 22:13:37.507632|INFO    |SQL           |   |database updated successfully to revision: 22
    2018-08-13 22:13:37.508621|INFO    |SQL           |   |database updated successfully to revision: 23
    2018-08-13 22:13:37.509621|INFO    |SQL           |   |database updated successfully to revision: 24
    2018-08-13 22:13:37.510621|INFO    |SQL           |   |database updated successfully to revision: 25
    2018-08-13 22:13:37.511620|INFO    |SQL           |   |database updated successfully to revision: 26
    2018-08-13 22:13:37.512620|INFO    |SQL           |   |database updated successfully to revision: 27
    2018-08-13 22:13:37.513620|INFO    |SQL           |   |database updated successfully to revision: 28
    2018-08-13 22:13:37.514620|INFO    |SQL           |   |database updated successfully to revision: 29
    2018-08-13 22:13:37.515619|INFO    |DatabaseQuery |   |database busy, waiting for finishing index tasks, may take some time!
    2018-08-13 22:14:17.531828|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |Licensing Information
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |licensed to       : Anonymous
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |type              : No License
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |starting date     : Sun Jul  1 00:00:00 2018
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |ending date       : Wed Jul 31 00:00:00 2019
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |max virtualservers: 1
    2018-08-13 22:14:17.534827|INFO    |Accounting    |   |max slots         : 32
    2018-08-13 22:14:18.487535|INFO    |              |   |Puzzle precompute time: 939
    2018-08-13 22:14:18.487535|INFO    |FileManager   |   |listening on 0.0.0.0:30033, [::]:30033
    2018-08-13 22:14:18.502557|INFO    |Query         |   |listening for query on 0.0.0.0:10011, [::]:10011
    2018-08-13 22:14:18.502557|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1/32, 
    2018-08-13 22:14:18.571604|INFO    |              |   |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    After pc reboot i tried again, and i get the same log:

    Code:
    2018-08-13 22:17:56.249739|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.3.0 (2018-07-31 16:10:01)
    2018-08-13 22:17:56.249739|INFO    |ServerLibPriv |   |SystemInformation: Windows 10 (17134) x64 (AMD or Intel) Binary: 64bit
    2018-08-13 22:17:56.249739|INFO    |ServerLibPriv |   |Using hardware aes
    2018-08-13 22:17:56.249739|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-08-13 22:17:56.249739|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
    2018-08-13 22:17:56.250739|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
    2018-08-13 22:17:56.259735|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |Licensing Information
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |licensed to       : Anonymous
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |type              : No License
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |starting date     : Sun Jul  1 00:00:00 2018
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |ending date       : Wed Jul 31 00:00:00 2019
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |max virtualservers: 1
    2018-08-13 22:17:56.265732|INFO    |Accounting    |   |max slots         : 32
    2018-08-13 22:17:56.343708|INFO    |              |   |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2018-08-13 22:17:57.180441|INFO    |              |   |Puzzle precompute time: 903
    2018-08-13 22:17:57.180441|INFO    |FileManager   |   |listening on 0.0.0.0:30033, [::]:30033
    2018-08-13 22:17:57.196441|INFO    |Query         |   |listening for query on 0.0.0.0:10011, [::]:10011
    2018-08-13 22:17:57.196441|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1/32,
    In case it helps this is a recent log of the server before the upgrade:
    Code:
    2018-08-10 07:37:15.529143|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.10.1 (2013-11-08 11:09:56)
    2018-08-10 07:37:15.530143|INFO    |ServerLibPriv |   | SystemInformation: Windows 8 (9200) x64 (AMD or Intel) Binary: 64bit
    2018-08-10 07:37:15.530143|INFO    |ServerLibPriv |   | Using hardware aes
    2018-08-10 07:37:15.838773|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2018-08-10 07:37:15.838773|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2018-08-10 07:37:15.840757|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2018-08-10 07:37:15.853765|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2018-08-10 07:37:16.904417|INFO    |              |   | Puzzle precompute time: 1042
    2018-08-10 07:37:16.905416|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2018-08-10 07:37:16.939405|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
    2018-08-10 07:37:16.939405|INFO    |Query         |   | listening on 0.0.0.0:10011
    I don't have a licensekey.dat, and i never have in the past either.
    I am just using it as personal server with max 32 users (never more than 10 or so) and I'm fairly sure that's allowed by you guys.


    Any clues to what i can change to fix it? I'm a bit at a loss. Googling and searching this forum for recent threads didn't really give me anything.

    Thanks for any insight you may have. If there is any more information you'd need from me, please let me know.

    Best,
    Parsley

  2. #2
    Join Date
    September 2012
    Posts
    6,080
    Did the local IP change maybe?
    You could try from a mobile device with WiFi disabled.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    August 2018
    Posts
    2
    Thanks for the reply.

    My external IP has not changed.
    I will try from a mobile device without wifi later tonight.

    If needed i can request a client log from one of my friends if that could help you? Not sure if they exist?

    (local IP didn't change either. I've checked that when i checked the port forwarding on my router.)
    Last edited by dante696; August 15th, 2018 at 11:18 PM. Reason: merged 2 posts

  4. #4
    Join Date
    August 2018
    Posts
    2
    I have the same issue. Since updating i can only connect from the same machine, but not from any other one. Since i didn't update the server in a long time my only idea would be that there's a port which has to be opened or some setting to be set?

    I have no idea what's causing this issue..

  5. #5
    Join Date
    August 2018
    Posts
    4
    when you connect to the server do you use your local network IP or Public?

    Quote Originally Posted by Chris View Post
    Did the local IP change maybe?
    You could try from a mobile device with WiFi disabled.
    My first thought as well, might be worth a check to see if your LAN IPV4 for your computer has changed, this would explain you being able to connect and your mates not being able to, my thinking behind this being that if you can connect the problem isn't with your computer/the server itself, its much more likely to be a protocol/address/port problem instead.

  6. #6
    Join Date
    August 2018
    Posts
    4
    Quote Originally Posted by Parsley View Post
    Thanks for the reply.

    My external IP has not changed.
    I will try from a mobile device without wifi later tonight.

    If needed i can request a client log from one of my friends if that could help you? Not sure if they exist?

    (local IP didn't change either. I've checked that when i checked the port forwarding on my router.)
    maybe try downloading another set of fresh teamspeak files and see if you can host a server from them? just so you can validate whether it may be a file or a firewall problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: October 14th, 2015, 11:24 AM
  2. Server sporadically not accessible although running
    By Kogeri in forum Linux / FreeBSD
    Replies: 3
    Last Post: March 15th, 2013, 02:21 PM
  3. [Resolved] Seting server accessible @ sub.domain but inaccessible @ domain ?
    By PotHEdd in forum Server Support
    Replies: 2
    Last Post: March 17th, 2011, 10:58 AM
  4. console always accessible
    By Bugingbullet in forum Windows
    Replies: 2
    Last Post: December 26th, 2009, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •