Forum

Page 1 of 3 123 LastLast
Results 1 to 15 of 36
  1. #1
    Join Date
    June 2008
    Posts
    18,409

    [Discussion] TeamSpeak 3 Client 3.2.2 Beta

    Here you can leave your feedback about the client 3.2.2 beta version.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #2
    Join Date
    January 2016
    Posts
    12
    Thanks for the update, testing it out with Task Force Arrowhead Radio (TFAR) and ACRE2 plugins for Arma 3.

  3. #3
    Join Date
    August 2016
    Posts
    4
    TFAR dev here. Thanks for the fix o7
    Didn't get confirmation about it being fixed yet, but checking if something doesn't freeze can take quite a long time

    Already eagerly waiting for TS5 to break everything again in the future and us having to switch to Mumble o7
    This bug was already making me and ACRE Team push forward on preparations for that.

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,371
    This client also prevents connecting to hacked servers that have more slots or more users than their license allows.

  5. #5
    Join Date
    August 2018
    Posts
    1

    Yeet

    Will this also work with the ACRE2 plugin?

  6. #6
    Join Date
    April 2018
    Posts
    4
    I got two users with one freeze each while using my plugin (not TFAR) so far.
    Don't know if it's TS related tho (might be a code issue?), the last log entry is:
    Code:
    2018-08-23 18:54:40.298812|        |KeyBindings   |   |Default monitoring disabled
    EDIT:
    Also got a crash, uploaded the dump.

    EDIT2:
    I just keep uploading logs and dumps i get.
    Attached Files Attached Files
    Last edited by KnallErbse; August 23rd, 2018 at 10:23 PM.

  7. #7
    Join Date
    August 2016
    Location
    Italy
    Posts
    2
    Hi,

    we're testing now this beta. We find an error in max client before unvalid license disconnection.
    Beta client actually count "Normal user" + "Query User", instead the verification of real client.

    In server info we actually see in "Current Clients" Normal user + Query User.

    For example:
    100 Real client
    2 Query

    Current Clients: 102


    Waiting for a reply, I wish you best regards.

  8. #8
    Join Date
    January 2016
    Posts
    12
    So far so good. During al day no freeze at all. Working fine. Thank you

  9. #9
    Join Date
    June 2008
    Posts
    18,409
    Quote Originally Posted by KnallErbse View Post
    I got two users with one freeze each while using my plugin (not TFAR) so far.
    We are evaluating your crash.

    Quote Originally Posted by mondyx92 View Post
    we're testing now this beta. We find an error in max client before invalid license disconnection..
    We will release a new beta to fix this issue.

    Quote Originally Posted by By-Jokese View Post
    So far so good. During al day no freeze at all. Working fine. Thank you
    Good news! Thank you for your feedback.

    Update 1

    A new beta will not be released this week. We found another crash related to max clients in server and want to fix this first.
    Last edited by thorwe; August 24th, 2018 at 06:09 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    May 2016
    Location
    Idar-Oberstein
    Posts
    163
    Hi Foxtrott, KnallErbse & other plugin devs.
    The first beta 3.2.2 took some measurements to battle the freeze when you call TS functions from within onEditPostProcessVoiceDataEvent and onEditMixedPlaybackVoiceDataEvent.
    The upcoming beta 2 should take care of onEditPlaybackVoiceDataEvent and onEditCapturedVoiceDataEvent.
    Please report if any issue remains, we'll see what we can do.

    We cannot make much sense of the crash dump forwarded by @KnallErbse yet.
    It'd be cool if I could get my hands on the plugin and ideally the source to test and look over.

    So, the current code base / releases of those plugins should work as before now or, in case of the usage of the aforementioned callbacks once beta 2 is up.

    That said, I'd like to humbly advise against calling TS functions from within audio callbacks whenever possible.
    Despite things having worked out so far - until 3.2.0 that is - in an audio best practice sense, it should be avoided.
    With audio running in dedicated high priority threads, it might not necessarily be a crash but e.g. priority inversion is only a lock away.

    A couple of hints inspired by code on github:
    * own client id could be cached on connect
    * persistent client identification can be done using the client's unique identifier, (going the extra mile in combo with the client id for clones). Given that this won't change, it can be cached e.g. onClientMove with ENTER_VISIBILITY.
    * if nicknames are necessary there're client update events. Caveat: At this point there's need of protection.
    * getting a client variable can be cached on the client's variable update event. Atomic should suffice if it's not a string, however this will likely be sabotaged by your desire to put it in a container.

    If you guys would meet us half-way on your next update, it'd be appreciated.
    Last edited by thorwe; August 24th, 2018 at 06:26 PM. Reason: was missing an 'of'

  11. #11
    Join Date
    April 2018
    Posts
    4
    Thanks for the work so far, guys.

    After your tips and advise regarding the callbacks, i'll do some changes to the plugin when i have time.

    The crash could also totaly be my fault, i just started "programming" in c++ with this plugin, so... :P
    If you want to have a look at it, that's fine with me. Do you want to wait until the new version is done?
    Feel free to PM me regarding the plugin (since you are also german, you can write in german).

  12. #12
    Join Date
    June 2018
    Posts
    21
    Hello! Since I am updating the 3.2.2 client when I'm not respoding, it does not let me let it work normally when it's not respoding. I need to get out with the teamspeak 3 and go back to normal again.

  13. #13
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,376

    Connection lost because server license can not be validated

    I sometimes (can't reproduce when or why) instantly disconnect from my server after connecting to it.

    The server tab states:
    Code:
    <17:54:58> Trying to resolve hostname ***.de
    <17:54:58> Trying to connect to server on ***.de
    <17:54:59> Connected to Server: "No server"
    <17:54:59> Connection lost because server license can not be validated
    An extract of the clientlog (with two connect attempts):
    Code:
    2018-08-26 15:54:28.103538|INFO    |ClientUI      |8  |Connect to server: ***.de
    2018-08-26 15:54:28.105046|INFO    |ClientUI      |8  |Trying to resolve ***.de
    2018-08-26 15:54:28.118065|INFO    |TSDNS         |   |SRV DNS resolve unsuccessful, "_tsdns._tcp.***.de" DNS server returned answer with no data
    2018-08-26 15:54:28.118201|INFO    |TSDNS         |   |SRV DNS resolve unsuccessful, "_ts3._udp.***.de" DNS server returned answer with no data
    2018-08-26 15:54:28.127537|INFO    |TSDNS         |   |A/AAAA DNS resolve successful, "***.de" =(h: myipv6 p:0), (h: myipv4 p:0)
    2018-08-26 15:54:28.127789|INFO    |TSDNS         |   |A/AAAA DNS resolve for possible TSDNS successful, "***.de" =(h: myipv6 p:0), (h: myipv4 p:0)
    2018-08-26 15:54:28.149289|INFO    |TSDNS         |   |TSDNS queried unsuccessfully myipv6:41144
    2018-08-26 15:54:28.173788|INFO    |TSDNS         |   |TSDNS queried unsuccessfully myipv4:41144
    2018-08-26 15:54:28.173913|INFO    |TSDNS         |   |No TSDNS found
    2018-08-26 15:54:28.174312|INFO    |ClientUI      |8  |Lookup finished: ip=myipv6 port=9987 query=***.de error=0
    2018-08-26 15:54:28.174485|INFO    |ClientUI      |8  |Resolve successful: [myipv6]:9987myipv4:9987
    2018-08-26 15:54:28.174663|INFO    |ClientUI      |8  |Initiating connection: [myipv6]:9987
    2018-08-26 15:54:28.408415|INFO    |ClientUI      |8  |Connect status: Connecting
    2018-08-26 15:54:28.451126|DEVELOP |PktHandler    |   |Puzzle solve time: 3
    2018-08-26 15:54:28.507691|INFO    |ClientUI      |8  |Connect status: Disconnected
    2018-08-26 15:54:28.507965|INFO    |ClientUI      |8  |Disconnected or forced to leave, want autoreconnect = 0
    2018-08-26 15:54:58.503110|INFO    |ClientUI      |8  |Connect to server: ***.de
    2018-08-26 15:54:58.504669|INFO    |ClientUI      |8  |Trying to resolve ***.de
    2018-08-26 15:54:58.524143|INFO    |TSDNS         |   |SRV DNS resolve unsuccessful, "_tsdns._tcp.***.de" DNS server returned answer with no data
    2018-08-26 15:54:58.524293|INFO    |TSDNS         |   |SRV DNS resolve unsuccessful, "_ts3._udp.***.de" DNS server returned answer with no data
    2018-08-26 15:54:58.533909|INFO    |TSDNS         |   |A/AAAA DNS resolve for possible TSDNS successful, "***.de" =(h: myipv6 p:0), (h: myipv4 p:0)
    2018-08-26 15:54:58.534130|INFO    |TSDNS         |   |A/AAAA DNS resolve successful, "***.de" =(h: myipv6 p:0), (h: myipv4 p:0)
    2018-08-26 15:54:58.552997|INFO    |TSDNS         |   |TSDNS queried unsuccessfully myipv6:41144
    2018-08-26 15:54:58.575981|INFO    |TSDNS         |   |TSDNS queried unsuccessfully myipv4:41144
    2018-08-26 15:54:58.576248|INFO    |TSDNS         |   |No TSDNS found
    2018-08-26 15:54:58.577704|INFO    |ClientUI      |8  |Lookup finished: ip=myipv6 port=9987 query=***.de error=0
    2018-08-26 15:54:58.577884|INFO    |ClientUI      |8  |Resolve successful: [myipv6]:9987myipv4:9987
    2018-08-26 15:54:58.578057|INFO    |ClientUI      |8  |Initiating connection: [myipv6]:9987
    2018-08-26 15:54:58.809967|INFO    |ClientUI      |8  |Connect status: Connecting
    2018-08-26 15:54:58.851074|DEVELOP |PktHandler    |   |Puzzle solve time: 6
    2018-08-26 15:54:58.903136|INFO    |ClientUI      |8  |Connect status: Connected
    2018-08-26 15:54:58.959694|WARNING |SCHandler     |8  |Error while parsing packet: unknown error code
    2018-08-26 15:54:58.989507|ERROR   |ClientUI      |8  |Failed to get hostmessage mode
    2018-08-26 15:54:58.996532|INFO    |ClientUI      |8  |Connect status: Establishing connection
    2018-08-26 15:54:59.004720|INFO    |              |   |Failed to get own channel ID when setting 3D sound for whiperer
    2018-08-26 15:54:59.011180|INFO    |ClientUI      |8  |Connect status: Connection established
    2018-08-26 15:54:59.011401|INFO    |PermManager   |   |Requesting permissions from server
    2018-08-26 15:54:59.011690|INFO    |ChatTabWidget |   |Prevented to set an empty chattab name in addNewTab
    2018-08-26 15:54:59.062190|INFO    |ClientUI      |8  |Connect status: Disconnected
    2018-08-26 16:01:59.793024|INFO    |              |   |tried to request user integration info without valid session
    The important part from the server log (I removed some other people joining and some permission/servergroup handling):
    Code:
    2018-08-26 15:54:11.320476|INFO    |VirtualServerBase|1  |client connected 'てんㆁㅆㄤຣ'(id:5) from [mypersonalipv6]:40541
    2018-08-26 15:54:35.829004|INFO    |PktHandler    |1  |Cleaning up connection because of 14 resends of COMMAND packet
    2018-08-26 15:54:35.829403|INFO    |PktHandler    |1  |Dropping client 22 because of resend timeout
    2018-08-26 15:54:36.535059|INFO    |PktHandler    |1  |Cleaning up connection because of 9 resends of COMMAND packet
    2018-08-26 15:54:36.535175|INFO    |PktHandler    |1  |Dropping client 5 because of resend timeout
    2018-08-26 15:54:36.535238|INFO    |VirtualServerBase|1  |client disconnected 'てんㆁㅆㄤຣ'(id:5) reason 'reasonmsg=connection lost'
    2018-08-26 15:54:58.892215|INFO    |VirtualServerBase|1  |client connected 'てんㆁㅆㄤຣ'(id:5) from [mypersonalipv6]:40541
    2018-08-26 15:55:27.812368|INFO    |PktHandler    |1  |Dropping client 14 because of ping timeout 19 0 0
    2018-08-26 15:55:27.813924|INFO    |PktHandler    |1  |Dropping client 18 because of ping timeout 19 0 0
    2018-08-26 15:55:27.813985|INFO    |VirtualServerBase|1  |client disconnected 'てんㆁㅆㄤຣ'(id:5) reason 'reasonmsg=connection lost'

    I am connecting via normal DNS (no tsdns or server nickname).

    If it's important, I use a reserved slot (server was full).

    I also had this issue yesterday when connecting with another identity to it, so the new tab was disconnected and the already connected first tab disconnected with the same error message in the server tab.

    Client Setup:
    Gentoo Linux amd64
    Latest update 3.2.2 (beta channel)

    Server Setup:
    Debian 8 on Linux amd64
    Server 3.3.1, using the free 32 slot (no license)
    Last edited by dante696; August 26th, 2018 at 08:08 PM. Reason: moved

  14. #14
    Join Date
    June 2008
    Posts
    18,409
    Possibly a Query Client caused this (reported above) or we have something new with reserved slots (need to evaluate).
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #15
    Join Date
    September 2005
    Location
    Germany / Dortmund
    Posts
    1,376
    Possibly related, there is a query connected nearly 24/7.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Discussion] TeamSpeak 3 Client 3.2.0 Beta
    By Chris in forum Suggestions and Feedback
    Replies: 55
    Last Post: August 13th, 2018, 09:30 AM
  2. [Discussion] TeamSpeak 3 Client 3.1.8 Beta
    By Chris in forum Suggestions and Feedback
    Replies: 18
    Last Post: January 21st, 2018, 01:19 PM
  3. [Discussion] TeamSpeak 3 Client 3.1.7 Beta
    By Chris in forum Suggestions and Feedback
    Replies: 20
    Last Post: December 13th, 2017, 09:00 PM
  4. [Discussion] TeamSpeak 3 Client 3.1.6 Beta
    By Chris in forum Suggestions and Feedback
    Replies: 10
    Last Post: August 16th, 2017, 01:43 PM
  5. [Discussion] TeamSpeak 3 Client 3.1 [BETA]
    By KIDINK^ in forum Suggestions and Feedback
    Replies: 249
    Last Post: January 10th, 2017, 04:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •