Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    September 2018

    Error: bind failed on

    I am trying to upgrade my teamspeak server to version 3.4.0.
    I have a no-profit license for my Clan that we used for years.
    After several attempts, I managed to execute the installation script correctly, however, the server does not run.
    My server is a Linux Ubuntu 16.04.3 LTS
    Agradesco any help in this regard.
    Attached the log with the errors ...

    2018-09-24 20:54:22.918104|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.4.0 (2018-09-10 07:29:44)
    2018-09-24 20:54:22.918312|INFO |ServerLibPriv | |SystemInformation: Linux 4.4.0-134-generic #160-Ubuntu SMP Wed Aug 15 14:58:00 UTC 2018 x86_64 Binary: 64bit
    2018-09-24 20:54:22.918394|INFO |ServerLibPriv | |Using hardware aes
    2018-09-24 20:54:22.920321|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2018-09-24 20:54:22.920421|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2018-09-24 20:54:22.920932|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2018-09-24 20:54:22.941763|INFO |SQL | |db_CreateTables() tables created

    I M P O R T A N T
    Server Query Admin Account created
    loginname= "serveradmin", password= "xxxxxxx"

    2018-09-24 20:54:23.002407|INFO |Accounting | |Licensing Information
    2018-09-24 20:54:23.002479|INFO |Accounting | |type : Non-Profit License
    2018-09-24 20:54:23.002528|INFO |Accounting | |starting date : Thu Jul 12 00:00:00 2018
    2018-09-24 20:54:23.002544|INFO |Accounting | |ending date : Tue Jan 29 00:00:00 2019
    2018-09-24 20:54:23.002556|INFO |Accounting | |max virtualservers: 10
    2018-09-24 20:54:23.002567|INFO |Accounting | |max slots : 512
    2018-09-24 20:54:23.059491|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2018-09-24 20:54:23.415018|INFO | | |Puzzle precompute time: 395
    2018-09-24 20:54:23.415544|ERROR |FileManager | |bind failed on; reason: Address already in use
    2018-09-24 20:54:23.415627|ERROR |FileManager | |bind failed on [::]:30033; reason: Address already in use
    2018-09-24 20:54:23.415665|ERROR |FileManager | |Could not bind filetransfer listen port on default addresses
    2018-09-24 20:54:23.415693|CRITICAL|VirtualSvrMgr | |Could not start file manager 258 no network port available

  2. #2
    Join Date
    September 2012
    Quote Originally Posted by cc-maz View Post
    2018-09-24 20:54:23.415544|ERROR |FileManager | |bind failed on; reason: Address already in use
    2018-09-24 20:54:23.415627|ERROR |FileManager | |bind failed on [::]:30033; reason: Address already in use
    Took the liberty of highlighting the error.

    You didn't actually update, but created a new installation that you're starting.
    The old server is still running as well.

    You need to stop the old server, replace all its files with the new server package files and then start it again.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    September 2018

    problem solved

    Hello, thanks for answering.
    You were right, my mistake was trying to start the server with the "", which apparently left the ports taken.
    Solution: Restart the pc, delete the installation folder of the TS and try again. I made an empty text file called ".ts3server_license_accepted", and now with the command " start" everything worked fine.
    Apparently, the issue is complicated when trying to accept the license.

    Problem solved, thank you very much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3ANetwork Bind failed error: 98
    By meliorus in forum Linux / FreeBSD
    Replies: 10
    Last Post: July 2nd, 2018, 09:27 PM
  2. Error on server start "bind failed"
    By Magnetto in forum Server Support
    Replies: 11
    Last Post: November 1st, 2016, 10:16 AM
  3. Replies: 14
    Last Post: March 12th, 2012, 04:19 PM
  4. Replies: 7
    Last Post: February 14th, 2011, 05:38 PM
  5. Replies: 1
    Last Post: December 14th, 2010, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts