As far as I see, the Linux Teamspeak server uses a statically linked libssh 0.7 for providing the new ssh serverquery access.
According to https://www.heise.de/security/meldun...n-4193260.html there is a serious security bug in libssh 0.6 and above that requires immediate fix. Unpatched servers are allowing serverquery access without providing credentials.

See also:
https://www.libssh.org/security/advi...2018-10933.txt

Is a vulnerable libssh 0.6 or above used in Teamspeak server 3.4.0?
If yes, when is an update available?