Forum

Results 1 to 5 of 5
  1. #1
    Join Date
    February 2017
    Posts
    4

    Microphone does not work in macOS Mojave (10.14)

    I've been using TeamSpeak on my Mac for a long time, and it's worked great for years. I updated to Mojave (macOS 10.14) and TeamSpeak isn't recognizing input from my microphone. Neither push to talk, continuous transmission, nor voice activation detection are working. I wonder if TeamSpeak needs to request access to the microphone on Mojave via System Preferences > Security & Privacy > Privacy > Microphone? Not sure what I can provide for debugging here. I looked at the client log and didn't see anything useful there.

  2. #2
    Join Date
    June 2008
    Posts
    17,839
    I can not confirm this.

    After updating to Mojave i get asked if the client is allowed to use the Microphone. And then i can talk and the client appears under ..Security & Privacy -> Microphone.
    And only if i deny or remove the access under ....Security & Privacy -> Microphone I'm not able any longer to use the microphone.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2017
    Posts
    4
    Yeah that’s what I was afraid of. I’m not getting prompted to allow TS3 to use the microphone. I also don’t see any way to forcibly add TS3 to the allowed applications pane for Privacy > Microphone. Is there a way to force TS3 to ask for permission again or reset things so I can get prompted again?

  4. #4
    Join Date
    June 2008
    Posts
    17,839
    The client itself is only triggers the the feature in your operation system because a microphone was detected. The client itself has no control over it.
    I would suggest that you add the App (as before) but i did not find a way to do that.

    Maybe no microphone was detected at all? Are you sure you have a working mic connected?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    February 2017
    Posts
    4
    Yeah, my bad. I tried this on another machine running Mojave and it worked fine. I'm going to chalk this up to hardware error. Sorry for the noise. You guys can close this out or consider it a non-issue, I think.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Microphone doesnt work
    By Visoplex in forum Windows
    Replies: 0
    Last Post: March 23rd, 2014, 11:27 AM
  2. my microphone wont work
    By Impacts in forum General Questions
    Replies: 1
    Last Post: August 5th, 2011, 03:26 PM
  3. Microphone does not work TS3
    By tng!! in forum Windows
    Replies: 12
    Last Post: June 13th, 2010, 04:42 PM
  4. Microphone does not work TS3
    By tng!! in forum Bug Reports [EN/DE]
    Replies: 12
    Last Post: June 13th, 2010, 04:42 PM
  5. Trying to get my microphone to work
    By stealthbob in forum Client Support
    Replies: 4
    Last Post: January 16th, 2010, 01:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •