Results 1 to 2 of 2
  1. #1
    Join Date
    December 2018

    Port Issue (error codesystem:22 Invalid argument)

    I've decided to try and start a free license Teamspeak server on linux using PuTTY. I started it up with a simple command line after installing it:

    ./ start license_accepted=1

    Then, I connected and it worked fine. I asked for my friend to test it, and he couldn't connect to it. I assumed it was because I didn't have the 9987 port forwarded. Because I didn't want to open that port, I decided to try and change the port (and I reinstalled the server as that is what the internet told me to do). Then, I put in this command line (as my first starting line):

    ./ start license_accepted=1 default_voice_port=25567

    That seemed to not want to work, and gave this error message:

    2018-12-31 04:29:44.241967|ERROR |UDPServers | |could not bind * port 9987 error codesystem:22 Invalid argument
    2018-12-31 04:29:44.242112|ERROR |VirtualServer |1 |bind failed on *:9987
    2018-12-31 04:29:44.242394|CRITICAL|VirtualServerBase|1 |Could not bind virtual server address/port: 257 unable to bind network port

    That confused me, as it seemed like it was trying to connect to 9987 port still, when I was trying to change it to 25567 (a port I had open). So, I tried a view other command lines such as:

    ./ start license_accepted=1 default_voice_port=25567 voice_ip=*
    ./ start license_accepted=1 default_voice_port=25567 filetransfer_port=25566 filetransfer_ip=* query_ip=* query_port=25565 voice_ip=*

    And I also tried using ./ instead of ./, and still received the same problem.

    So my question is, what is the problem, and how can I solve it? Thank you.

  2. #2
    Join Date
    June 2008
    You did set * as IP, but is not a valid address. for IPv4 and :: for Ipv6 are valid addresses if you plan to assign all available addresses.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts