Forum

Results 1 to 13 of 13
  1. #1
    Join Date
    December 2009
    Location
    Poland
    Posts
    83

    Server crashed - failure ecc_import.c:100

    teamspeak3-server_linux_amd64-3.5.1

    Server crashed after the following error
    Code:
    LTC_ARGCHK 'in != NULL' failure on line 100 of file ../../../../s/deps/ts_tomcrypt/src/pk/ecc/ecc_import.c

  2. #2
    Join Date
    June 2008
    Posts
    18,003
    edit
    Please download and install server 3.7.0
    https://www.teamspeak.com/en/downloads/#server



    Is this reproducible?

    Can you update to server 3.6.0 and send us a crashdump (see changelog) in case it happens again?
    Last edited by dante696; March 24th, 2019 at 10:09 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    December 2009
    Location
    Poland
    Posts
    83
    Hello Dante,
    it was only one time on one of our customer. The server was just running and he didn't notice anything abnormal. It isn't reproductible - nobody knows what happend. I am waiting for stable version and then I will update all servers to 3.6.0.

  4. #4
    Join Date
    June 2008
    Posts
    18,003
    Ok. Thanks for the Feedback. We have an idea but can not say without a crash dump.
    The stable version will be released tomorrow. That's the plan so far.

    Update
    The stable version was released
    https://forum.teamspeak.com/threads/138675
    Last edited by dante696; January 22nd, 2019 at 08:28 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    March 2019
    Posts
    2

    Crash on Debian 8 server

    edit by mod server is outdated.
    an update will help


    Today found my server stopped.

    Version: 3.6.1.

    Crashdump in attach.
    ts3server_3_6_1_linux_amd64_30ed-9338-1c80-0ccf.dmp

    If needed additional things (like core environment), please write.
    Last edited by dante696; March 24th, 2019 at 10:13 PM. Reason: merged

  6. #6
    Join Date
    March 2018
    Posts
    6

    Server crashes over and over again after working fine for months.

    Hello, my server was working perfectly for months, may have crashed once after 50, and a few days ago after 12 days, but restarted automatically. Today, my server crashed 5+ times, and I did not change anything!
    Ts│Server version: 3.5.1, now updated to 3.6.1, but the same problem.
    OS: Ubuntu 16.04
    32gb ram;
    16 CPU vCores
    1TB SSD...

    Today I waited for the crash and it returns:
    HTML Code:
    :/etc/init.d# LTC_ARGCHK 'in != NULL' failure on line 100 of file ../../../../s/deps/ts_tomcrypt/src/pk/ecc/ecc_import.c
    
    ts3server has crashed. A crashdump has been generated at "/home/ts3/crashdumps/ts3server_3_6_1_linux_amd64_db64-6364-dea1-62c7.dmp"
    crashdumps have been added. (3 pieces)
    Last edited by dante696; March 24th, 2019 at 10:10 PM. Reason: merged

  7. #7
    Join Date
    December 2015
    Posts
    267
    Maybe try a non-outdated server version (3.7.0) where also server crash was fixed.
    Fixed: Server crash when a client sent a malformed login.
    Last edited by dante696; March 24th, 2019 at 10:09 PM. Reason: merged

  8. #8
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    Hello dante696

    got the message as in the thread post #1(3.3.0).
    Updated to 3.6.1 after 2nd time it have happened within 24h.
    Now it crashed 3rd time within same 24h and spit a crashdump file.
    Might have to go for 3.7.0.... while maybe not rly fixing the problem.

    Code:
    LTC_ARGCHK 'in != NULL' failure on line 100 of file ../../../../s/deps/ts_tomcrypt/src/pk/ecc/ecc_import.c
    
    ts3server has crashed. A crashdump has been generated at "***/ts3server_3_6_1_linux_amd64_79ba-fc70-f69c-643e.dmp"

    //Tomas

  9. #9
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    324
    Quote Originally Posted by Tomas View Post
    Hello dante696

    got the message as in the thread post #1(3.3.0).
    Updated to 3.6.1 after 2nd time it have happened within 24h.
    Now it crashed 3rd time within same 24h and spit a crashdump file.
    Might have to go for 3.7.0.... while maybe not rly fixing the problem.

    Code:
    LTC_ARGCHK 'in != NULL' failure on line 100 of file ../../../../s/deps/ts_tomcrypt/src/pk/ecc/ecc_import.c
    
    ts3server has crashed. A crashdump has been generated at "***/ts3server_3_6_1_linux_amd64_79ba-fc70-f69c-643e.dmp"

    //Tomas
    This is crasher used malformed login, that's why your server is crashed, please patch your server version 3.7.0 the current one and this bug is already fixed.

  10. #10
    Join Date
    March 2018
    Posts
    6
    Thanks for all the info, and the fix @dante696.
    So, just to get it right, the bug occured when a user somehow and of somekind failed to logon to my server?
    Or/ and has somebody coded a Teamspeak crasher, and it┤s most likely, that someone crashed my server again & again?

  11. #11
    Join Date
    March 2019
    Posts
    2
    Quote Originally Posted by MXPLRS|Kirill View Post
    edit by mod server is outdated.
    an update will help
    Okay, will test latest.

  12. #12
    Join Date
    January 2019
    Posts
    1
    that was my problem too but i solved it with this download. thanks

  13. #13
    Join Date
    April 2019
    Posts
    1
    Quote Originally Posted by yegane View Post
    that was my problem too but i solved it with this download. thanks
    Thanks for the solution

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failure to connect to server help
    By Ulezz in forum Windows
    Replies: 1
    Last Post: August 30th, 2014, 01:48 PM
  2. failure to connect to server (win 7)
    By penichillen in forum Windows
    Replies: 11
    Last Post: November 26th, 2012, 01:39 PM
  3. Server Crashed and Crashed
    By BlackRain1058 in forum Server Support
    Replies: 15
    Last Post: June 4th, 2011, 04:32 PM
  4. Failure to connect to server
    By Clown_n_ya in forum Windows
    Replies: 3
    Last Post: May 4th, 2011, 10:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •