Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2019
    Location
    USA
    Posts
    13

    SendPluginCommand Problem

    I am relatively new to both C++ and the Client SDK. I am attempting to send data via the plugin command to a specific clientID but it does not seem to be working. It repeatedly gives invalid ID errors.

    https://gyazo.com/84322411deb0fc997a801ebfeeb538e3

    I've spent a while trying to troubleshoot why this isn't working an I honestly just have no clue, I found one other instance of someone having the same problem on this forums from 2013, but there was never any replies to the thread where they posted about it. This issue is really stalling everything I've been working on so I would greatly appreciate any help anyone can offer! Thank you.

  2. #2
    Join Date
    November 2016
    Posts
    22
    Is your project/source code on GitHub, so I might take a look?

  3. #3
    Join Date
    January 2019
    Location
    USA
    Posts
    13
    Quote Originally Posted by Ray.Gamma View Post
    Is your project/source code on GitHub, so I might take a look?
    I did come up with my own solution/work-around by creating my own version of a client targeted command. Here is the github for the plugin though so maybe we can figure out what was causing the original error.
    Last edited by ShadowSwipe; February 21st, 2019 at 08:10 PM.

  4. #4
    Join Date
    November 2016
    Posts
    22
    Ok, so you're no longer stuck. FYI there is no repository DOJ_Radio under your account.

  5. #5
    Join Date
    September 2012
    Posts
    6,077
    You're confusing the parameter type, which is an array of anyID which must be zero terminated.

    So the correct way would be:
    Code:
    anyID targets[2] = {clientID, 0};
    ts3Functions->sendPluginCommand(serverConnectionHandlerID, pluginID.c_str(), client.getDataPacket().c_str(), PluginCommandTarget_CLIENT, targets, 0);
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  6. #6
    Join Date
    January 2019
    Location
    USA
    Posts
    13
    Thank you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question regarding sendPluginCommand
    By MadStyleCow in forum General Questions
    Replies: 0
    Last Post: September 11th, 2013, 10:34 PM
  2. sendPluginCommand packet guarantee?
    By NouberNou in forum Client Plugins / Lua Scripts
    Replies: 2
    Last Post: April 16th, 2012, 11:23 AM
  3. [Fixed?] sendPluginCommand defined scope still not respected
    By jaynus in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: August 27th, 2010, 01:48 PM
  4. [PLUGIN API] sendPluginCommand SCOPE is not respected
    By jaynus in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: July 2nd, 2010, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •