Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    September 2017

    [Possible Bug] Teamspeak causing audio stutter and issues with USB devices.


    I have discovered a possible bug which I have pounded my head into my desk for a while now and could not figure out what was going on.

    Starting a few months ago I started having issues with audio stutter that occurred every time I would move my mouse (Razer naga epic chroma)which would also stutter as if I was really far from my receiver but I was even having issues with the mouse and head set on wireless and wired mode. My headset is a g933 from logitech but the stutter affected my sound card and speakers as well. At first I thought this was a simple USB hub issue so I started replacing those with no luck. While unpluggedin the devices and plugging them back in resolves the issue for the most part it did not fully. What I mean by that is if I unplugged my mouse and plug it back it, it resolves the movement stutter and audio lag but causes the razer software to not respond making my lights and macros not work. The only solution I found was to restart my computer entirely, so I thought. Since, in recent time I have discovered that closing teamspeak resolves all problems and how I discovered this was strange. Teamspeak is pretty much open 24/7 or anytime my computer is running. The other day I got fed up and start closing everyhing on my computer, everything by teamspeak as I just in my head thought no way would that be an issue. Well, After closing everything and it not resolving my issues still I just restart my computer which at the time I only had ts open. Nearly immeditally after clicking restart and ts closing I heard a large amount of device disconnect and reconnect sounds. which got me thinking.

    Since then I waited for the computer to become unusable again and at the time closed teamspeak and what do you know, everything returns to normal. Audio is fine on both my headset and my speakers, mouse movement returns to normal.

    I don't know if this will be easy to locate and I know this is a long post, Tl;Dr it seems that teamspeak is causing some issues with USB drivers and devivces. I thought this was just my computer till a friend in my teamspeak started having the exact same issue. I had him explain it and then had him try my fix and sure enough same results that everything returns to normal. Personally I find myself restarting teamspeak 2-3 times a day now where I used to leave my computer and teamspeak running for months at a time without issue. This has only come and gotten worse over the last 1-3 updates that I have received.

  2. #2
    Join Date
    November 2017


    I have the same issue; I'm using Windows 10 on a fairly powerful desktop machine (i5-7600k prime95-stable at 5.0GHz, 16GB 2400MHz RAM) and I experience the same issue even with the computer idle. If I leave TeamSpeak running, it will start to show spikes in CPU usage when I move my mouse. The spikes become higher over time and often result in significant audio errors and other system lag after a few hours. I have not been using TeamSpeak much because of this, and I have no idea what to do to fix it. I've tried reinstalling the program, and it made no difference.

  3. #3
    Join Date
    April 2018

    Same Issue

    I have the same issue using the Logitech G933. If I close the client the issue clears up for a few minutes and comes right back. I've tried plugging into different USB ports and I've uninstalled and reinstalled both the 32 bit and 64 bit versions of the client. Using a different codec doesn't seem to help either. This problem is very annoying. Thinking about switching to Ventrilo. We used that for years without problems before switching to TS because other friends were using it and the sound quality did seem better. However, restarting the client every 5 to 10 minutes is not an acceptable solution.

  4. #4
    Join Date
    March 2017

    iRacing degrades the longer TeamSpeak is running

    I am having a similar but different issue where iRacing will slowly degrade. Frame rates get slower and slower over a 10-20 minute period. Significant stuttering will start occurring with the video and the voice chat. Interestingly enough, the engine sounds are not affected. I'm using a Z300 wireless headphones from Turtlebeach. I also can close Teamspeak and everything goes back to normal instantly. If I restart Teamspeak, it will slowly degrade again.

  5. #5
    Join Date
    April 2018
    I was just able to replicate the issue with Teamspeak running but not connected to a server and no game running. Eventually my mouse movement pauses when moving the mouse around. When I close teamspeak the issue goes away. My group is thinking about converting our server to Ventrilo. Luckily my friends are willing to do this for me, as I'm the only one of 6 people experiencing this issue.

  6. #6
    Join Date
    April 2018
    My experience is exactly the same as this.

  7. #7
    Join Date
    March 2019
    I'm having a similar issue. Over time, TeamSpeak starts to cause high CPU. This is while using Logitech G633. This affects gameplay and requires a restart of TeamSpeak to alleviate the problem temporarily. I believe it is directly related to the headsets microphone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak is causing performance issues on Windows 8
    By SunnyChoppers in forum Windows
    Replies: 0
    Last Post: July 9th, 2016, 06:33 AM
  2. Replies: 1
    Last Post: August 21st, 2015, 09:48 AM
  3. [Resolved] TeamSpeak 3 Overlay plugin 3.4.12 Causing major issues
    By tommy45 in forum Windows
    Replies: 7
    Last Post: May 20th, 2012, 09:57 PM
  4. [Resolved] Problem with capture and audio devices.
    By .:Paul:. in forum Bug Reports [EN/DE]
    Replies: 4
    Last Post: February 25th, 2011, 08:03 AM
  5. Mapping servers to audio devices
    By wendelin in forum General Questions
    Replies: 1
    Last Post: January 16th, 2010, 04:32 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts