Forum

Results 1 to 8 of 8

Hybrid View

  1. #1
    Join Date
    May 2018
    Location
    Germany
    Posts
    4

    [BBCode] Embed User Avatar in Channel Description

    Hello,

    I tried to embed a user avatar as image in a channel description, but it won't work. It always displays this blocked icon or a file icon.

    If I do it like an download URL I can download it with that:

    avatar_gommdemeackinmpafmklpplackfapkdhnofoafbn

    So how can I embed this as image?
    Last edited by fredisz; April 8th, 2019 at 04:05 PM. Reason: This is now a bug report not a question anymore

  2. #2
    Join Date
    August 2015
    Posts
    30
    How are you going to do that?

    If I understand you correctly you try to get the avatar a user is using (what he gave hisself) and get it back through the saved image of the server to make it visible as a channel description picture, right?

    which command are you using for it?
    I did not try to get the avatars yet and can't get in touch but maybe I have a hint for you (since it lacks a bit of information here)
    [IMG]ts3image://{FILENAME}?channel={CHANNELID}&path={PATH}/[/IMG]
    Maybe it could work with it... I don't know if you can use 0 as CID for the server or just leave it empty and then use the path of the server folders. For getting pictures out of an upload folder of a channel it works at least.
    Maybe dante has an idea or numma will come around the corner with another hint

  3. #3
    Join Date
    May 2018
    Location
    Germany
    Posts
    4

    Exclamation

    Thank you, it works with your solution, as channel id you will need 0 and as path you need /, so for example:
    [IMG]ts3image://avatar_bihmkeccldipbnnfignofiffgobodnfdloljoogp?ch annel=0&path=/[/IMG]

    But it will only work on TeamSpeak for Android, on the PC it will only display this blocked icon so, this is now a bug I have found.

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,335
    After analyzing the TeamSpeak client's behaviour, I'd say that this is intentionally blocked.

  5. #5
    Join Date
    August 2015
    Posts
    30
    Alright! Nice to know it worked. Normally I would try it myself but the time to get some stuff done is just sadly not available at the moment.
    Let's hope there will be a solution to get it working. I am not sure if it is meant to be blocked since it is the same for stored icons on the server instead of a channel. Here the old hint about how to use it came from dante afair.
    I wonder if one could use a workaround until that since you need to get the avatars name anyways you could try getting a script up to save the image automaticly as file on the server (machine) and use http to bring it back in the [IMG] tags. Not nice but could work in my imagination.

  6. #6
    Join Date
    August 2015
    Posts
    30
    Damn I was searching for the old threat to find it but sadly it is just gone for now - maybe I will remember it then I will link it here.
    At the research I found this:
    https://forum.teamspeak.com/threads/...877#post375877

    Maybe that helps it I don't know if that could/would work (the white on white part)

    I'll check back later.

    -- EDIT --
    Found it - maybe there are some information which could help to be used. It was written on page 2 that it would work with ts3file:// being loaded from channel 0 but you would still get error codes. I wonder if that was getting blocked now or we could use it as a workaround until we get a statement for why it should not get implemented (since I don't see a problem with that at the moment).
    https://forum.teamspeak.com/threads/...ag-with-client
    Last edited by lightpsycho; April 8th, 2019 at 08:40 PM. Reason: More research leads to more information avoided tripple post - see EDIT part

  7. #7
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,335
    Quote Originally Posted by lightpsycho View Post
    I am not sure if it is meant to be blocked since it is the same for stored icons on the server instead of a channel.
    The behaviour is: The client does not even attempt to download avatars. No query commands are caused (either ftgetfileinfo or ftinitdownload).
    IIRC, icons do still work, don't they?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Rejected] Client / channel description - [video][/video] BBcode
    By Daniel180 in forum Suggestions and Feedback
    Replies: 21
    Last Post: September 6th, 2013, 07:30 PM
  2. Monospace BBCode in channel description
    By Djinndrache in forum Suggestions and Feedback
    Replies: 0
    Last Post: June 9th, 2013, 02:15 PM
  3. Replies: 2
    Last Post: March 12th, 2012, 09:35 AM
  4. BBCode in member description
    By Tshaar in forum Suggestions and Feedback
    Replies: 0
    Last Post: September 21st, 2011, 11:47 AM
  5. Replies: 1
    Last Post: April 26th, 2011, 03:46 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •