Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    April 2014

    ftinitupload always returns parameter not found?

    so currently trying to get filetransfer via query working but always when trying to get the ftkey via ftinitupload I always receive an error response.
    I currently try with TeamSpeak Server Version 3.7.1 running via docker on my local windows machine.
    The command i use:

    ftinitupload name=\/icon_2949460685 cid=0 size=245 clientftfid=5648 resume=0 overwrite=1
    error id=1539 msg=parameter\\snot\\sfound
    Is the "parameter not found" response because I miss a parameter or because I have too much?
    As far as the documentation goes I seem to have all the required parameters

    Initializes a file transfer upload. clientftfid is an arbitrary ID to identify the file transfer on client-side. On success, the server generates a new ftkey which is required to start uploading the file through TeamSpeak 3's file transfer interface. Since version 3.0.13 there is an optional proto parameter. The client can request a protocol version with it. Currently only 0 and 1 are supported which only differ in the way they handle some timings. The server will reply which protocol version it will support. The server will reply with an ip parameter if it determines the filetransfer subsystem is not reachable by the ip that is currently being used for the query connection.
    i_ft_needed_file_ upload _power
    ftinitupload clientftfid={clientFileTransferID} name={filePath} cid={channelID} cpw={channelPassword} size={fileSize} overwrite={1|0} resume={1|0} [proto=0-1]
    ftinitupload clientftfid=1 name=\/image.iso cid=5 cpw= size=673460224 overwrite=1 resume=0
    clientftfid=1 serverftfid=6 ftkey=itRNdsIOvcBiBg\/Xj4Ge51ZSrsShHuid port=30033 seekpos=0 proto=0
    error id=0 msg=ok
    am I doing something wrong or is it a bug? (I also tried adding the optional proto parameter)
    Even when I only use ftinitupload i get the same error response

  2. #2
    Join Date
    April 2014
    alright I just found out that it was somehow my own stupidity, it seems that you need to send the empty cpw= parameter also

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Channelist returns subscription power 0
    By C0kkie in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: June 8th, 2018, 08:24 AM
  2. How to actually use ftinitupload
    By leejw00t354 in forum Server Support
    Replies: 2
    Last Post: August 22nd, 2016, 09:44 PM
  3. [Resolved] Disconnect from server: parameter not found
    By Hansz in forum Linux
    Replies: 4
    Last Post: November 3rd, 2015, 08:22 AM
  4. Problems with ftinitupload
    By JoBa97 in forum Server Support
    Replies: 17
    Last Post: May 7th, 2014, 04:55 PM
  5. [Resolved] "parameter not found" when connecting with a generated privilege key
    By catalin in forum Server Support
    Replies: 5
    Last Post: August 3rd, 2012, 02:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts