We have just released a very important security update for the TeamSpeak 3 Client addressing a Remote Code Execution vulnerability in the Qt framework. Please upgrade your desktop clients to version 3.2.5 immediately. The update is available for Windows, Linux and macOS. Mobile clients for Android and iOS are not affected by this issue.

You can use the auto-update feature to grab this new release. If you need an installer, please refer to our Downloads page.

Here's the full changelog:

Code:
=== Client Release 3.2.5 17 Apr 2019
 - Fixed Qt security vulnerability
DOWNLOAD NOW



*** IMPORTANT ***
We strongly recommend that all server providers and admins change the minimum desktop client version for users required to connect to the server.

increase the minimum client version via ServerQuery
Use the following commands via ServerQuery (per default running on TCP port 10011) to do this:

Code:
// authenticate with your serveradmin account (generated during initial server start)
login username password

// change default settings for virtual servers you create in the future
use 0           
serveredit virtualserver_min_client_version=1555517253

// repeat this for all existing virtual servers in the TeamSpeak instance
use port=9987   
serveredit virtualserver_min_client_version=1555517253
use port=9988   
serveredit virtualserver_min_client_version=1555517253
...
No restart is required when you're using ServerQuery to change the settings.




We sincerely apologize for any inconvenience caused. At TeamSpeak, we take security very seriously so we will continue to provide security updates for TeamSpeak 3 while our team is also working on getting the next generation TeamSpeak 5 Client ready for Beta.

Feel free to discuss this release here.