Forum

Page 11 of 11 FirstFirst ... 91011
Results 151 to 160 of 160
  1. #151
    Join Date
    June 2008
    Posts
    18,240
    Please try to reboot your Windows server and then start the ts server.
    We found an issue when uptime on Windows is high. That one will be fixed in next server update.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #152
    Join Date
    October 2014
    Posts
    60

    failed to register local accounting service

    Well I could do with a little help from knowledgable people again.

    I've built a server from the TS3 SDK.
    It's basically the server example that ships with the SDK.

    All works well except...

    A user of my app has come across the following issue which closes the server instantly.

    Code:
    2019-04-27 11:01:29.605760|ERROR   |Accounting    |   |failed to register local accounting service
    2019-04-27 11:01:29.605760|ERROR   |ServerLibPriv |   |Server() error while starting servermanager, error: instance check error
    I've searched and see this is also a known issue with the standard TS3 server.

    Ive found solutions for linus regarding file permissions, but as this is a 32bit windows app I've not come across anything that fixes that.

    Can anybody point me in the right direction?

    Roo

  3. #153
    Join Date
    March 2013
    Posts
    3

    Server dumps every 15 minutes on the dot.....

    Trying to resurrect my ancient Windows based TS server - Got everything set up - outside users can connect just fine through my ASA however every 15 minutes on the mark the server dumps - I have a service starter so the server comes back up within 5 seconds or so but it is maddening to listen to it dump and restart.

    Currently using server 3.9.1

    Logs don't have anything super helpful - here's the latest 4 on the for the last dump.

    2019-09-02 03:10:12.087360|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
    2019-09-02 03:10:12.087360|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
    2019-09-02 03:10:12.087360|INFO |ServerLibPriv | |Using hardware aes
    2019-09-02 03:10:12.102983|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2019-09-02 03:10:12.102983|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2019-09-02 03:10:12.102983|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2019-09-02 03:10:12.118608|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2019-09-02 03:10:12.118608|INFO |Accounting | |Licensing Information
    2019-09-02 03:10:12.118608|INFO |Accounting | |licensed to : Anonymous
    2019-09-02 03:10:12.118608|INFO |Accounting | |type : No License
    2019-09-02 03:10:12.118608|INFO |Accounting | |starting date : Tue Jan 1 00:00:00 2019
    2019-09-02 03:10:12.118608|INFO |Accounting | |ending date : Fri Jan 31 00:00:00 2020
    2019-09-02 03:10:12.118608|INFO |Accounting | |max virtualservers: 1
    2019-09-02 03:10:12.118608|INFO |Accounting | |max slots : 32
    2019-09-02 03:10:12.259240|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2019-09-02 03:10:14.790622|INFO | | |Puzzle precompute time: 2639
    2019-09-02 03:10:14.806249|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2019-09-02 03:10:14.821870|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
    2019-09-02 03:10:14.821870|INFO |Query | |listening for query ssh on 0.0.0.0:10022, [::]:10022
    2019-09-02 03:10:14.821870|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    2019-09-02 03:25:15.418568|ERROR |Accounting | |failed to register local accounting service: The system cannot find the file specified.

    2019-09-02 03:10:14.821870|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
    2019-09-02 03:25:15.481071|INFO |VirtualServerBase|1 |stopped

    2019-09-02 03:25:16.652989|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
    2019-09-02 03:25:16.652989|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
    2019-09-02 03:25:16.652989|INFO |ServerLibPriv | |Using hardware aes
    2019-09-02 03:25:16.652989|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2019-09-02 03:25:16.652989|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2019-09-02 03:25:16.652989|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2019-09-02 03:25:16.668615|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2019-09-02 03:25:16.668615|INFO |Accounting | |Licensing Information
    2019-09-02 03:25:16.668615|INFO |Accounting | |licensed to : Anonymous
    2019-09-02 03:25:16.668615|INFO |Accounting | |type : No License
    2019-09-02 03:25:16.668615|INFO |Accounting | |starting date : Tue Jan 1 00:00:00 2019
    2019-09-02 03:25:16.668615|INFO |Accounting | |ending date : Fri Jan 31 00:00:00 2020
    2019-09-02 03:25:16.668615|INFO |Accounting | |max virtualservers: 1
    2019-09-02 03:25:16.668615|INFO |Accounting | |max slots : 32
    2019-09-02 03:25:16.793616|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2019-09-02 03:25:19.262496|INFO | | |Puzzle precompute time: 2557
    2019-09-02 03:25:19.262496|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2019-09-02 03:25:19.278120|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
    2019-09-02 03:25:19.278120|INFO |Query | |listening for query ssh on 0.0.0.0:10022, [::]:10022
    2019-09-02 03:25:19.278120|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,


    2019-09-02 03:25:19.278120|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987

    I opened the following inbound ports for it

    UDP-9987
    TCP-10011
    TCP-30033
    UDP-2008
    TCP-443




    I've:
    Set my server's AV to avoid scanning the directory and sub-directories where it's installed
    Set my ASA to never shun my server



    The only thing I can gather is "failed to register local accounting service: The system cannot find the file specified.' has something to do with it.

    {it's taken me 15 minutes to write this as I just heard it dump and restart in the background}

    I can resolve accounting2.teamspeak.com [104.20.74.196] with 32 bytes of data:
    Reply from 104.20.74.196: bytes=32 time=24ms TTL=59
    Reply from 104.20.74.196: bytes=32 time=21ms TTL=59
    Reply from 104.20.74.196: bytes=32 time=28ms TTL=59
    Reply from 104.20.74.196: bytes=32 time=31ms TTL=59

    out of ideas aside from getting a discord server.

  4. #154
    Join Date
    January 2017
    Location
    Germany
    Posts
    45
    from other similar problems: your windows account used to start the server is missing SE_CREATE_PERMANENT_NAME.

    Source:
    https://forum.teamspeak.com/threads/...367#post459367
    https://forum.teamspeak.com/threads/...nting-service)

    hope it will fix your problem :3

  5. #155
    Join Date
    March 2013
    Posts
    3
    It doesn't help. AlwaysUp (the service wrapper I'm using) is starting the Teamspeak server as the Local System Account (Not a domain account / administrator account - I tried it both ways before hitting the forums) and the LSA has implicit rights - according to Microsoft, "By default, LocalSystem is the only account that has this right" to the "create permanent shared objects" policy in user rights assignments which is what you referenced above. When I go to modify this policy, the buttons are greyed out.

    This is the same service wrapper I was using with 3.0.13.8 and that worked fine.


    I modified the default domain policy and went into user rights assignments and Local System was there - I added my own domain admin account (which you shouldn't need to do) and the Local Service account. Let's see what happens.
    Last edited by mweitsen; September 2nd, 2019 at 08:43 AM.

  6. #156
    Join Date
    March 2013
    Posts
    3
    Basically nothing. Name:  CPSO.png
Views: 63
Size:  54.1 KB so the create permanent shared objects policy has the LSA, the Local Service, and my own domain account. Without rebooting, leaving the LSA as the logon for the service wrapper - nada, still blows up and restarts on the 15 minute mark.

    Rebooted,changed the wrapper login to my domain account and it still dumps.

    I dunno, after running a TS server since the early 2000s maybe a proper installer is due?

    Anyone else have any ideas or is this just a bug or the wrapper itself....or is it time for Discord?

  7. #157
    Join Date
    September 2019
    Posts
    1

    After updating to 3.9.1 server keeps crashing

    Long story short.
    I updated to 3.9.1
    it would not start and the log had nothing that i could see so i tried a new server all together.
    the server would lunch and give me a key as soon as i click close the server shuts down.
    and will not start at all
    The log show.

    2019-09-22 08:12:42.725457|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
    2019-09-22 08:12:42.726392|INFO |ServerLibPriv | |SystemInformation: Windows Server 2012 R2 (9600) x64 (AMD or Intel) Binary: 64bit
    2019-09-22 08:12:42.726392|INFO |ServerLibPriv | |Using hardware aes
    2019-09-22 08:12:42.727433|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2019-09-22 08:12:42.727433|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2019-09-22 08:12:42.728393|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2019-09-22 08:12:42.760402|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2019-09-22 08:12:42.761402|ERROR |Accounting | |failed to register local accounting service: The file exists.
    2019-09-22 08:12:42.762413|INFO |Accounting | |Licensing Information
    2019-09-22 08:12:42.762413|INFO |Accounting | |licensed to : Anonymous
    2019-09-22 08:12:42.762413|INFO |Accounting | |type : No License'
    2019-09-22 08:12:42.762413|INFO |Accounting | |starting date : Tue Jan 1 00:00:00 2019
    2019-09-22 08:12:42.762413|INFO |Accounting | |ending date : Fri Jan 31 00:00:00 2020
    2019-09-22 08:12:42.762413|INFO |Accounting | |max virtualservers: 1
    2019-09-22 08:12:42.762413|INFO |Accounting | |max slots : 32
    2019-09-22 08:12:42.797412|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2019-09-22 08:12:45.720244|INFO | | |Puzzle precompute time: 2916
    2019-09-22 08:12:45.721244|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2019-09-22 08:12:45.751253|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
    2019-09-22 08:12:45.751253|INFO |Query | |listening for query ssh on 0.0.0.0:10022, [::]:10022
    2019-09-22 08:12:45.751253|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, ::1/128,
    The only thing i see of note is "failed to register local accounting service: The file exists."
    I tried to revert to a backup of 3.7.1 and get the simular log

    For note
    Windows 2012 server
    64bit

  8. #158
    Join Date
    November 2019
    Location
    Denmark
    Posts
    2

    TS3 server crashes when playing YouTube video, or a website with YouTube embedded

    Hello

    I have had a strange problem for many months now.

    Whenever i open any type of Youtube video, embedded or directly from Youtube, the TS3 server i'm running closes.
    I get no errors or messages, and everyone on the server gets disconnected.
    After the crash, i can run the server again with no issues, while browsing Youtube. It's first when i close all connections to Youtube, and then reopening Youtube that the server closes again.

    I have tried different browsers, but with no luck. Even the Steam chat makes the server crash, when it contains an embedded Youtube video.

    Running TS3 server 3.9.1 on Windows 10 Pro version 1903, build 18362.418

    Let me know if you need more info.

    Thanks in advance!


    2019-11-10 01:28:14.612809|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.9.1 (2019-07-02 13:17:23)
    2019-11-10 01:28:14.612809|INFO |ServerLibPriv | |SystemInformation: Windows 10 (18362) x64 (AMD or Intel) Binary: 64bit
    2019-11-10 01:28:14.612809|INFO |ServerLibPriv | |Using hardware aes
    2019-11-10 01:28:14.613809|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
    2019-11-10 01:28:14.613809|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2019-11-10 01:28:14.613809|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2019-11-10 01:28:14.625802|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2019-11-10 01:28:14.625802|INFO |Accounting | |Licensing Information
    2019-11-10 01:28:14.625802|INFO |Accounting | |licensed to : Anonymous
    2019-11-10 01:28:14.625802|INFO |Accounting | |type : No License
    2019-11-10 01:28:14.625802|INFO |Accounting | |starting date : Tue Jan 1 00:00:00 2019
    2019-11-10 01:28:14.625802|INFO |Accounting | |ending date : Fri Jan 31 00:00:00 2020
    2019-11-10 01:28:14.625802|INFO |Accounting | |max virtualservers: 1
    2019-11-10 01:28:14.625802|INFO |Accounting | |max slots : 32
    2019-11-10 01:28:14.679771|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
    2019-11-10 01:28:15.379368|INFO | | |Puzzle precompute time: 742
    2019-11-10 01:28:15.380368|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
    2019-11-10 01:28:15.385365|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
    2019-11-10 01:28:15.385365|INFO |Query | |listening for query ssh on 0.0.0.0:10022, [::]:10022
    2019-11-10 01:28:15.386364|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32,
    2019-11-10 01:28:24.627125|ERROR |Accounting | |failed to register local accounting service: Den angivne fil blev ikke fundet.

    2019-11-10 01:28:15.385365|INFO |VirtualServer |1 |listening on 0.0.0.0:9987, [::]:9987
    2019-11-10 01:28:24.627125|INFO |VirtualServerBase|1 |stopped
    Last edited by dante696; November 10th, 2019 at 11:34 AM. Reason: merged

  9. #159
    Join Date
    November 2019
    Location
    Denmark
    Posts
    2
    So not a single person can help with this problem? The server will work for weeks, with no issues at all. It only goes down when connecting to Youtube. Can anyone explain that?

  10. #160
    Join Date
    June 2008
    Posts
    18,240
    We absolutely have no clue why opening YouTube should cause this.

    In most cases it is a permission issue on the system or has to do with Antivirus or a local firewall.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Instance check error / failed to register local accounting service on Linux
    By dani4u87 in forum Linux / FreeBSD
    Replies: 125
    Last Post: November 1st, 2019, 03:19 AM
  2. Replies: 5
    Last Post: June 1st, 2016, 03:11 PM
  3. Replies: 2
    Last Post: August 20th, 2010, 03:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •