Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    October 2014

    Question Server "crash" on sftp disconnect.

    I login into the user that started the Teamspeak server with sftp I don't even have to change a directory, then when I disconnect whether it be from filezilla or winscp, it "crashes" the server.

    If I login with Putty it doesn't "crash" the server.

    I am running Server Version 3.8.0

    This is one of the lines put into logs after the "crash","failed to register local accounting service: No such file or directory"

    I was reading the thread about this problem with "failed to register local accounting service: File exists" I was able to fix that but now I am having this problem with sftp shutting down the server
    Last edited by DigidyDOG; July 8th, 2019 at 04:32 AM.

  2. #2
    Join Date
    October 2014
    I was hoping to get some traction on this thread. I was hoping that the 3.9.1 update would resolve this issue.

    Since there is no crash dump and there is no answers i'll add the logs.

    I hope someone has some answers.

  3. #3
    Join Date
    December 2009
    Check the system log files, did you tried that already?

  4. #4
    Join Date
    March 2017

    Exclamation I am having the same issue

    Hi, I was about to make a thread on this - I am having the exact same problem. Every time I disconnect from SFTP (in FileZilla), I get this single error in the server log:
    2019-08-16 19:16:54.175484|ERROR   |Accounting    |   |failed to register local accounting service: No such file or directory
    and the server immediately shuts down with no other errors.

    This also appears to happen at random every 1-5 days (possibly unrelated to SFTP?) with that exact same error message.

    I am running the latest Fedora Server 30, the latest TS3 Server 3.9.1, and have noticed this issue on multiple fresh Fedora Server 30 installations I am running. This issue has been occurring for at least 2 weeks, every 1-5 days at random, and every time I disconnect from SFTP.

    In case it matters, I am using the LinuxGSM server wrapper to manage the server.

    /dev/shm/7gbhujb54g8z9hu43jre8 exists with the following permissions:
    [[email protected] ~]$ ls -lah /dev/shm
    total 4.0K
    drwxrwxrwt.  2 root           root             60 Aug 16 13:52 .
    drwxr-xr-x. 19 root           root           3.7K Aug 12 02:06 ..
    -rw-r--r--.  1 ts3server-ch22 ts3server-ch22  128 Aug 16 13:52 7gbhujb54g8z9hu43jre8
    The server is not running as root.

    Attached: all log files where this issue has occurred.

    EDIT 1:
    I just did some further testing, and was able to get this issue to randomly occur (WITHOUT SFTP connection/disconnection) on a fresh install of Debian 10.
    1. Deploy Debian 10 VPS on Vultr
    2. Login, update/upgrade/reboot
    3. Install "cockpit" web interface
    4. Follow setup/install procedure for LinuxGSM server wrapper with ts3server on Debian (found here)
    5. Start server, server runs successfully for a random time period (in this case it was only one minute)
    6. Eventually observe server shutdown ("Server has been shut down: Server Shutdown!") with last log entry "failed to register local accounting service: No such file or directory"
    7. Restart server, server will run successfully for a random time period, will eventually crash again with same error

    I am not sure at this point if this issue is directly related to TeamSpeak server, LinuxGSM server wrapper, or the Cockpit web interface, as these are the only non-standard things I am doing on top of the clean Debian 10 install.

    Also very notable - the OP's log files showed he was using Ubuntu Server 16.04, I originally experienced this on Fedora 30, and the above test was done on Debian 10...

    I would be very interested to hear if OP is also using this server wrapper or that web interface. I am stumped here.
    Attached Files Attached Files
    Last edited by stere0123; August 17th, 2019 at 01:07 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 11:39 AM
  2. How to remove "connect" and "disconnect" popups on overlay?
    By Floydrose in forum General Questions
    Replies: 1
    Last Post: July 30th, 2012, 03:35 PM
  3. [Fixed] Disconnect Problem "invalid clientID: 0"
    By Chaos234 in forum Bug Reports [EN/DE]
    Replies: 62
    Last Post: September 22nd, 2010, 08:00 AM
  4. Silencing Teamspeak viewer "connect/disconnect to server"
    By Demona Golgari in forum Permission System
    Replies: 1
    Last Post: January 2nd, 2010, 04:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts