Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    June 2019
    Posts
    1

    TeamSpeak causes all audio to be distorted on Manaro (rolling release)

    TeamSpeak 3 and possibly other programs corrupt output audio stream

    Environment
    `Linux telavus 4.19.49-1-MANJARO #1 SMP PREEMPT Sun Jun 9 20:24:20 UTC 2019 x86_64 GNU/Linux
    List of PLAYBACK Hardware Devices
    playback.txt
    List of CAPTURE Hardware Devices
    capture.txt
    Rest of environment:
    env.txt

    Steps to reproduce
    Launch TeamSpeak3 while listening to audio on a Steinberg CI2 sound card

    What is the current bug behavior?
    When I launch TeamSpeak3 audio begins to crackle on ALL audio output. The problem persists even if I close down TeamSpeak3, as all other audio output (example being Spotify, Foobar2000 or videos on the internet). A partial fix for this is to add 'load-module module-udev-detect tsched=0' (but that brings its own issues) The only way to correct this problem when it has started is to kill the pulseaudio process and restart it. It also seems that SOMETIMES simply launching pavucontrol fixes the problem altogether (Or changing profiles in the Configuration tab, although that makes the input audio distorted), aslong as I dont kill the teamspeak process and open it up again. Its also worth mentioning that despite the Steinberg having Audio input, this is not affected at all and when I speak with others on TeamSpeak they dont notice anything unusual about the input audio.
    Speaker test gives the exact same output when its fine and when its not:
    https://pastebin.com/FpAcz95H
    test_log.txt

    With exception of Time per period = 10.943108

    What is the expected correct behavior?
    Normal audio with no crackling or robotic/metallic sounds.

  2. #2
    Join Date
    August 2015
    Posts
    55
    I wonder if you tried - maybe I overread it - everything while having the CI2 unplugged (as best before powering your PC).

    Also; Could you try to bring a VM running with the same system but no other stuff than the OS, then installing the CI2 and TS3 to get a look on the behaviour then.
    My problem is that I am out of business and don't have the contacts anymore to make the fast setup for myself.

    And something else: You are the first doing a good description since a longer while! At least the hope for a good description brought something

    Anyways, I will try to check back in that threat! Could you also get a soundfile up for an example? If not here there could be some specific things if somebody else should get that problem which I then would find out before reasking from listening

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: October 29th, 2018, 07:31 AM
  2. USB Audio Logitech C270 distorted sounds
    By Deep1984 in forum Windows
    Replies: 3
    Last Post: October 25th, 2017, 05:45 AM
  3. All other audio is distorted when TS3 is running
    By EvoSpyder in forum Windows
    Replies: 5
    Last Post: August 20th, 2016, 02:18 PM
  4. [RELEASE] Dice rolling plugin
    By TheCraiggers in forum Client Plugins / Lua Scripts
    Replies: 79
    Last Post: October 19th, 2012, 11:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •