Forum

Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 33
  1. #16
    Join Date
    June 2008
    Posts
    18,144
    This file looks good and you should be bale to add groups with max needed add power of 75**.
    **As long you do not have channel-client permissions assigned anywhere else.

    That question remains
    Quote Originally Posted by dante696 View Post
    Didn't you say you set client permissions? I don't see any?
    What you cold try is to close the client and search and delete all perm.dat files.
    Open %appdata%/ts3client/cache and search for the file.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #17
    Join Date
    July 2014
    Posts
    25
    Didn't you say you set client permissions? I don't see any?
    I removed those permissions so I would be able to assign server permissions (since I couldn't assign server permissions with those client permissions active).

    I deleted all of the "perm.dat" files. The problem is still there.

    Can I delete some other settings file or should I delete everything and reinstall the program?

  3. #18
    Join Date
    January 2017
    Location
    Germany
    Posts
    42
    I can actully reproduce this Bug on linux and windows o.O

    I have no rights outside the default channel if:

    • I have Serveradmin (skip flag on) + Channel Admin + Client Permission (add/remove power) without skip tag


    It works outside the default channel if:

    • I have Serveradmin (skip flag on) + Channel Admin + Client Permission (add/remove power) with skip tag
    • I have Serveradmin (skip flag on) + Channel Guest + Client Permission (add/remove power) without skip tag


    ...maybe the permission-system tries too often to override the rights and the result are what @Bisquik told us.

  4. #19
    Join Date
    June 2008
    Posts
    18,144
    It's not a bug when you set client permissions and don't set the Skip flag or the Skip permission for client permissions.

    Client permissions have higher priority (Tier) and that way you said you don't want a skip flag. So you don't get one on the client permissions you add.

    edit
    Quote Originally Posted by Bisquik View Post
    I removed those permissions so I would be able to assign server permissions (since I couldn't assign server permissions with those client permissions active).
    How should I be able to find the reason when overview shows a working setup?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #20
    Join Date
    January 2017
    Location
    Germany
    Posts
    42
    I am apparently stupid... *facepalm*

    I thought the client permission is always higher than all, have been wondering all the time why the skip tag is there xD

  6. #21
    Join Date
    June 2008
    Posts
    18,144
    Quote Originally Posted by Senpai_Mizu View Post
    I thought the client permission is always higher than all
    That's the case*.
    *Highest priority are channel-client permission followed by client permissions.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #22
    Join Date
    January 2017
    Location
    Germany
    Posts
    42
    Quote Originally Posted by dante696 View Post
    That's the case*.
    *Highest priority are channel-client permission followed by client permissions.
    I have a short question about this.


    so that means for example:
    I have a specific User and he has default server-/channelgroup (no defined talk power ➜ value=blank)

    If I give this person the client permission (i_client_talk_power=10 + skip) ➜ This Client should have in every Channel a talk power from 10, right?

    ...and let me say, I have 3 Channels (1, 2 and 3), and the client should have in Channel 3 a talk power from 15 ➜ I have to set the channel client permission (i_client_talk_power=15) to the specific channel + client, right?

  8. #23
    Join Date
    November 2016
    Location
    Germany
    Posts
    99
    Correct, or you create a channel group which only grants specific rights like talk power. Easier to control than giving a lot of people client permissions. Also better because you canīt see who has client permissions or channel client permissions as simple as you can check channel groups.

  9. #24
    Join Date
    January 2017
    Location
    Germany
    Posts
    42
    yea I know, the reason why I ask is I get always the value = 222 on my server, no matter what power value I set.
    But apparently this is only on outdated server versions (tested on version 3.6.0), everything works fine on 3.9.1.

  10. #25
    Join Date
    July 2014
    Posts
    25
    Here is my Permissions Overview with the Client Permissions changed so I cannot assign Server Groups.


    That text file is from the Linux server. I guess I missed something when I first posted, because now it is happening there too.

    Although, I did reinstall TS3 Client a few days ago trying to solve this (since I had a 32 bit version [updated] and I upgraded it to the current 64 bit version). I used my old files to backup and restore after the install.

    FYI, the Linux server is 32 bit and the Windows server is 64 bit. They are the same current server version otherwise.
    Attached Files Attached Files

  11. #26
    Join Date
    June 2008
    Posts
    18,144
    As explained ->> No Skip enabled in single client permissions = No Skip for that permissions.


    No glitch or Bug.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #27
    Join Date
    July 2014
    Posts
    25
    I plan on installing a new hard drive in a few weeks. I will only save my identity this time and just copy down on paper my settings. I wonder if that will change anything?

  13. #28
    Join Date
    July 2014
    Posts
    25
    Quote Originally Posted by dante696 View Post
    As explained ->> No Skip enabled in single client permissions = No Skip for that permissions.


    No glitch or Bug.
    What does that mean? What do I need to change?

  14. #29
    Join Date
    June 2008
    Posts
    18,144
    Open your client permissions. There on the top you can read Skip.
    And on that position you have a check box on each permission.
    Enable it on all your active client permissions.

    Or enter Skip in search bar and enable that one permission and it's Skip flag.

    And you may read how permission system works. There is a documentation in the server directory for this.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #30
    Join Date
    January 2017
    Location
    Germany
    Posts
    42
    1. You have a Servergroup that skips the permission of the Channelgroup
    2. You set a Client Permission, that does not skip the permission of the Channelgroup
    3. Result: Channelgroup Permission are used (Client Permission > Servergroup Permission)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: September 16th, 2015, 07:57 AM
  2. Replies: 1
    Last Post: January 11th, 2014, 05:10 PM
  3. Channel Admin granting Server Admin permissions?
    By KLHill in forum Permission System
    Replies: 1
    Last Post: January 6th, 2014, 07:38 PM
  4. Replies: 2
    Last Post: June 2nd, 2011, 02:58 PM
  5. My TEAMSPEAK SERVER Glitched Me
    By Monson in forum General Questions
    Replies: 1
    Last Post: July 18th, 2010, 09:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •