Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    May 2013

    Server thinks my name is in use!


    I run a personal TeamSpeak 3 server on a small Linux PC (Ubuntu 18.04.3 LTS) in my home for me and my friends to use.
    Until recently the version of the server had been 3.3 but that stopped working a few weeks back saying the license file could not be accessed. I found out later that the reason for the error was that it was an older version and I guess this is their way of forcing me to upgrade! I am on the free unlicensed use terms, no need to pay for a license for more connections when only 3 or 4 people are ever logged in!
    The upgrade process failed so I re-installed the 3.9 server from scratch. It seems to work but there is one problem I can not solve that leads me to writing this post.

    I have used the token so I am the server admin, no troubles there. I always log in with the nickname Galbi3000. After starting the server I can log in fine. I can log out, log back in and no problems. But each next day I log back in (the server PC is always running) but the server thinks my name has already been used and so the client appends a 1 to my name (Galbi30001), I still have admin priveledges so the token is still recognised but it just will not let me use my name from the previous day! The only way I can log back in as myself is if I restart the server.

    I have never had this issue before with all the previous versions of the server I have used, I have been using this setup for at least 4 years!

    Any ideas how to fix this?

    P.S. I might add that I also use an ESP8266 device hooked up to a small OLED screen that logs in to the server query port and monitors the server to alert me if anyone logs in to it while I am not logged in. I created a server query login just for that device using the "ServerQuery Login" option from the Tools menu while I was logged in as Galbi3000. Previously I used the serveradmin login provided at first run of the server in previous versions but for some reason the new server will not let the device log in with serveradmin even though the password is correct! I mention this in case the device logging in to a username and password created while logged in as Galbi3000 makes the server think I am logged in even though the user name the device uses is not the same.

    P.P.S. If you are interested in seeing how the ESP8266 device works then take a look at my GitHub page for it:
    Last edited by Galbi3000; August 16th, 2019 at 09:17 AM.

  2. #2
    Join Date
    May 2013
    OK, I feel dumb! LOL

    I added the P.S. to the post because the notion came to me just as I finished writing the post. So after making the edit I started to look into that possibility and actually solved the issue!

    I took a look at the log files and saw that I was logging in as Galbi3000 from the IP address of the ESP8266 device! So the login I created was linked to my account even though the username was different.

    I created a new account on the server, gave it server admin priveledges and then used that to create a ServerQuery login, re-programmed the device to use those new credentials and it logs in fine. Hopefully tomorrow I will not be logging in as Galbi30001

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Teamspeak client thinks I have no permissions and the only fix is reinstalling
    By BadassOverlord in forum Permission System
    Replies: 7
    Last Post: February 19th, 2018, 11:54 AM
  2. Replies: 13
    Last Post: December 10th, 2015, 04:27 PM
  3. TS3 server wont' start.Thinks another instance is running
    By onthefritz in forum Linux / FreeBSD
    Replies: 6
    Last Post: December 5th, 2014, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts