Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    August 2019
    Posts
    1

    static noise when others transmit in teamspeak only, using new headset

    Hi all, I just purchased a new headset (Sennheiser GSP 670) and I ran into a weird issue when I plugged it in for the first time today. About half the time when my friends talk to me or teamspeak, I hear a loud and very distracting buzzing/static noise. No one else hears this noise. It seems to happen when others talk loudly, laugh, or cough (essentially, sudden high noise coming from their client to my headset). I have never had this problem before and I have used teamspeak for years. I only have this issue in TeamSpeak. When I hit the 'test sound' button in teamspeak, I get a very staticy 'testing your playback sound system'. I'm basically at a complete loss of what to do. 90% of my google search results showed results from 2006.

    It is probably worth mentioning that this headset has a volume control knob on the headset that can be used to control teamspeak/discord/ventrilo/mumble etc. and nothing else. Under "Volume Mixer" in windows, there is a separate "device" for this function, which only shows TeamSpeak 3. I am assuming the problem lies within this functionality but I cannot find the cause of it.

    Thank you for any help.

    Edit: For others experiencing the same issue with the GSP 670, I have found a solution - I disabled the above mentioned functionality through windows (set the "speaker" as default communications device instead of the 'teamspeak-only-knob'). Now the knob is useless, but I don't hear static. I don't really care about the functionality of the knob - changing the volume of teamspeak at will on my headset is closer to a gimmick than a useful feature.
    Last edited by dujour88; August 30th, 2019 at 09:03 AM.

  2. #2
    Join Date
    August 2015
    Posts
    55
    So it seems to be e.g. a driver problem is what I get out of this? Otherwise I had some other ideas but if that is the solution for now we probably won't have much else as possibilities. Maybe one or 2 options but they probably wouldn't work anyways.

    Cheers

  3. #3
    Join Date
    September 2019
    Posts
    1

    Resolution and possible cause

    Hey, i just found this thread and hope i can shed some light on this issue as well as a possible cause.

    From what I've been able to test so far, which is limited at best, it would appear that the "Communication" headset feature doesn't like stereo. I've attached a picture of the playback options you have in the settings and setting it force centre speaker removed the "static" from my teamspeak experience with the GSP670 headset.

    Attachment 18346

    I hope this helps others with this headset and can confirm if this works for them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Static when using Teamspeak with bluetooth headset
    By afichera in forum Client Support
    Replies: 1
    Last Post: March 17th, 2019, 09:58 AM
  2. Static noise in mic
    By Cruz3R in forum Windows
    Replies: 0
    Last Post: March 19th, 2017, 07:10 PM
  3. Annoying static in headset when using teamspeak
    By DontLookAtThis in forum General Questions
    Replies: 0
    Last Post: November 10th, 2014, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •