Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    August 2016
    Posts
    6

    Ignoring image link parameters

    Why is TS3 ignoring TS3 images with additional parameters?

    Try adding this image into the channel description and tell me how do you see it please:
    https://media.fortniteapi.io/images/...ground&size=64

    When you open this link in browser it returns image with background and 64x64 size, but TS3 channel description not.

    Thanks for fast feedback.

  2. #2
    Join Date
    August 2016
    Posts
    6
    Hmm, I just got access to TS5 beta, and it is fixed there, is it so hard to actually LOOK & REPLY to this thread, with anything from you "developers"?

  3. #3
    Join Date
    August 2016
    Posts
    6
    Hah, funny thing, a non-developer kind human, investigated this issue, and found out it is a bug in TS3 URL encoding

    https://s.dark-gaming.eu/20-10-2019/12-21-51_rid2l7.png
    https://s.dark-gaming.eu/20-10-2019/12-22-02_rid1I5.png

    I can not believe that TS3 developers do not care about their "customers" or "community" or w/e, and a guy that has nothing special with TS3 looked into it and helped me.

    And TS3 will 100% not fix this bug, as we know them.

  4. #4
    Join Date
    October 2019
    Posts
    2

    TS3 Client wrongly encodes image URL parameters

    Hi, I just created an account to confirm this issue and explain what's actually causing it.

    The TeamSpeak3 Client encodes the URL parameters in a wrong way, i.e. "&" becomes "&" which results in every parameter except the first one to be prefixed with "amp;" (since "&" separates query parameters).

    See this for yourself.
    The first request is from Chromium: https://web.archive.org/web/20191126...-7662689124699
    The second request is from the TeamSpeak3 Client: https://web.archive.org/web/20191126...-8119008089415

    This shows that it's indeed a bug in the TeamSpeak Client. It should not encode the "&" into "&" since that messes up the query parameters.
    Last edited by irgendwr; November 26th, 2019 at 11:09 PM. Reason: update links

  5. #5
    Join Date
    February 2017
    Location
    Australia
    Posts
    115
    both of your links are 404

  6. #6
    Join Date
    October 2019
    Posts
    2

    Exclamation How to reproduce the issue

    You can reproduce the issue yourself with with something like https://postb.in .

    TeamSpeak Client:

    0. Create a new "Bin" at https://postb.in .
    1. Add this to a Channel Description:
    Code:
    [ img ] https://postb.in/<bin-id>?hello=world&foo=bar&answer=42 [/ img ]
    and view channel description to load URL.
    2. Look at the result: https://web.archive.org/web/20191126...-8119008089415

    Query
    Code:
    hello: world
    amp;foo: bar
    amp;answer: 42
    Notice how the parameters (except the first) have "amp;" in front of them. That's the issue.
    As I already explained: This is caused due to the TeamSpeak Client wrongly encoding "&" as "&amp;" in the URL.

    When calling the URL in chromium it works as expected:

    Result: https://web.archive.org/web/20191126...-7662689124699

    Query
    Code:
    hello: world
    foo: bar
    answer: 42
    Last edited by irgendwr; November 26th, 2019 at 11:08 PM. Reason: bug => issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [REQUEST] Image in chat/view image option (for screenshots and etc.)
    By Hazro in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: March 5th, 2017, 05:49 PM
  2. [Not possible] Image with link
    By LaocheXe in forum Skins / Icon & Sound Packs
    Replies: 5
    Last Post: June 4th, 2014, 12:08 AM
  3. Image Over Background Image?
    By xDarkMx in forum Skins / Icon & Sound Packs
    Replies: 0
    Last Post: October 8th, 2013, 10:32 PM
  4. ts3server_linux_amd64 ignoring all input parameters?
    By testlab in forum Linux / FreeBSD
    Replies: 7
    Last Post: January 4th, 2010, 04:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •