Forum

Results 1 to 1 of 1
  1. #1
    Join Date
    March 2019
    Posts
    3

    [Linux][Client][Crash] TS crashed when voice transmition started

    I'm using Lubuntu 18.04, system uses PulseAudio Audio manager.

    In TS I'm using Voice detection mode, and when sound level reaches defined in settings level TS crashed.
    Same happens when used PTT mode or continious transmission.

    Firstly seen in 3.3.0 (doesnt checked on linux earlier), but it still happen in current 3.3.2 vesion.

    GDB crash stack trace:
    PHP Code:
    jsUnexpected number of download buttons in addon element.
    2019-10-29 17:08:55.902914|INFO    |PreProSpeex   |2  |Speex version1.2rc1
    [New Thread 0x7fff5e7f4700 (LWP 17811)]

    Thread 14 "ts3client_linux" received signal SIGILLIllegal instruction.
    [
    Switching to Thread 0x7fffd43df700 (LWP 17741)]
    0x0000000000f16150 in ?? ()
    (
    gdbbt full
    #0  0x0000000000f16150 in ?? ()
    No symbol table info available.
    #1  0x0000000000c62a03 in ?? ()
    No symbol table info available.
    #2  0x0000000000c76749 in ?? ()
    No symbol table info available.
    #3  0x0000000000c65b35 in ?? ()
    No symbol table info available.
    #4  0x0000000000c64db1 in ?? ()
    No symbol table info available.
    #5  0x0000000000c5dcf0 in ?? ()
    No symbol table info available.
    #6  0x0000000000c5931f in ?? ()
    No symbol table info available.
    #7  0x0000000000c5fc8d in ?? ()
    No symbol table info available.
    #8  0x00007ffff6fc96db in start_thread (arg=0x7fffd43df700) at pthread_create.c:463
            
    pd 0x7fffd43df700
            now 
    = <optimized out>
            
    unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140736754218752, -859768667358635761140736754216640033647728140737488342320859858259808606479859784054841006351}, 
                  
    mask_was_saved 0}}, priv = {pad = {0x00x00x00x0}, data = {prev 0x0cleanup 0x0canceltype 0}}}
            
    not_first_call = <optimized out>
    #9  0x00007fffee5c988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
    No locals.
    (
    gdbc
    Continuing
    .
    2019-10-29 17:09:23.385295|DEBUG   |PulseAudio    |   |Underflow occurred on device alsa_output.usb-Logitech_Logitech_Wireless_Headset_000D44FFABBE-00.analog-stereo 

    Thread 14 "ts3client_linux" received signal SIGABRTAborted.
    __GI_raise (sig=sig@entry=6at ../sysdeps/unix/sysv/linux/raise.c:51
    51    
    ../sysdeps/unix/sysv/linux/raise.cNo such file or directory.
    (
    gdbbt
    #0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:51
    #1  0x00007fffee4e8801 in __GI_abort () at abort.c:79
    #2  0x00007ffff1451775 in ?? () from ./libQt5WebEngineCore.so.5
    #3  0x00007ffff1452dc2 in ?? () from ./libQt5WebEngineCore.so.5
    #4  <signal handler called>
    #5  0x0000000000f16150 in ?? ()
    #6  0x0000000000c62a03 in ?? ()
    #7  0x0000000000c76749 in ?? ()
    #8  0x0000000000c65b35 in ?? ()
    #9  0x0000000000c64db1 in ?? ()
    #10 0x0000000000c5dcf0 in ?? ()
    #11 0x0000000000c5931f in ?? ()
    #12 0x0000000000c5fc8d in ?? ()
    #13 0x00007ffff6fc96db in start_thread (arg=0x7fffd43df700) at pthread_create.c:463
    #14 0x00007fffee5c988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
    (gdbc
    Continuing
    .

    Thread 14 "ts3client_linux" received signal SIGABRTAborted.
    __GI_raise (sig=sig@entry=6at ../sysdeps/unix/sysv/linux/raise.c:51
    51    in 
    ../sysdeps/unix/sysv/linux/raise.c
    (gdbbt
    #0  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:51
    #1  0x00007fffee4e8801 in __GI_abort () at abort.c:79
    #2  0x00007ffff1451775 in ?? () from ./libQt5WebEngineCore.so.5
    #3  0x00007ffff1452dc2 in ?? () from ./libQt5WebEngineCore.so.5
    #4  <signal handler called>
    #5  __GI_raise ([email protected]=6) at ../sysdeps/unix/sysv/linux/raise.c:51
    #6  0x00007fffee4e8801 in __GI_abort () at abort.c:79
    #7  0x00007ffff1451775 in ?? () from ./libQt5WebEngineCore.so.5
    #8  0x00007ffff1452dc2 in ?? () from ./libQt5WebEngineCore.so.5
    #9  <signal handler called>
    #10 0x0000000000f16150 in ?? ()
    #11 0x0000000000c62a03 in ?? ()
    #12 0x0000000000c76749 in ?? ()
    #13 0x0000000000c65b35 in ?? ()
    #14 0x0000000000c64db1 in ?? ()
    #15 0x0000000000c5dcf0 in ?? ()
    #16 0x0000000000c5931f in ?? ()
    #17 0x0000000000c5fc8d in ?? ()
    #18 0x00007ffff6fc96db in start_thread (arg=0x7fffd43df700) at pthread_create.c:463
    #19 0x00007fffee5c988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95 
    Additional info:
    CPU AMD C-60, arch amd64.
    Last edited by MXPLRS|Kirill; October 30th, 2019 at 01:43 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. previously started server crashed
    By Big_Jul in forum Linux / FreeBSD
    Replies: 0
    Last Post: April 12th, 2014, 04:51 PM
  2. Client crash - Starting up voice activation test crashes client
    By GeneralCookie in forum Client Support
    Replies: 1
    Last Post: April 30th, 2013, 01:45 PM
  3. (Linux) Crash on connect or test voice input
    By kilavil in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: August 18th, 2011, 07:37 PM
  4. [Resolved] Teamspeak Client RC1 and RC2 on Linux Crashed
    By kizuzi in forum Linux
    Replies: 1
    Last Post: June 28th, 2011, 08:34 AM
  5. Teamspeak Client RC1 and RC2 on Linux Crashed
    By kizuzi in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: June 28th, 2011, 08:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •