Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 2 of 8 FirstFirst 1234 ... LastLast
Results 16 to 30 of 107
  1. #16
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    340
    Quote Originally Posted by dante696 View Post
    Just to make sure.
    Does your answer mean "The issue still exists and you already use hints_enabled=0" ?


    We are not sure why you have such problems. Logs or recorded sessions from wireshark may help to see more.
    Hello @dante696

    Yes that was on our side fail with software raid and just strange backward settings networking same for optimization kernel sysctl.conf that's why it just stop after some minutes, anyway thank you for trying help. have a nice evening.

  2. #17
    Join Date
    December 2010
    Location
    United Kingdom
    Posts
    340
    Quote Originally Posted by dante696 View Post
    Just to make sure.
    Does your answer mean "The issue still exists and you already use hints_enabled=0" ?


    We are not sure why you have such problems. Logs or recorded sessions from wireshark may help to see more.
    Hello @dante696

    Yes that was on our side fail with software raid and just strange backward settings networking same for optimization kernel sysctl.conf that's why it just stop after some minutes, anyway thank you for trying help. have a nice evening.

  3. #18
    Join Date
    October 2017
    Posts
    12
    Hi @dante696,

    the Docker Image is still missing on Docker Hub . Could you please check this? Thank you!

  4. #19
    Join Date
    October 2017
    Posts
    12
    Hi @dante696,

    the Docker Image is still missing on Docker Hub . Could you please check this? Thank you!

  5. #20
    Join Date
    June 2008
    Posts
    18,513
    We did requested changes and pushed a new version to Github.
    Should be available within a day.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #21
    Join Date
    June 2008
    Posts
    18,513
    We did requested changes and pushed a new version to Github.
    Should be available within a day.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #22
    Join Date
    July 2017
    Posts
    8
    The docker image with the tag latest throws the following error atm:
    | /opt/ts3server/entrypoint.sh: line 50: can't create /var/run/ts3server/ts3server.ini: Permission denied
    Config: container runs in host namespace, volume mounted to /var/ts3server with permissions for user 9987.

    The older images work without any problems. The given path is not part of the volume...

  8. #23
    Join Date
    July 2017
    Posts
    8
    The docker image with the tag latest throws the following error atm:
    | /opt/ts3server/entrypoint.sh: line 50: can't create /var/run/ts3server/ts3server.ini: Permission denied
    Config: container runs in host namespace, volume mounted to /var/ts3server with permissions for user 9987.

    The older images work without any problems. The given path is not part of the volume...

  9. #24
    Join Date
    June 2008
    Posts
    18,513
    Show us the full config or we can not see anything.

    Please leave /var/run/ts3server/ alone or check your user permissions.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #25
    Join Date
    June 2008
    Posts
    18,513
    Show us the full config or we can not see anything.

    Please leave /var/run/ts3server/ alone or check your user permissions.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #26
    Join Date
    July 2017
    Posts
    8
    Quote Originally Posted by dante696 View Post
    Show us the full config or we can not see anything.

    Please leave /var/run/ts3server/ alone or check your user permissions.

    I only quoted the error msg....

    docker-compose:
    Code:
    version: '2.4'
    services:
      ts3server_xyz:
        container_name: ts3server_xyz
        image: teamspeak:latest
        userns_mode: "host"
        network_mode: "host"
        restart: unless-stopped
        environment:
          TS3SERVER_LICENSE: accept
          TS3SERVER_QUERY_PROTOCOLS: "raw,ssh"
    • docker-compose up


    The container is not able to start.
    Code:
    Creating ts3server_xyz ... done
    Attaching to ts3server_xyz
    ts3server_xyz    | /opt/ts3server/entrypoint.sh: line 50: can't create /var/run/ts3server/ts3server.ini: Permission denied
    I do not think that my config is special... Permissions should not be a problem, because it is 1:1 the default environment of the image without any modifications through volumes etc.

    Docker version: Docker version 19.03.4, build 9013bf583a
    Last edited by Hedius; November 12th, 2019 at 09:14 AM.

  12. #27
    Join Date
    July 2017
    Posts
    8
    Quote Originally Posted by dante696 View Post
    Show us the full config or we can not see anything.

    Please leave /var/run/ts3server/ alone or check your user permissions.

    I only quoted the error msg....

    docker-compose:
    Code:
    version: '2.4'
    services:
      ts3server_xyz:
        container_name: ts3server_xyz
        image: teamspeak:latest
        userns_mode: "host"
        network_mode: "host"
        restart: unless-stopped
        environment:
          TS3SERVER_LICENSE: accept
          TS3SERVER_QUERY_PROTOCOLS: "raw,ssh"
    • docker-compose up


    The container is not able to start.
    Code:
    Creating ts3server_xyz ... done
    Attaching to ts3server_xyz
    ts3server_xyz    | /opt/ts3server/entrypoint.sh: line 50: can't create /var/run/ts3server/ts3server.ini: Permission denied
    I do not think that my config is special... Permissions should not be a problem, because it is 1:1 the default environment of the image without any modifications through volumes etc.

    Docker version: Docker version 19.03.4, build 9013bf583a

  13. #28
    Join Date
    June 2008
    Posts
    18,513
    We can not reproduce this with these settings.

    What you could try is a docker-compose down and then docker-compose up again.
    !!!! You loose your server data because you stored them in that docker and not on seperate mounted volume !!!!

    Or you can try to run docker-compose up open a new folder.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #29
    Join Date
    June 2008
    Posts
    18,513
    We can not reproduce this with these settings.

    What you could try is a docker-compose down and then docker-compose up again.
    !!!! You loose your server data because you stored them in that docker and not on seperate mounted volume !!!!

    Or you can try to run docker-compose up open a new folder.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #30
    Join Date
    July 2017
    Posts
    8
    Quote Originally Posted by dante696 View Post
    We can not reproduce this with these settings.

    What you could try is a docker-compose down and then docker-compose up again.
    !!!! You loose your server data because you stored them in that docker and not on seperate mounted volume !!!!

    Or you can try to run docker-compose up open a new folder.
    I store my data in volumes.
    I just removed the volume section from the shown config, because it also happens with total clean containers. Recreating the container does not change anything.

    The problem is that my docker daemon runs in a usernamespace.

    my docker config is (etc/docker/daemon.json)
    Code:
    {
      "userns-remap": "default"
    }
    With this setting containers do not run as root on the host kernel by default. (So user id 0 is a really high user on the host) Isolation for security.

    https://docs.docker.com/engine/security/userns-remap/

    The compose file has the parameters:
    userns_mode: host
    network_mode: host

    Network host just directly attaches the container to the host interfaces.
    Userns_mode host is needed to bypass the mentioned isolation. The container runs then in the root namespace of the host system. (Same as in a default docker setup)

    I am able to reproduce this issue on a Debian 9 and on a Debian 10 host.

    A change in the docker image from version 3.9.1 to 3.10 made it incompatible with those settings....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Discussion] TeamSpeak Server 3.8.0
    By Chris in forum Suggestions and Feedback
    Replies: 58
    Last Post: June 19th, 2019, 03:21 PM
  2. [Discussion] TeamSpeak 3 Server 3.2.0
    By dante696 in forum Suggestions and Feedback
    Replies: 24
    Last Post: July 19th, 2018, 09:34 AM
  3. [Discussion] TeamSpeak 3 Server 3.1.3
    By Chris in forum Suggestions and Feedback
    Replies: 2
    Last Post: April 28th, 2018, 12:26 AM
  4. [Discussion] TeamSpeak 3 Server 3.1.1
    By Chris in forum Suggestions and Feedback
    Replies: 4
    Last Post: March 4th, 2018, 02:42 PM
  5. [Discussion] TeamSpeak 3.1.1 Beta Discussion
    By Chris in forum Suggestions and Feedback
    Replies: 15
    Last Post: February 10th, 2017, 05:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •