Simply, unable to connect to most of the channels, logs below. Sometimes i am able to connect those servers and sometimes not (most of the time not). No i'm not banned on them and yes they are online since my friends can connect to it. Reinstalling TS or windows doesn't resolve the issue, most likely network related but i'm out of ideas.

TS3 version 3.3.2
logs:
14.12.2019 20:34:20 ClientUI Info Connect to server: nulleeet.com
14.12.2019 20:34:20 ClientUI Info Trying to resolve nulleeet.com
14.12.2019 20:34:20 TSDNS Info SRV DNS resolve unsuccessful, "_tsdns._tcp.nulleeet.com" Domain name not found
14.12.2019 20:34:20 TSDNS Info A/AAAA DNS resolve successful, "nulleeet.com" =(h: 108.61.167.122 p:0)
14.12.2019 20:34:20 TSDNS Info A/AAAA DNS resolve for possible TSDNS successful, "nulleeet.com" =(h: 108.61.167.122 p:0)
14.12.2019 20:34:20 TSDNS Info SRV DNS resolve unsuccessful, "_ts3._udp.nulleeet.com" Domain name not found
14.12.2019 20:34:22 TSDNS Info TSDNS queried unsuccessfully 108.61.167.122:41144
14.12.2019 20:34:22 TSDNS Info No TSDNS found
14.12.2019 20:34:22 ClientUI Info Lookup finished: ip=108.61.167.122 port=9987 query=nulleeet.com error=0
14.12.2019 20:34:22 ClientUI Info Resolve successful: 108.61.167.122:9987
14.12.2019 20:34:22 ClientUI Info Initiating connection: 108.61.167.122:9987
14.12.2019 20:34:22 ClientUI Info Connect status: Connecting
14.12.2019 20:34:22 PktHandler Devel Puzzle solve time: 3
14.12.2019 20:34:28 PktHandler Info Cleaning up connection because of 5 resends of COMMAND packet
14.12.2019 20:34:28 ClientUI Info Connect status: Disconnected
14.12.2019 20:34:28 ClientUI Info Failed to connect to server, want autoreconnect = 0

specs:
Ryzen 3700x, RTX2070, B450 Tomahawk, Win 10
All available drivers and updates installed.