Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 3 of 3 FirstFirst 123
Results 31 to 44 of 44
  1. #31
    Join Date
    January 2003
    Location
    The Netherlands
    Posts
    1,344

  2. #32
    Join Date
    June 2006
    Location
    England, Hertfordshire
    Posts
    249
    Thanks

    What do I do with this RPM file?

  3. #33
    Join Date
    June 2006
    Location
    England, Hertfordshire
    Posts
    249
    Extracted the files, run command and it seems I have gone past that now. It says "EDatabaseError.dbExpress Error: Invalid Username/Password" going to search the forums for help on this.

  4. #34
    Join Date
    September 2008
    Location
    france
    Posts
    2

    Can't lunch teamspeak server

    hi everybody !
    When I try to lunch my server with SQL I've this error :
    Code:
     ---------------------------------------------------------------
    -------------- log started at 16-09-08 19:34 -------------
    ---------------------------------------------------------------
    16-09-08 19:34:09,ALL,Info,server,	Server init initialized
    16-09-08 19:34:09,ALL,Info,server,	Server version: 2.0.24.1 Linux
    16-09-08 19:34:09,ERROR,All,SQL,	Database initialization error: EDatabaseError.Unable to Load ./libmysqlclient_r.so.15.0.0
    16-09-08 19:34:09,ERROR,All,SERVER,	Start_Server: unable to open database
    my server.ini

    Code:
    [Main Config]
    BoundToIp1=
    ExternalIPDectection=1
    HTTPServer Port=9100
    HTTPServer Enabled=1
    DateTimeFormat=dd-mm-yyyy hh:nn:ss
    TCPQueryPort=9101
    AllowedClientNameChars=
    DisAllowedClientNameChars=()[]{}
    
    [debug]
    MessageTypes=LMTALL
    MessageDepths=LMDALL
    
    [WebPost]
    AdminEmail=na
    ISPLinkURL=na
    ISPName=Private
    ISPCountryNumber=4426
    Enabled=1
    PostURL=
    ListPublic=1
    UserAgent=teamspeak
    
    [log]
    access_r=0
    access_u=0
    channel_registerred=0
    channel_unregisterred=0
    sa=0
    chat=0
    kick_server=0
    kick_channel=0
    
    [Spam]
    max_commands=10
    in_seconds=2
    
    [DBEXPRESS]
    sqldir=mysql_sql
    Drivername=mysql
    Database=ts
    Hostname=127.0.0.1
    User_name=******
    Password=*********
    GetDriverFunc=getSQLDriverMYSQL
    VendorLib=/usr/lib/libmysqlclient_r.so.15.0.0
    LibraryName=./libsqlmy.so
    Active=1
    If any one can help me

  5. #35
    Join Date
    January 2003
    Location
    The Netherlands
    Posts
    1,344
    EDatabaseError.Unable to Load ./libmysqlclient_r.so.15.0.0


    Find that client?

  6. #36
    Join Date
    September 2008
    Location
    france
    Posts
    2
    Yes ...... i've got it and its the right dir ...

  7. #37
    Join Date
    November 2008
    Location
    Germany
    Posts
    2

    Dosn't even work! :(

    Hi ppl,

    after getting mysql libs 10.0.0 (as described here), set the passwd with old_password and "EInvalidField.field b_sp_AdminEditServerWelcomeMessage not found -> Edit the table and change the type tyint to int and the value 1 to 11" I now get the following error (am I the only one?):

    13-11-08 15:05:36,ALL,Info,server, Server init initialized
    13-11-08 15:05:36,ALL,Info,server, Server version: 2.0.24.1 Linux
    13-11-08 15:05:37,ERROR,All,SERVER, VirtualServer Startup(1) Exception: EInvalidField.field b_sp_ChannelJoinChannelWithoutPassword not found
    13-11-08 15:05:39,ALL,Info,server, Server init finished
    13-11-08 15:05:39,WARNING,Info,server, TeamSpeak Server daemon activated

    Does anyone have any Idea what I did wrong?
    The Table exists in Server: localhost - Datenbank: <database> - Tabelle: ts2_server_privileges
    So whay doesn't it work?

    If I select the server superadmin (webinterface), the server now quielty dies.

    Regards
    - Nagilum

  8. #38
    Join Date
    November 2008
    Location
    us
    Posts
    1
    Note: to all those out there like me running x64 use the i386 rpm and put it in the TS folder.
    That will work if you have the x64 libs you'll get as frustrated as me as TS is 32 only ap
    till version 3

  9. #39
    Join Date
    November 2008
    Location
    France
    Posts
    2

    Unhappy Always same problem

    I have a problem when I launch TS 2.x on a DEbian 64 with mysql 5.x

    Code:
    ---------------------------------------------------------------
    -------------- log started at 17-11-08 10:42 -------------
    ---------------------------------------------------------------
    17-11-08 10:42:31,ALL,Info,server,      Server init initialized
    17-11-08 10:42:31,ALL,Info,server,      Server version: 2.0.23.19 Linux
    17-11-08 10:42:32,ERROR,All,SQL,        Database initialization error: EDatabaseError.Unable to Load /usr/lib/libmysqlclient_r.so.10.0.0
    17-11-08 10:42:32,ERROR,All,SERVER,     Start_Server: unable to open database
    ----------------------------------------------------------
    ---------------------------------------------------------------
    --------------- log ended at 17-11-08 10:42 --------------
    ---------------------------------------------------------------
    Here the end of my config file:
    Code:
    [DBEXPRESS]
    sqldir=/backup/teamspeak/tss2_rc2/mysql_sql/
    Drivername=mysql
    Database=ts
    Hostname=127.0.0.1
    User_name=ts
    Password=ts2008
    GetDriverFunc=getSQLDriverMYSQL
    VendorLib=/usr/lib/libmysqlclient_r.so.10.0.0
    LibraryName=./libsqlmy.so
    Active=1
    I already change the hash password, modify read_servers.sql, replace localhost by 127.0.0.1, I have in /usr/lib the libmysqlclient_r.so.10.0.0, i restart the linux but nothing change i already have the same problem.
    Someone can help me please

  10. #40
    Join Date
    November 2008
    Location
    Germany
    Posts
    2
    Does noone have a clue where my problem is and how to solve it?
    Did noone have the same problem?

    Regards
    - Nagilum

  11. #41
    Join Date
    October 2006
    Location
    Here
    Posts
    37
    What about:

    Code:
    ls -l /usr/lib/libmysqlclient_r.so.10.0.0

  12. #42
    Join Date
    November 2008
    Location
    France
    Posts
    2
    the lib was in chmod 777, nothing change alwas same problem, please help

  13. #43
    Join Date
    March 2009
    Location
    French
    Posts
    51
    Hello,

    I installed the teamspeak server, in the file server.ini, I put:
    Code:
    [DBEXPRESS]
    sqldir=mysql5_sql/
    Drivername=mysql
    Database=ts
    Hostname=localhost
    User_name=root
    Password=my_password
    GetDriverFunc=getSQLDriverMYSQL
    Vendorlib=/usr/lib/libmysqlclient_r.so.15.0.0
    LibraryName=./libsqlmy.so
    Active=1
    or :
    Code:
    [DBEXPRESS]
    sqldir=/home/serveur/serveurts/mysql5_sql/
    Drivername=mysql
    Database=ts
    Hostname=localhost
    User_name=root
    Password=my_password
    GetDriverFunc=getSQLDriverMYSQL
    Vendorlib=/usr/lib/libmysqlclient_r.so.15.0.0
    LibraryName=/home/serveur/serveurts/libsqlmy.so
    Active=1

    I create a database ts :
    mysql -u root -p and CREATE DATABASE ts; use ts.


    I start the server and error :
    28-03-09 01:28:06,ERROR,All,SQL, Database initialization error: EDatabaseError.DLL/Shared Library Name not Set
    28-03-09 01:28:06,ERROR,All,SERVER, Start_Server: unable to open database

    I type >> locate libmysqlclient_r.so >>
    /usr/lib/libmysqlclient_r.so
    /usr/lib/libmysqlclient_r.so.15
    /usr/lib/libmysqlclient_r.so.15.0.0
    privilege for libmysqlclient_r.so.15 > root (chmod 644, I tested 777 but no change)....

    OS : Debian Lenny :
    uname -a
    Linux *******.ovh.net 2.6.27.10-grsec-xxxx-grs-ipv4-32 #4 SMP Wed Feb 18 16:30:23 UTC 2009 i686 GNU/Linux

    mysql (phpinfo.php) :
    mysql
    MySQL Support enabled
    Active Persistent Links 0
    Active Links 0
    Client API version 5.0.51a
    MYSQL_MODULE_TYPE external
    MYSQL_SOCKET /var/run/mysqld/mysqld.sock
    MYSQL_INCLUDE -I/usr/include/mysql
    MYSQL_LIBS -L/usr/lib -lmysqlclient_r

    thanks for answer...

  14. #44
    Join Date
    October 2009
    Location
    Illinois, USA
    Posts
    1

    libmysqlclient_r.so.10.0.0 for MySQL

    Here's the library for anyone who needs it...
    It took me for ever to find it... so I figured I'd share. This was my stumbling block in getting TS up and running with MySQL, but now it's all good

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ts3+Mysql tutorial (windows) ?
    By deviss in forum General Questions
    Replies: 1
    Last Post: October 11th, 2010, 08:49 AM
  2. [Mini-Tutorial] Fix ServerAdmin Lost Password (MYSQL)
    By Appleboy in forum Server Support
    Replies: 2
    Last Post: December 24th, 2009, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •