Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 27
  1. #1
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation Runtime Error beim Starten des Servers!!!???

    Guten Tag liebe Community.

    Ich habe folgendes Problem:

    Wenn ich Teamspeak-Server starte auf Linux openSUSE 10.3 (64 Bit) habe ich einen Runtimefehler.

    Was mache ich falsch? Hier meine Vorschrittsweiße:

    1."tss2_rc2" Ordner von Windows auf den V-Server hochgeladen

    2.Ich gehe in den Ordner:
    Code:
    cd /tss2_rc2
    3.Ich gebe die Schreibrechte "777"

    4.Ich starte "Teamspeak2-Server"
    Code:
    ./teamspeak2-server_startscript start
    5.Nun warte ich auf die Fehlermeldung:
    Code:
    WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    !!!!!!!!!!!
    starting the teamspeak2 server
    libgcc_s.so.1 must be installed for pthread_cancel to work
    ./teamspeak2-server_startscript: line 7:  3383 Aborted                 ./server_linux -PID=tsserver2.pid
    Was mache ich falsch bzw. was muss ich noch installieren, damit ich Teamspeak²-Server starten kann???

    Ich würde mich um positive Antworten, die mir weiterhelfen freuen. Danke schonmal im voraus.

    Mit freundlichen Grüßen:
    C.Designs

  2. #2
    Join Date
    August 2008
    Location
    Whois
    Posts
    586
    Mit suse kenn ich mich zwar nicht aus aber das sollte mit yast ja auch klappen:

    http://forum.teamspeak.com/showpost....28&postcount=5

  3. #3
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation

    Leider geht dies nicht, da folgendes kommt:

    Code:
    ...apt-get install ia32-libs
    -bash: apt-get: command not found
    Dies geschieht genauso, wenn ich den anderen Befehl benutze.

    Was muss ich machen???

  4. #4
    Join Date
    October 2005
    Location
    Germany
    Posts
    44
    Quote Originally Posted by C.Designs View Post
    Leider geht dies nicht, da folgendes kommt:

    Code:
    ...apt-get install ia32-libs
    -bash: apt-get: command not found
    Dies geschieht genauso, wenn ich den anderen Befehl benutze.

    Was muss ich machen???
    apt-get ist der Paketmanager von debian! Wie ich sehe verwendest du SuSE!
    Schau also mal in deinem SuSE-Paketmanager nach einem solchen Paket!

  5. #5
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation

    Na prima...


    Leider kenne ich mich mit Linux Suse nicht aus!!! Bitte um Hilfe.... um eine ausfürhrliche Antwort würde ich mich freuen

  6. #6
    Join Date
    October 2005
    Location
    Germany
    Posts
    44
    Quote Originally Posted by C.Designs View Post
    Na prima...


    Leider kenne ich mich mit Linux Suse nicht aus!!! Bitte um Hilfe.... um eine ausfürhrliche Antwort würde ich mich freuen
    Wieso benutzt du es dann?

    Falls es ein gemieteter Root-Server ist, rate ich dir folgendes: Abschalten, und SuSE auf einer lokalen Kiste bei dir zu Hause installieren und dich damit auseinandersetzen. Nebenbei noch

    http://forum.teamspeak.com/showthread.php?t=45516

    lesen.

    Ansonsten auf jeden Fall mal damit auseinandersetzen. Wie gesagt schau einfach in dem Paketmanager von SuSE (ich glaube das geht irgendwie über YaST (bin Debiannutzer)) nach den ia32-libs suchen und so installieren.

  7. #7
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation

    Quote Originally Posted by DiWoWo View Post
    Wieso benutzt du es dann?

    Falls es ein gemieteter Root-Server ist, rate ich dir folgendes: Abschalten, und SuSE auf einer lokalen Kiste bei dir zu Hause installieren und dich damit auseinandersetzen. Nebenbei noch

    http://forum.teamspeak.com/showthread.php?t=45516

    lesen.

    Ansonsten auf jeden Fall mal damit auseinandersetzen. Wie gesagt schau einfach in dem Paketmanager von SuSE (ich glaube das geht irgendwie über YaST (bin Debiannutzer)) nach den ia32-libs suchen und so installieren.
    Ich kenne mich teilweiße mit Linux aus. Auserdem hilft mir diese Antwort nicht viel weiter

    Ich möchte doch einfach nur eine gute antwort mit den rcihtigen Anweißungen, damit ich diesen Fehler beheben kann...ist das den zuviel verlangt???

    Bitte um dringende Hilfe

  8. #8
    Join Date
    August 2008
    Location
    Whois
    Posts
    586
    http://forum.teamspeak.com/showpost....34&postcount=2
    Lesen, Verstehen, Google benutzen, TS² Server starten.

    Du kannst nicht erwarten, das hier Speziallisten sind, die sich mit jedem BS auskennen.

    Wie du in meinem oberen Posten lesen kannst
    Zitat: "das sollte mit yast ja auch klappen"
    wäre ein logischer Schritt:
    http://lmgtfy.com/?q=yast+ia32-libs

    Oder in einem SuSe Forum zu Fragen, ob dort jemand mit entsprechender Erfahrung ist.

    Mann nennt sowas auch EIGENINITIATIVE

    Ach... Und PS:
    http://forum.teamspeak.com/showthread.php?t=40815

    Wie gesagt: EIGENINITIATIVE

  9. #9
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation

    Hallo....

    ich habe gdacht hier sind wenigstens Leute die sich mit Teamspeak auskennen und die Fehler beheben können.

    Auserdem habe ich deine Fariante schon probiert. Wie gesagt...es geht nicht und mit Yast kenne ich mich nicht aus, bzw. weiß nicht was ich damit Anfangen soll...???

    Bitte um Hilfe

  10. #10
    Join Date
    December 2006
    Location
    Germany, Bay, Würzburg,...
    Posts
    3,083
    Wie bereits gesagt: Wenn man sich einen Server zulegt, sollte man zumindest mal Grundkenntnisse haben, was das überhaupt ist und wie man damit umzugehen hat. Deine Kenntnisse auf Windows übertragen: "Ich weiß wo mans an und wieder ausschaltet. Aber wo bitteschön ist 'Start'?!"

    Wie bereits gesagt, du musst mit yast (das ist dein Paketmanager mit dem du Programme/Pakete installierst) die 32bit-Librarys installieren. Ggf. einfach mal suchen.

    Am besten ist es aber immernoch, wenn du deinen Server erst mal wieder kündigst und dir zu Hause erst mal auf einem lokalen Rechner Grundkenntnisse aneignest. Wenn du dort was falsch konfigurierst, passiert da i.d.R. nichts, aber ein Rootserver hängt ungeschützt im Internet, ein Konfigurationsfehler kann da schon ausreichen, um dich bettelarm zu machen. Aber manche Leute wollen ja wohl nicht hören und müssens immer drauf anlegen ...

  11. #11
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    unter SuSe heist der pedant zu apt-get zypper

    nebenbei nimm dir die Anmerkung von Hook zu Herzen

  12. #12
    Join Date
    October 2009
    Location
    Germany
    Posts
    27
    Also...Nochmal auf deutsch und zum mitschreiben.

    Ich bin nicht vom Mond und habe bereits Kenntnise mit Linux gemacht bzw. Ubuntu. Doch ich kann das betriebssytsem nicht wechslen, da mein Freund der Inhaber des Servers ist. Ich richte ihm bloß die ganzen Sachen ein.

    Ich glaube hier wird man nicht mehr weitergeholfen. Da muss ich wohl in einem anderen Forum nachfragen, wie zb. Teamspeak-Einstieg. ;(

    unter SuSe heist der pedant zu apt-get zypper
    Folgednes kommt, wenn ich dieses Befehl eintippe:

    Code:
    apt-get zypper
    -bash: apt-get: command not found
    Falls ich hier doch noch Hilfe erhalte, würde ich mich sehr freuen

    Anmerkung:
    Ich habe selber mal ein Projekt geleitet (den Namen darf ich nicht nennen), und habe alles gut auf die Reihe bekommen, doch da gab es den Fehler auch nicht!!!


    Mit freundlichen Grüßen:
    C.Designs

  13. #13
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    gemeint war eigentlich das du apt-get durch zypper ersetzen sollst, also:
    zypper install ia32-libs

  14. #14
    Join Date
    October 2009
    Location
    Germany
    Posts
    27

    Exclamation

    Hallo...es geht immer noch nicht

    Habe den Befehl ausgeführt und danach versucht den Server zu starten und folgendes kommt:

    Code:
    zypper install ia32-libs
    Refreshing 'OpenSuSE 10.3'
    Do you want to trust key id A84EDAE89C800ACA, SuSE Package Signing Key <[email protected]>, fingerprint 79C179B2E1C820C1890F9994A84EDAE89C800ACA [yes/no]: y
    Import key A84EDAE89C800ACA to trusted keyring? [yes/no]: y
    * Building repository 'OpenSuSE 10.3' cache
    Refreshing 'OpenSuSE 10.3 Update'
    * Building repository 'OpenSuSE 10.3 Update' cache
    * Reading repository 'OpenSuSE 10.3' cache
    * Reading repository 'OpenSuSE 10.3 Update' cache
    * Reading installed packages [100%]
    
    package 'ia32-libs' not found
    Nothing to do.
    "Zensiert":~ # cd /tss2_rc2
    "Zensiert":/tss2_rc2 # ./teamspeak2-server_startscript start
    WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    !!!!!!!!!!!
    starting the teamspeak2 server
    libgcc_s.so.1 must be installed for pthread_cancel to work
    ./teamspeak2-server_startscript: line 7:  3352 Aborted                 ./server_linux -PID=tsserver2.pid
    Was mache ich wieder falsch? Muss ich was deinstallieren oder installieren?

    Danke trotzdem an Dabulator für die trotzdem Hilfreiche Antwort

  15. #15
    Join Date
    February 2008
    Location
    Germany, Schorndorf
    Posts
    186
    Muss jetzt leider ein bischen raten, da ich nicht an meinen Linux Kisten sitze.
    ia32-libs gibt es tatsächlich nicht unter SuSe, das ist für Debian. Ich habe mich da etwas von meinen Vorgängern leiten lassen

    Es müssten folgende Libraries nachinstalliert werden

    zypper install glibc-32bit*
    Last edited by Dabulator; October 21st, 2009 at 09:08 AM. Reason: es wird linux-gate.so.1; libpthread.so.0; libdl.so.2; libc.so.6 und /lib/ld-linux.so.2 benötigt

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •