Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 47
  1. #31
    Join Date
    April 2007
    Location
    Germany
    Posts
    98
    Quote Originally Posted by asd3344 View Post
    2009-12-20 21:43:06.912374|ERROR |DatabaseQuery | | mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)
    2009-12-20 21:43:06.912374|CRITICAL|ServerLibPriv | | Server() DatabaseError


    why ?
    my sql is not user root ..
    Try this one:
    Quote Originally Posted by NeoShadowdream View Post
    Make sure to hit enter after this last line of your ts3db_mysql.ini
    [config]
    host=******
    username=******
    password=******
    database=******
    <--empty line

    when I added this my ini the server fired right up on MySQL 5

    use only the lines above, adding otheres seemed to stop it from working.
    This fixed my problems

  2. #32
    Join Date
    December 2009
    Location
    Saudi Arabia
    Posts
    22
    not work


    mysql_real_connect() failed with error: Access denied for user 'root'@'localhost' (using password: NO)

  3. #33
    Join Date
    December 2009
    Location
    Kansas
    Posts
    5
    My only problem now is this showing up in log file with server not starting.

    2009-12-21 11:47:30.390625|CRITICAL|SQL | | db_CreateTables() unable to load instance default values


    Any clues why im getting this?

  4. #34
    Join Date
    December 2006
    Location
    Denmark
    Posts
    25
    Are you running mySQL in strict mode?

    Quote Originally Posted by Jwalters0814 View Post
    My only problem now is this showing up in log file with server not starting.

    2009-12-21 11:47:30.390625|CRITICAL|SQL | | db_CreateTables() unable to load instance default values


    Any clues why im getting this?

  5. #35
    Join Date
    June 2009
    Location
    germany
    Posts
    4
    ? what must i setup ? and where

  6. #36
    Join Date
    December 2009
    Location
    Germany
    Posts
    9
    Do you have all 3 options in your ts3server.ini?

    Code:
    dbplugin=ts3db_mysql
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/

  7. #37
    Join Date
    December 2009
    Location
    Home
    Posts
    2

    Exclamation

    Hello my problem is as follows ts3server_win32

    Code:
    2009-12-22 18:58:24.656250|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta5 [Build: 9462]
    2009-12-22 18:58:24.656250|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2009-12-22 18:58:24.656250|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2009-12-22 18:58:24.828125|ERROR   |DatabaseQuery |   | db_exec() CREATE TABLE channel_properties (  server_id integer unsigned,  id     error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AUTOINCREMENT NOT NULL,  channel_parent_id  integer unsigned,  server_id        ' at line 1
    2009-12-22 18:58:24.828125|CRITICAL|SQL           |   | db_CreateTables() unable to create tables
    ts3server.ini

    Code:
    machine_id=
    default_voice_port=9989
    voice_ip=YOURIP
    licensepath=
    filetransfer_port=30034
    filetransfer_ip=YOURIP
    query_port=10012
    query_ip=YOURIP
    dbplugin=ts3db_mysql
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs/
    logquerycommands=1
    ts3db_mysql.ini

    Code:
    [config]
    host=localhost
    port=3306
    username=teamspeak
    password=******
    database=ts3db
    socket=
    What is the problem? Thank you for your reply
    Last edited by Dubik; December 22nd, 2009 at 06:59 PM.

  8. #38
    Join Date
    August 2007
    Location
    Bangkok Thailand
    Posts
    44
    @ Dubik

    Change your dbsqlcreatepath value to be like this.

    dbsqlcreatepath=create_mysql/


    ---------------
    To guys having problem that TS3 server doesn't read your MySQL configuration file.

    [config]
    host=localhost
    port=6661
    username=ts3
    password=blablabla
    database=xgn_ts3
    socket=
    "This line should be an empty line"
    Make sure you have an empty line after socket= like Lil-rich said.

  9. #39
    Join Date
    December 2009
    Location
    Home
    Posts
    2
    Quote Originally Posted by Dark-Master View Post
    @ Dubik

    Change your dbsqlcreatepath value to be like this.

    dbsqlcreatepath=create_mysql/
    ou me stu... here but thank you very much :-)

  10. #40
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    Quote Originally Posted by jwevrsn View Post
    Not necessarily, it could have been his internal network IP.

    It should work although you are correct it is advisable to use localhost.
    It is NOT advisable to use "localhost", unless TS is the only one program accessing database.
    Use 127.0.0.1 or real LAN IP. 127.0.1.1 for Linux server would be also acceptable.

  11. #41
    Join Date
    January 2008
    Location
    FRANCE
    Posts
    25
    I have an probleme with MySQL server on another machine.

    Code:
    [config]
    host=94.23.48.46
    port=3306
    username=******
    password=******
    database=******
    mysql_real_connect() failed with error: Can't connect to MySQL server on '127.0.0.1' (111)


    Why 127.0.0.1 ????

  12. #42
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    Where did you put that config?

  13. #43
    Join Date
    January 2008
    Location
    FRANCE
    Posts
    25
    In ts3db_mysql.ini on TS3 Server Folder

  14. #44
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    Try remove "dbpluginparameter=" from ts3server.ini

  15. #45
    Join Date
    January 2008
    Location
    FRANCE
    Posts
    25
    Same ...
    Code:
    2009-12-28 02:56:09.868188|ERROR   |DatabaseQuery |   | mysql_real_connect() failed with error: Can't connect to MySQL server on '127.0.0.1' (111)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FreeBSD 9.0 / 9.2 and TeamSpeak3 MySQL db dont work
    By jacekg in forum Linux / FreeBSD
    Replies: 2
    Last Post: July 28th, 2014, 03:18 PM
  2. still dont work
    By Scania in forum Windows
    Replies: 4
    Last Post: January 21st, 2010, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •