Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 24

Thread: Error Log

  1. #1
    Join Date
    December 2009
    Location
    Switzerland
    Posts
    22

    Question Error Log

    Hi there, I always get serveral 30 mins this Error in the log and the Server crashed:

    2009-12-20 12:32:35.852202|CRITICAL|TCPSockets | | select() failed
    What problem is this?

  2. #2
    Join Date
    December 2009
    Location
    German
    Posts
    1
    Can I connect only the errors we have on our windows 2008 Server.
    Our Teamspak 3 crashed after 20-30 minutes with the same errors.

    Would not be bad if it were time to come. because we want our Ts3 use them.

  3. #3
    Join Date
    December 2009
    Location
    Switzerland
    Posts
    22
    Our OS is Windows Server 2008 too

  4. #4
    Join Date
    December 2009
    Location
    Switzerland
    Posts
    22
    Quote Originally Posted by django View Post
    Can I connect only the errors we have on our windows 2008 Server.
    Our Teamspak 3 crashed after 20-30 minutes with the same errors.

    Would not be bad if it were time to come. because we want our Ts3 use them.
    Sorry for doublepost, did you activated TSViewer?

    After I registered this server in TSviewer, the Servers always crashes, the TSviewer cant connect too.

    2009-12-20 13:31:45.169953|INFO |VirtualServer | 1| query client connected 'Unknown from 85.25.120.233:44063'(id:51)
    2009-12-20 13:31:55.195678|INFO |VirtualServer | 1| query client disconnected 'TSViewer.com Query'(id:51) reason 'reasonmsg=connection lost'
    After disabling TSViewer, the Server works 50 mins well now. I will update you if it crashes again!

  5. #5
    Join Date
    August 2005
    Location
    Cali, USA
    Posts
    50
    yep same problem here. Server crashed 5 times within the last hour or two. I also just set up TSViewer so I'll disable it and see if it keeps happening.

    How did you disable it? Just changed the ip or sent them a message telling them to shut it off?
    I just changed the ip so i hope that will be enough...

    ---Edit---
    2 hours later. So far no crashes.
    Last edited by IZZO; December 21st, 2009 at 01:59 AM.

  6. #6
    Join Date
    July 2008
    Location
    canada
    Posts
    77
    I have this issue too, but no tsviewer in logs
    seems to be a very big issue, I hope they can fix this. may require a patched server update

  7. #7
    Join Date
    March 2003
    Location
    London UK
    Posts
    66
    Can't use any really query protocol interaction without the server crashing very regularly. With our standard monitoring in place which queries ever virtual server once a minute the physical server wouldn't last more than 10mins without a crash, and on average 5mins

  8. #8
    Join Date
    July 2008
    Location
    canada
    Posts
    77
    yes, I start noticing the crashes more regularly now that I implemented Ajax statusing, getting the status every 5-10 seconds for each account.

    seems to crash just from using the tcp query alot, not doing anything wrong

  9. #9
    Join Date
    March 2003
    Location
    London UK
    Posts
    66
    Yep, thats my theory atm, having disabled all of our monitoring the servers now been up for over 3 hours. Previously 10mins was about as long as it would stay up

  10. #10
    Join Date
    July 2008
    Location
    canada
    Posts
    77
    this needs to be Sticky'd and notified if the TS3 development team isnt already on it
    Its across all machines and being reported from many hosts

  11. #11
    Join Date
    March 2003
    Location
    London UK
    Posts
    66
    I reported to the dev's as soon as we spotted it, but I would suspect the're all in bed now, been a hectic few days ;-)

    Hopefully we will see a fix later today.

  12. #12
    Join Date
    December 2009
    Location
    Switzerland
    Posts
    22
    Quote Originally Posted by ginger
    TeamSpeak systems fixed that TS3 server problem. New server version comes later. This guys are fast huh? Yay :mrgreen:
    YaY Soon it will be released !

  13. #13
    Join Date
    July 2008
    Location
    canada
    Posts
    77
    I have patched servers to beta3 , does this fix the TCPSockets select() crash?

  14. #14
    Join Date
    March 2003
    Location
    London UK
    Posts
    66
    Not sure yet, but it does cause lots of log spam with:
    2009-12-21 22:21:31.090700|ERROR |TCPSockets | | invalid socket response, packet discarded, error: 10038

    It also breaks chained commands so querying the server is now much more work than it used to be

    I've now reworked the qstat teamspeak 3 module to use none chained requests and am about to re-enable our monitoring, so figures crossed.

  15. #15
    Join Date
    March 2003
    Location
    London UK
    Posts
    66
    That would be a no, querying all our servers on BETA 3 caused an instant crash.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: October 24th, 2012, 01:58 PM
  2. Replies: 0
    Last Post: September 5th, 2011, 07:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •