Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    December 2009
    nix an!

    Failure during pthread_create

    hi folks!
    every time i try to start the server on my vserver i get this error:

    Logging Started
    2009-12-20 13:16:13.202689|INFO |ServerLibPriv | | Server Version: 3.0.0-beta1 [Build: 9366]
    2009-12-20 13:16:13.209951|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2009-12-20 13:16:13.210117|INFO |DatabaseQuery | | dbPlugin version: 3.6.4
    2009-12-20 13:16:13.288213|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2009-12-20 13:16:13.701736|INFO |FileManager | | listening on
    2009-12-20 13:16:13.705727|CRITICAL| | | Failure during pthread_create
    and than the server is shutting down.
    sometime it works fine and the server starts and is running for 15-20 minutes and than i crashes and after that i need another 100 trys to restart it.

  2. #2
    Join Date
    September 2007
    Calgary Alberta Canada
    SOLVED: see

    My buddy is having the same issues.

    2009-12-22 18:42:26.203422|INFO    |Accounting    |   | max virtualservers: 10
    2009-12-22 18:42:26.205326|INFO    |Accounting    |   | max slots         : 512
    2009-12-22 18:42:26.249990|CRITICAL|              |   | Failure during pthread_create
    We are licensed with NPO. We have multiple IPs on this server.

    One IP is running ts3 server beta 3, 1 VS and 100 users.
    Another IP is running ts3 beta 2, 1 VS, 100 users.

    Another IP were trying to set up.

    Any solutions?

    We solved this by deleting and reinstalling But I would like to know why this happens and what we can do to prevent this

    EDIT #2
    The user we were having issues with was running "Jailshell" ( a gimped shell ) Once we got rid of that we were golden. As always I hope this helped. If this is indeed the cause can OP change topic to [SOLVED] if possible?

    EDIT #3
    Jan 20th 2010. Problem is back for beta 16 32 bit Linux server. No Jail Shell. I am assuming this is a shell issue and not a ts one. But this time more errors.
    "Failure during pthread_create, error = EAGAIN"

    Trace the new part I get this -->

    Try Again

    It is very common to get this error when your application is doing non-blocking operations on files or network sockets. For example, you can open a file/socket/fifo for reading with the O_NONBLOCK flag. If you subsequently do a read(2) call and there is no data waiting, instead of blocking and waiting until there is data ready and returning that data, the read() call will return an error (EAGAIN) to let your application know that there is no data ready and to try again later.

    Another example is if a system call failed due to insufficient resources (such as virtual memory), but it might succeed if called again. (eg fork(2) does this).

    I basically waited it out as I don't have root on my system and all is good. You could either reboot your box, restart the users shell if you had root.
    Last edited by KoldFusion; January 22nd, 2010 at 11:23 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 35
    Last Post: April 4th, 2016, 03:27 AM
  2. Replies: 5
    Last Post: November 18th, 2013, 04:23 PM
  3. [Resolved] Failure during pthread_create 12
    By Zion96 in forum Linux / FreeBSD
    Replies: 8
    Last Post: May 15th, 2011, 12:15 PM
  4. Failure during pthread_create 12 on MySQL startup
    By PlymWS in forum Linux / FreeBSD
    Replies: 1
    Last Post: March 15th, 2011, 08:45 AM
  5. pthread_create failed any solution ?
    By yajur in forum Linux / FreeBSD
    Replies: 0
    Last Post: December 21st, 2009, 07:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts