Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2004
    Posts
    21

    Error Msg "unable to load database plugin"

    Hi.

    I get the following error message after I try to start the server with mysql support:

    2009-12-20 16:19:49.055488|CRITICAL|DatabaseQuery | | unable to load database plugin library, halting!

    I've create the 2 files:
    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    dbplugin=ts3db_mysql
    dbpluginparameter=/home/voiceserver/teamspeak/ts3db_mysql.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mysql/
    logpath=logs
    logquerycommands=1
    [config]
    host=localhost
    port=3306
    username=testing
    password=xxxx
    database=xxx
    socket=mysql
    Somebody an idea?

  2. #2
    Join Date
    December 2009
    Location
    Netherlands
    Posts
    9
    I had the same error yesterday. What helped me was using
    Code:
    ldd libts3db_mysql.so
    I found out i had to install an extra library.

    Installing "libmysqlclient15off" solved the problem.

  3. #3
    Join Date
    December 2009
    Location
    Danbury, CT
    Posts
    3

    Question

    Can anyone expand on how to fix this. I have the exact same problem as the OP and really am struggling to figure out what needs to be done now to get the server to load for the first time. I tried the above ldd command, and it seemed to mostly work, except it said it could not find "libmysqlclient15off". Not sure where to go from here, any and all help would be appreciated! Thanks!

  4. #4
    Join Date
    March 2009
    Location
    USA
    Posts
    20
    The solution is to install the older (or newer) client libraries.

    Once place to find them is (for distros that can handle rpms):
    (x86) http://rpm.pbone.net/index.php3/stat....i586.rpm.html
    (x86_64) http://rpm.pbone.net/index.php3/stat...86_64.rpm.html

    Those rpms have all the library files (including the one ts3 needs)
    Last edited by aeular; December 21st, 2009 at 02:26 AM.

  5. #5
    Join Date
    December 2009
    Location
    lutz
    Posts
    39
    Quote Originally Posted by Pruitt View Post
    Can anyone expand on how to fix this. I have the exact same problem as the OP and really am struggling to figure out what needs to be done now to get the server to load for the first time. I tried the above ldd command, and it seemed to mostly work, except it said it could not find "libmysqlclient15off". Not sure where to go from here, any and all help would be appreciated! Thanks!
    Depends on your distribution. search your distro's repository for the missing library. The previous post mentioned a red hat distro. for Debian based look here. Choose your architecture and download the file with wget...then run "dkpg -i packagename"

  6. #6
    Join Date
    September 2007
    Location
    Calgary Alberta Canada
    Posts
    109

    Exclamation

    Quote Originally Posted by Fraq! View Post
    I had the same error yesterday. What helped me was using
    Code:
    ldd libts3db_mysql.so
    I found out i had to install an extra library.

    Installing "libmysqlclient15off" solved the problem.
    Same issue.
    my readout...

    Code:
    [[email protected] teamspeak3-server_linux-x86]$ ldd libts3db_mysql.so
            libmysqlclient.so.15 => not found
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00111000)
            libm.so.6 => /lib/tls/libm.so.6 (0x00ca8000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x001dc000)
            libc.so.6 => /lib/tls/libc.so.6 (0x0025f000)
            /lib/ld-linux.so.2 (0x00460000)
    As I dont have root I can't do anything about this. Needing root for installs like this only create TONS of support posts.

    Love the new TS3 but the last two days have been utter /facepalm

    To fix this on Ubuntu if thats your flavor
    Code:
    sudo apt-get install libmysqlclient15off
    might work?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: October 17th, 2014, 03:33 AM
  2. Replies: 15
    Last Post: June 20th, 2012, 01:51 PM
  3. [Resolved] unable to load database plugin library "libts3db_mysql.so", halting!
    By PoL4K in forum Linux / FreeBSD
    Replies: 10
    Last Post: March 15th, 2012, 07:29 PM
  4. Replies: 5
    Last Post: April 1st, 2010, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •