Forum

Results 1 to 5 of 5

Thread: Lua Question

  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    3

    Lua Question

    Hello, I have a Question to the Lua Plugin in Teamspeak 3.

    I have wrote a Hello World Lua Script in a external file.

    I try to load it with /lua load helloworld but i get a error message:
    Error loading lua script: C:/Program Files/TeamSpeak 3 Client/scripts/helloworld
    even with filtype .lua i become these error

    why i can`t load my script ?

    Sorry for my bad English

  2. #2
    Join Date
    December 2009
    Location
    Germany - Near Berlin
    Posts
    13
    Post pls the Code of your LUA File.

    -Flaver 'hooK'

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    3
    PHP Code:
    function helloworld(serverConnectionHandlerID)
        
    ts3.printMessage(serverConnectionHandlerID"Hello World")
    end 
    Its a simple Hello World ^^

  4. #4
    Join Date
    December 2009
    Location
    Germany - Near Berlin
    Posts
    13
    Hmm I would say youve forgot to write the require's

    PHP Code:
    require("ts3defs")
    require(
    "ts3errors"
    Write these in the Top of your Script.

    I hope i could help

    -Flaver 'hooK'

  5. #5
    Join Date
    December 2009
    Location
    Germany
    Posts
    3
    yes i have forgotten it thx

    it works

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •