Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 6 of 6
  1. #1
    Join Date
    November 2009
    Location
    No
    Posts
    37

    Unable to start server as non-root user on VPS

    Running the server as root gets results, everything loads fine. But as a regular user I am getting the following error:


    Code:
    [[email protected] teamspeak]$ ./ts3server_linux_x86 
    Logging Started
    2009-12-19 16:40:51.906118|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta1 [Build: 9366]
    2009-12-19 16:40:51.906533|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2009-12-19 16:40:51.906598|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.4
    2009-12-19 16:40:51.916629|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2009-12-19 16:40:52.118991|ERROR   |Accounting    |   | failed to register accounting service
    2009-12-19 16:40:52.119800|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    As stated in the title, this is on a VPS. I saw several other posts on outside websites (though they were in german) describing the same issue on the same platform.

    Could this be something to do with it being a monolithic kernal environment?

    This is a Virtuozzo VPS, if that helps.

    edit:

    Similar thread is here sorry I missed it, this can be merged into it if needed to keep issues organized.

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    its quite easy to fix it:

    delete the file in /dev/shm/ how it is described there.

    To find the correct file start ts3 with the follow commando:

    Code:
    s01:/usr/local/teamspeak3-server_linux-amd64# su --shell=/bin/bash --command="strace ./ts3server_linux_amd64 inifile=ts3server.ini" teamspeak
    (where teamspeak is the user.. change the server parameter how you need them)

    than search for the line:
    Code:
    unlink("/dev/shm/7gbhujb54g8z9hu43jre8") = -1 EPERM (Operation not permitted)
    this is the file with the wrong permission... it just get recreated with right permission.. so just delete it and run ts3 never again with root ;-)

  3. #3
    Join Date
    December 2008
    Location
    Chicago
    Posts
    15
    So I got very similar problem:
    [email protected] [~/ts3]# ./ts3server_linux_x86
    Logging Started
    2009-12-20 02:23:11.036066|INFO |ServerLibPriv | | Server Version: 3.0.0-beta1 [Build: 9366]
    2009-12-20 02:23:11.036637|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, (c)TeamSpeak Systems GmbH
    2009-12-20 02:23:11.036727|INFO |DatabaseQuery | | dbPlugin version: 3.6.4
    2009-12-20 02:23:11.178823|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2009-12-20 02:23:11.179913|ERROR |Accounting | | failed to register accounting service
    2009-12-20 02:23:11.180387|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance check error
    However I dont see it being permissions problems.
    [email protected] [~/ts3]# ls /dev/shm
    ./ ../
    [email protected] [~/ts3]#

    [email protected] [~/ts3]# strace ./ts3server_linux_x86 2>&1|grep -E "EPERM|unlink"
    [email protected] [~/ts3]#
    As far as I understand you can't run the server without license at all. Is that right? And no, my ssh login is not root.
    Last edited by JenDen; December 20th, 2009 at 06:41 AM.

  4. #4
    Join Date
    June 2008
    Location
    ca
    Posts
    22
    I have a OpenVZ vps and i try to run teamspeak 3 server as root but it still doesn't work.

    Is this a bug in ts server or a compatibility issue with vps environments?

  5. #5
    Join Date
    December 2009
    Location
    NY - USA
    Posts
    11

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    14
    Look there: http://forum.teamspeak.com/showthrea...594#post202594

    I analysed it with Purespider over TS Chat and found the problem.
    Last edited by Merld; December 21st, 2009 at 01:45 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: March 9th, 2015, 10:58 PM
  2. [Resolved] Can't start server as not-root user
    By HerrAusragend in forum Linux / FreeBSD
    Replies: 2
    Last Post: January 29th, 2015, 06:19 AM
  3. Replies: 0
    Last Post: May 4th, 2011, 02:22 AM
  4. Replies: 1
    Last Post: April 7th, 2010, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •