Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 3 of 11 FirstFirst 12345 ... LastLast
Results 31 to 45 of 160
  1. #31
    Join Date
    February 2008
    Location
    Wisconsin
    Posts
    53
    @ Mancert

    Thank you for your patience and assitance!

    I got frustrated last night and just hung it up. This AM, I sat down and everything worked as soon as I turned on the server. Go figure.

    I didn't understand path as just a directory path but the entire path statement including the file to be launched. I dont know why I poped the archive open in that directory, it should have been one deeper for the sake of orderlyness. Oh well. I'll fix it another time.

    Thanks again!
    Last edited by lawndart; December 22nd, 2009 at 03:31 PM.

  2. #32
    speeker Guest
    Quote Originally Posted by Hakaori View Post
    I created a teamspeak user using "adduser teamspeak", changed into the user and went to /home/teamspeak/
    Did you change the script to reflect that it is /home/teamspeak for
    TS3= location of teamspeak directory?
    I started the server as root and used the token found in /logs.
    Right there stop. You need two items, one is in logs, but the other is on the screen. You need the single admin token, PLUS the databaseuser/pass.

    Since you started as root, other users cannot run the server because of a file that teamspeak creates in /dev/shm. See end for instructions.

    The teamspeak server unfortunately stops immediately when I quit PuTTy.
    Yes, that is why you want to use this script.
    Temporarily you can do ./ts3server_blah_blah &
    the & will keep it running.

    I went to /etc/init.d/ and typed "nano teamspeak" and copy/pasted
    your script into the file and saved it.
    Correct. See last on permissions.

    I then went to /etc/rc0.d/ and created "rc.local" and entered "/etc/init.d/teamspeak start"
    I was suprised to see many "rc?.d" folders, so I just chose the first one "rc0.d". Was that right?
    I checked my ubuntu vm and didn't see why you would create rc.local.
    in /etc you should see rc0.d-rc6.d (folders) and rc.local. In rc.local create the ./etc/init.d/teamspeak start.
    I don't see an rc.local_shutdown in ubuntu, so do what I wrote earlier.

    Here is a link explaining the different rc's.
    http://www.linux.com/news/enterprise...nd-rcd-scripts

    I created "rc.local_shutdown" and copied "/etc/init.d/teamspeak stop" into it.
    I don't think this will work if ubuntu didn't already create it..

    I looked into /home/teamspeak/teamspeak3_server_x64/ for a PID file but couldnt find it.
    I went back to /etc/init.d/ and tried starting the script, but it said
    "Missing permission" so I typed "chmod -x teamspeak"
    Now I get the following error message:
    [email protected]:/etc/init.d# teamspeak start
    The program 'teamspeak' is currently not installed. You can install it by typing:
    apt-get install teamspeak-client
    bash: teamspeak: command not found
    [email protected]:/etc/init.d# damn you
    Ok lets talk permissions. Log in as root.
    your /home/teamspeak
    chown -R teamspeak:users /home/teamspeak

    your /etc/init.d script
    chmod 755 /etc/init.d/teamspeakscript

    Go to /dev/shm delete a file if there is one that is long random alpha/numeric.

    Now su teamspeak
    go to /home/teamspeak
    ./ts3server_blah_blah clear_database=1
    This will reset the database and give you the token + the password, highlight these (putty auto copy these) then paste in a text doc on your desktop. the admin token is one use, but the databaseuser is forever.

    cntrl C the server.
    now type exit

    You will be back as root.
    Go to /etc/init.d
    do ./teamspeak start

    see if it starts.

    type ps aux | grep ts3 to see if it is running.

  3. #33
    speeker Guest
    Quote Originally Posted by mancert View Post
    Only problem I've encountered my selves so far, is if there is a power shortage. Then the .pid file will still be in $TS3 folder and server will not start at boot up. I will see if I can sort something out for that, or if anyone else is willing please have a go.

    -mancert-
    Try something like this in script?
    prior to starting the server
    if ts3server_* is running, end script.
    if ts3server_* is not running, rm $TS3/*.pid
    Then start script.

  4. #34
    speeker Guest
    Quote Originally Posted by mancert View Post
    Only problem I've encountered my selves so far, is if there is a power shortage. Then the .pid file will still be in $TS3 folder and server will not start at boot up. I will see if I can sort something out for that, or if anyone else is willing please have a go.

    -mancert-
    Try something like this in script?
    prior to starting the server
    Code:
    service_start() {
    if ts3server_* is running,
    then end script with echo server already running.

    elseif ts3server_* is not running,
    then rm $TS3/*.pid

    continue on starting

  5. #35
    Join Date
    December 2009
    Location
    Berlin
    Posts
    40
    Edit by mod
    Please don't use this outdated script anymore! The script got an overhaul long time ago.
    Please use the minimal or startscript instead


    Thank you so very much for your help speeker, god bless you. I adhered to your advice and it seemed to work, but I somehow still cannot connect to the server using the ts3 client.

    [email protected]:/etc/init.d# ./teamspeak start
    -e Can't start TeamSpeak 3 Server. Server is already running.


    But I cannot connect to the server using the TS3 client. When I try to stop the client using "./teamspeak stop", it says:

    [email protected]:/etc/init.d# ./teamspeak stop
    Stopping TeamSpeak 3 Server
    TeamSpeak 3 Server stopped


    But when I try to start it again it says:

    [email protected]:/etc/init.d# ./teamspeak start
    -e Can't start TeamSpeak 3 Server. Server is already running.


    edit:
    aux says:

    [email protected]:/etc/init.d# ps aux | grep ts3
    root 4670 0.0 0.0 3008 748 pts/0 R+ 16:05 0:00 grep ts3



    This is the relevant part of the script, I entered. I did not make any changes because I extracted the archive in /home/teamspeak to /home/teamspeak/teamspeak3-server_linux-x86


    #!/bin/sh
    #Teamspeak 3 startup script

    #Server options
    TITLE='TeamSpeak 3 Server'
    NAME='ts3' # Name for screen session
    DAEMON='ts3server_linux_x86' # Server binary, here the 32bit
    TS3='/home/teamspeak/teamspeak3-server_linux-x86' # Path to ts3 binary
    USER='teamspeak' # User running server
    USERG='users' # Usergroup of user

    #Screen command
    INTERFACE="/usr/bin/screen -A -m -d -S $NAME"


    I added
    Code:
    ./etc/init.d/teamspeak start
    to rc.local as well as deleted the PID in /dev/shm.
    When I manually start the server it works fine.
    Last edited by dante696; March 3rd, 2011 at 09:27 AM.

  6. #36
    Join Date
    February 2008
    Location
    Wisconsin
    Posts
    53
    Make sure that this...

    Code:
    TS3='/home/teamspeak/teamspeak3-server_linux-x86' # Path to ts3 binary
    ... is the path to the directory and not the entire path including execuatable. My whole problem was I had the path wrong.

  7. #37
    Join Date
    February 2008
    Location
    Wisconsin
    Posts
    53
    @ Speeker and Mancert

    Can you please clearly explain what needs to be done for the server restart on a power failure. This stuff is all quite over my head and I am delighted and surprised to even have it working as well as I do (in spite of my self).

    Quote Originally Posted by speeker View Post
    Try something like this in script?
    prior to starting the server
    if ts3server_* is running, end script.
    if ts3server_* is not running, rm $TS3/*.pid
    Then start script.

  8. #38
    Join Date
    February 2008
    Location
    Wisconsin
    Posts
    53

    if a script is changed...

    If a script is changed, does this need to be done again?


    Code:
    update-rc.d -f ts3 defaults

  9. #39
    speeker Guest
    Quote Originally Posted by Hakaori View Post
    Thank you so very much for your help speeker, god bless you.
    You're Welcome!

    [email protected]:/etc/init.d# ./teamspeak start
    -e Can't start TeamSpeak 3 Server. Server is already running.
    This is caused by the .pid still being in /etc/teamspeak. Check that it is removed before you try it.
    if [ ! -f $TS3/$NAME-screen.pid ]; then
    means if NOT .pid present then continue.

    But I cannot connect to the server using the TS3 client. When I try to stop the client using "./teamspeak stop", it says:

    [email protected]:/etc/init.d# ./teamspeak stop
    Stopping TeamSpeak 3 Server
    TeamSpeak 3 Server stopped
    The process stopped, it only looks if the .pid is present to tell you that.

    But when I try to start it again it says:

    [email protected]:/etc/init.d# ./teamspeak start
    -e Can't start TeamSpeak 3 Server. Server is already running.


    edit:
    aux says:

    [email protected]:/etc/init.d# ps aux | grep ts3
    root 4670 0.0 0.0 3008 748 pts/0 R+ 16:05 0:00 grep ts3
    aux is showing that you only have the ps aux grep going, not the ts3sever_etc. So the server is NOT running because of the pid.

    This is the relevant part of the script, I entered. I did not make any changes because I extracted the archive in /home/teamspeak to /home/teamspeak/teamspeak3-server_linux-x86


    Code:
    #!/bin/sh
    #Teamspeak 3 startup script
    
    #Server options
    TITLE='TeamSpeak 3 Server'
    NAME='ts3'                                              # Name for screen session
    DAEMON='ts3server_linux_x86'                            # Server binary, here the 32bit
    TS3='/home/teamspeak/teamspeak3-server_linux-x86'       # Path to ts3 binary
    USER='teamspeak'                                        # User running server
    USERG='users'                                           # Usergroup of user
    
    #Screen command
    INTERFACE="/usr/bin/screen -A -m -d -S $NAME"
    I added
    Code:
    ./etc/init.d/teamspeak start
    to rc.local as well as deleted the PID in /dev/shm.
    TS3= is probably wrong.
    as root go cd /
    then go to your teamspeak directory using cd /what/where
    Whatever you put as /what/where after cd, is what TS3= should be.
    /home/teamspeak or /etc/teamspeak3 or whatever.

    When I manually start the server it works fine.
    This is because the server doesn't check for the pid, only for a running instance id. The script creates the .pid to tell if it is running already.

    Did you start as root or teamspeak? If root, go into /dev/shm and remove it again.

  10. #40
    Join Date
    December 2009
    Location
    Berlin
    Posts
    40
    I hope I am not absolutely stupid, but I think my path is correct:


    Code:
    [email protected]:/# cd /home/teamspeak/teamspeak3-server_linux-x86
    [email protected]:/home/teamspeak/teamspeak3-server_linux-x86# ls
    CHANGELOG  libts3db_mysql.so    logs             ts3-screen.pid
    doc        libts3db_sqlite3.so  serverquerydocs  ts3server_linux_x86
    files      LICENSE              sql              ts3server.sqlitedb
    [email protected]:/home/teamspeak/teamspeak3-server_linux-x86#

    Code:
    [email protected]:/dev/shm# cd /etc/teamspeak
    -bash: cd: /etc/teamspeak: No such file or directory
    [email protected]:/dev/shm# dir
    [email protected]:/dev/shm#
    Still no luck starting it, thanks again

  11. #41
    Join Date
    December 2009
    Location
    Berlin
    Posts
    40
    I deleted the ts3-screen.pid in the /home/teamspeak/blabla directory and now i get:

    Code:
    [email protected]:/etc/init.d# ./teamspeak start
    Starting TeamSpeak 3 Server
    bash: /usr/bin/screen: No such file or directory
    TeamSpeak 3 Server screen process ID written to /home/teamspeak/teamspeak3-server_linux-x86//ts3-screen.pid
    TeamSpeak 3 Server started.
    [email protected]:/etc/init.d#
    But still hasnt started to my knowledge

  12. #42
    speeker Guest
    Quote Originally Posted by Hakaori View Post
    I hope I am not absolutely stupid, but I think my path is correct:


    Code:
    [email protected]:/# cd /home/teamspeak/teamspeak3-server_linux-x86
    [email protected]:/home/teamspeak/teamspeak3-server_linux-x86# ls
    CHANGELOG  libts3db_mysql.so    logs             ts3-screen.pid
    doc        libts3db_sqlite3.so  serverquerydocs  ts3server_linux_x86
    files      LICENSE              sql              ts3server.sqlitedb
    [email protected]:/home/teamspeak/teamspeak3-server_linux-x86#
    Still no luck starting it, thanks again
    Np just wanted to make sure the TS3 is right, the /home/teamspeak/teamspeak3-server_linux-x86 is unwieldy to type, I always shorten it to just /home/teamspeak or /etc/teamspeak.

    I see in your /home/teamspeak/teamspeak3-server_linux-x86 is
    ts3-screen.pid
    that is the pid that is stopping it from starting. The pid is created in the ts3 directory every time the script is given the start command.
    Delete the pid, and try ./etc/init.d/teamspeak start

    If it still won't work pm me and I can ssh into system to figure out why it won't start.

  13. #43
    Join Date
    December 2009
    Location
    Berlin
    Posts
    40
    Woops, I think I posted before you had a chance to read it. I deleted that file, but it somehow still does not start, something about


    Code:
    [email protected]:/etc/init.d# ./teamspeak start
    Starting TeamSpeak 3 Server
    bash: /usr/bin/screen: No such file or directory
    TeamSpeak 3 Server screen process ID written to /home/teamspeak/teamspeak3-serve                   r_linux-x86//ts3-screen.pid
    TeamSpeak 3 Server started.
    [email protected]:/etc/init.d# ps aux | grep ts3
    root      4832  0.0  0.0   3008   760 pts/0    S+   18:00   0:00 grep ts3
    [email protected]:/etc/init.d#

  14. #44
    Join Date
    August 2005
    Location
    Nederland
    Posts
    56
    Do 'yum install screen' and try again

    A question:

    I'm getting an empty .pid and the following error:

    Code:
    2009-12-22 18:31:07.679782|ERROR   |Accounting    |   | failed to register accounting service
    2009-12-22 18:31:07.680162|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    Anybody know how to solve this error?

    + I'm getting 00.00.00.00 ips in the log files, proper ip is listed in the server.ini file. How do I make this script load the server.ini file?

  15. #45
    Join Date
    December 2009
    Location
    Berlin
    Posts
    40
    THANKS !!! yum is not available for Ubuntu, but apt-get install screen solved my problem!

    Huge thanks go out to speeker and hollander its working now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak 3 Server Startup Script
    By Griffen8280 in forum Tools / Web Based
    Replies: 1
    Last Post: January 15th, 2012, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •