Forum

Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 48
  1. #31
    Join Date
    April 2014
    Posts
    1

    Cannot set up hotkeys using multiple keyboard keys.

    The newest version of OS X 10.9.2 does not allow TS3 to come up as an app in Security & Privacy>Privacy>Accessibility. I can not set up hotkeys using combos like ctrl+f13 etc. I can only use single keys (option, shift, command, 1 or 2 more).

    I must been missing something obvious...

    Help. Please.

  2. #32
    Join Date
    June 2008
    Posts
    17,942
    I am not sure what How to this is, but you are in the wrong menu.
    This has nothing to to do with security settings.

    Quote Originally Posted by PeterS View Post
    - Open System Preferences
    - Universal Access
    - "Enable access for assistive devices" (on bottom)
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #33
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,510
    Quote Originally Posted by dante696 View Post
    I am not sure what How to this is, but you are in the wrong menu.
    This has nothing to to do with security settings.
    Actually, he is looking in the right place. In newer OS X versions, the privacy setting is exactly what you need. However, this doesn't always work.

    Try to drag the TeamSpeak 3 app bundle into that list again (even if it's already in there) and restart the client... that fixed the problem for me.

    http://250kb.de/u/140424/p/DhKq4gH84EC4.png

  4. #34
    Join Date
    June 2008
    Posts
    17,942
    Thank you for that hint.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #35
    Join Date
    July 2010
    Location
    Texas
    Posts
    10

    Unable to bind irregular keys like ` on Mac 10.9 using TS 3.0.14

    10.9 Changed the Universal Access ---> Enable Access for assistive devices

    The is the new place for it:

    System Preferences --> Security & Privacy --> Privacy Tab --> Accessibility Options

    Apps must be registered here to have access to your computer. And TS 3.0.14 is not registered here as an assistive device

    So TS 3.0.14 is not completely compatible with Mac OS X 10.9.

    The Warning in HotKeys under TS Preferences is now incorrect -->
    To be able to use hotkeys on Mac, you need to open the System preferences
    "Universal Access" page and make sure "Enable access for assistive devices"
    is turned on.


    This means, I cannot bind most of the keys on the keyboard. such as the "tilde" key next to the "1" and above the "Tab"

    my hands rest not he KB in such a way that this key is best for Push-to-Talk, but I can't register it through the TS HotKeys Settings because it doesn't have access to the letter and number keys on the Mac Book KB
    Attached Images Attached Images  

  6. #36
    Join Date
    June 2014
    Posts
    1
    Hey!

    I have the same probleme as everyone except that in Universal Acces I don't have the TeamSpeak3 icon, I only have Skype and Steam. Do you know how can I put TS3 there to activate it ?
    Click image for larger version. 

Name:	ts3.png 
Views:	447 
Size:	100.9 KB 
ID:	10726
    Last edited by SoAir; June 15th, 2014 at 03:00 PM.

  7. #37
    Join Date
    June 2008
    Posts
    17,942
    This was explained 2 post before...

    Pleae read Post #1 or Post #33
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #38
    Join Date
    July 2014
    Posts
    2

    Numpad hotkeys not working after latest update.

    Hi everyone, as the title says, the hotkey i had on my numpad (the one on the left of they keyboard) does not work after the latest update.
    Here are some infos:
    Ts3 client: Version 3.0.15.1 (14/07/14 14:31:32)
    I'm running Mac os X Yosemite on 10.9.4.
    The hotkey worked before the update; nothing changed on my part to make it stop working.

    So... help?

  9. #39
    Join Date
    July 2014
    Posts
    3
    Since the latest update mostly no keys at all may be assigned for push-to-talk.

    OS X Maverics (fully updated to current version)

    Variant A:
    - Start TS3 client
    - cmd+;
    - go to hotkeys
    - assign "<" as "Push-to-Talk ("Standard")"
    - login to any server
    - Result: "<" does not work as p2t key

    Variant B:
    - Start TS3 client
    - login to any server
    - cmd+;
    - go to hotkeys
    - assign "<" as "Push-to-Talk ("Standard")"
    - Result: "<" cannot be assigned as p2t key
    ... though "cmd" and "ctrl" buttons may be assigned as p2t key


    Sidenote:
    - Shift + Tab (up) can't be assigned either as default "Toggle Microphone Mute"

    -----

    Edit: No connection to sticky on global hotkeys issue as far as I can see.
    Edit2: Only ctrl, option, cmd, shift (left), shift (right) and "fn" key may be assigned for push 2 talk. Any other key may not be assigned.

  10. #40
    Join Date
    July 2014
    Posts
    2
    I found a solution:
    Just remove all hotkeys and redo everyone of them :/

  11. #41
    Join Date
    July 2014
    Posts
    1
    I tried remapping my hot key for PTT (~), but it was not recognising most keyboard keys at all.

    We had to kill the process in the terminal to allow it to access the keyboard.

    Restarting the application again killed access to the keyboard. I have to restart the computer to get control back.

  12. #42
    Join Date
    July 2010
    Location
    Texas
    Posts
    10
    I have the Tilde ~ mapped from older versions. Since the newer versions don't recognize that key at all. but now it's not working.

    I ran some more testing and setup a new hotkey profile

    Settings -> HotKeys -> Press the Green Plus to add New Profile -> Name it and Chose first Radio button "Default Settings" for a blank slate.

    Assigned "fn" key on the extended Apple KB. (seems to work)

    It seems TeamSpeak hasn't updated to 10.9 compatibility because I still get a warning to go to Sustem Preferences, Universal Access and turn on access for assistive devices. Apple moved this to Security and Privacy --> Privacy Tab --> Choose Accessiblity Setting on the left. Then drag & Drop the TS3 Client in the App list on the Right.
    Click image for larger version. 

Name:	Screen Shot 2014-07-19 at 6.43.31 PM.png 
Views:	771 
Size:	90.8 KB 
ID:	10979


    However, Apple has some measures in to prevent Keyloggers from unidentified Apps and I think TS3 is UnIdentified from the Apple Dev Network. So it probably won't get to access key bindings from any of the "Input Source" Keys

    Click image for larger version. 

Name:	Screen Shot 2014-07-19 at 6.45.05 PM.png 
Views:	405 
Size:	59.8 KB 
ID:	10980
    Last edited by Twintails; July 20th, 2014 at 12:48 AM. Reason: More testing and information

  13. #43
    Join Date
    July 2010
    Location
    Texas
    Posts
    10
    Quote Originally Posted by MrDre Drizzle View Post
    The newest version of OS X 10.9.2 does not allow TS3 to come up as an app in Security & Privacy>Privacy>Accessibility. I can not set up hotkeys using combos like ctrl+f13 etc. I can only use single keys (option, shift, command, 1 or 2 more).

    I must been missing something obvious...

    Help. Please.
    Drag and drop the app from your applications folder into the Right side. (all keys still don't work, but this gets the app access it needs.)

  14. #44
    Join Date
    July 2014
    Posts
    3
    My solution so far:
    - open system prefs -> security & privacy -> accessibility -> unlock
    - open finder -> open applications folder -> drag & drop teamspeak 3 application into accessibility window
    - launch ts3 from finder

    Not the best way. But keyboard shortcuts are working this way, again.
    Hope there'll be a patch very soon.

  15. #45
    Join Date
    January 2016
    Posts
    4

    Keys are not recognized by client

    I attempted to use keys including letters, forward slash, and tilde as my mute key and none of them are recognized. I am able to use the Alt key, but hardly anything else is recognized. I updated a client last night and noticed the functionality loss this morning (7 April 2016 ~noon)
    Specs:
    OS X El Capitan V. 10.11.3
    MacBook Pro (17-inch, Late 2011)
    TeamSpeak 3:
    Version 3.0.19 (4/1/16 04:48:51)
    Qt Version: 5.5.1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Teamspeak 3 disables my media player's global hotkeys?
    By chaosglory in forum Windows
    Replies: 0
    Last Post: April 19th, 2015, 01:41 PM
  2. [Resolved] Hotkeys not working
    By Jolle in forum General Questions
    Replies: 20
    Last Post: May 29th, 2014, 01:17 PM
  3. Hotkeys not working?
    By DanTheHumann in forum General Questions
    Replies: 0
    Last Post: December 14th, 2013, 06:10 PM
  4. None of my hotkeys are working...
    By McJamesV in forum Windows
    Replies: 3
    Last Post: February 27th, 2012, 10:14 AM
  5. Replies: 0
    Last Post: September 8th, 2010, 04:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •